Aqara Curtain Driver E1

Great, I reset and deleted both devices then re-added them thinking I would be starting over… now neither has the reverse control lol :frowning: UGHHH

So I got my left and right curtain motor setup and they seem to have good open and close positions… Only problem is, they are reversed, so when I open them, HA says they are closed and when they are physically closed, HA says they are open. I still don’t see the Configuration section on the device for either now :frowning:

You are using ZHA? What version of HA?

I have using ZHA, on the latest stable releases,

Home Assistant 2022.8.7
Supervisor 2022.08.5
Operating System 8.5
Frontend 20220802.0 - latest

Also fyi, when I go to add it/pair it, this is what it detects,

LUMI lumi.curtain.agl001

Might be best to enable debug logging, re-pair and submit an issue on GitHub.

Are your open and close states matched to your open and close buttons? Oddly enough if my curtains are closed and it’s status says closed, then slide the slider to the right to a value of 100 to open them, it works fine. But in that same scar io but hit the open button itself, it tries to close them again, it’s like the slider and status are good, but the open and close button are backwards?? I’ll post some bugs… hopefully it will help improve the integration

I have noticed the same thing with z2m. Using service calls to open/close work best for me.

I did the other way round. I first make sure the driver is in full closed position, triple click the button and it will move slightly till it hits the stop position and sounds a long beep. Then, I manually pull the curtain all the way to fully open position that I want and it will sound another long beep and this will be my full opened range.

This is how I set the travel range and I only have one driver at the moment. The second one is in shipment. But I think the same procedure should apply even with dual drivers according to the manual.

I did find the manual tells the different thing as it says it will move itself towards the full opened position and set the opened position when you pulled the curtain by ~10cm. For my case, it didn’t move and I have to manual pull them.

Hope it helps.

I have a couple of these and can answer a few of the questions on this thread:

  1. Yes when these are setup and configured without the aquara hub manual control works fine (you tug on the curtain and they open / close)
  2. you can set the direction of the curtain in the zigbee2mqtt settings:

I am really struggling to get them setup correctly though. The travel calibration without the aqara hub really seems to not work properly. I have either got into a state where the driver stops about 1" short leaving a 2" gap in the middle of my curtain pair when they are closed or there is no calibration and each driver runs for around 30 seconds after it has reached either end of the pole just spinning the wheel on the bar.

I also have issue with the wheel slipping on the bar…

I decided to return these. Too many problems for example with the wheel slipping. I finally got them paired with the Aqara E1 hub though, which helped a lot. Apparently it required three (!!) consecutive firmware upgrades to the hub. After the first it didn’t cross my mind that it would not upgrade it straight to the newest version.

In the end my main problem however was with the U-track I have. Here in Finland we basically don’t have U-tracks big enough for rollerglides. Maybe for commercial use, but they are too expensive. Without rollers the friction / load seems to get too big for the motor when closing the curtains.

Are you using the Aqara E1 USB hub? If yes, can the E1 hub be integrated to HA?

I’m thinking to get this hub also to be easier to work with this curtain driver and also the FP1 sensor. Plus, it can offer firmware upgrade also.

Currently I’m using them with z2m.

For those having issues getting these setup, ill just offer my experience after getting two more of these.

  1. I just have them paired with ZHA, but non of them have the reverse option in the settings (if you look back at my posts, one did for a little while until I re-paired it). not exactly sure why ZHA doesn’t have this option but apparently its a bug.

  2. When installing them, I followed this procedure.
    a. Pair the device to ZHA
    b. Close your curtain
    c. Lower the extension hook by double tapping the button
    d. Attach the Curtain Driver to the little mounting piece that goes over the rail and with the curatin still full closed, double tap the button to raise the mounting hooks.
    e. Once fully raised I triple click the button which I think sets the end (or start point depending on how you think about it).
    f. Last I pull the curtain gently to open the curtain and the motor driver should start opening the curtain and then set the maximum position from that.
    g. Now the tricky part, because I can’t inverse the driver in entity settings, if you find the device lists itself as open when its closed or vice versa, you have to essentially reverse how it works physically, this involves flipping the device by lowering the hooks and reattaching it, but also flipping what was the open and closed position… this really isn’t intuitive but it works to say the least.

I find this gets the job done, again its not perfect. If the entity driver were fixed to allow me to invert it more easily that would be great. Also the button to open and close does not work, only the position slider… so the drivers need some work to say the least :(. But it now works and I can open and close my curtains!

The first position where you do the tripe click, it is always the full closed position. In order words, it will register the position to 0% as closed. Then, you pull the curtain and it will open till the end and register as 100% as open.

For z2m, we do have the inverse option. But for you case, can you setup the travel limits in inverse? Then you don’t have to flip the curtain driver manually and you will get the correct reporting in ZHA.

I have two of these drivers now and use them to open my left and right curtains and I don’t have to configure any of the driver to be inverse in the z2m. I just set the travel limits differently for each of the drivers.

I think the problem with doing the initial triple click in the opposite manner would mean that HA would think when its open its actually closed, and when its closed it will think its open because you are doing the initial triple click to set 0 in the open position which actually should be the closed position.

FWIW, I initially had problems with the wheel slipping. I realized the track it was running on was really smooth. I wiped it off with some rubbing alcohol (presumably some residual grease or something from the factory) which helped, then I also scuffed the surface with 60-grit sandpaper, which really helped

1 Like

I second this! Wiping with alcohol did not help much but slightly sanding the rail surface helped a lot!

Sorry if this shouldn’t be here, but I currently have 4 of these Curtain Driver E1 devices (firmware 0.0.0_0024) connected via Zigbee2MQTT (1.28.0) to HA (currently 2022.9.7).

I keep on getting the following errors in my HA log:

Logger: homeassistant.helpers.template
Source: helpers/template.py:582
First occurred: 10:57:32 (26 occurrences)
Last logged: 12:09:16

Template variable warning: 'dict object' has no attribute 'motor_state' when rendering '{{ value_json.motor_state }}'
Template variable warning: 'dict object' has no attribute 'motor_state' when rendering '{% if not value_json.motor_state %} stopped {% else %} {{ value_json.motor_state }} {% endif %}'

I have previously created an issue for this Xiaomi ZNCLBL01LM: Template variable warning: 'dict object' has no attribute 'motor_state' when rendering '{{ value_json.motor_state }}' · Issue #14023 · Koenkk/zigbee2mqtt · GitHub, and added the motor_state to the template Added 'pause' motor_state for lumi.curtain.agl001 by buhito81 · Pull Request #4673 · Koenkk/zigbee-herdsman-converters · GitHub which has become part of the Zigbee2MQTT release 1.28 - but I’m still getting this error.

Does anyone else experience this too?

Nope. This is not how it works in z2m. When you do triple click at closed position, it will register as 0 and you pull the curtain towards to open position and it will move all the way to open and register that to 100.

So it will remember which direction it will move as open.

Anyone having the same?

I managed to set mine up ok, all pretty straight forward really . My issue is the lumi sensor doesn’t show up in HA and apparently it does have one. I am very low down in the food chain when I comes to all this stuff so any help would be appreciated. Thanks