Aqara devices unstable on Dongle-E

Hi all, ive been running zigbee2mqtt with a Sonoff Dongle-E flashed to the latest stable version known to work well with z2m and zha. Zigbee has been a bit of a mixed bag for me, and then particularly with my Aqara devices. They run like a dream for a while and then suddenly seem to drop off the network, having to reconnect them again, which is a pain, especially those P1 PIRs.

I was wondering – is it worthwhile to get one of those Aqara Hub M2 or something like it and have my Aqara devices connect to that to help with stability? I’ve come to the point I’d rather replace them all together, but that feels like a waste. Even my dirt cheap Tuya PIRs have been rock solid and performing like champs.

Don’t get me wrong - when they work they work perfectly, but it’s more like a waiting game to see when they will disconnect again…

Some people have reported better luck with the ZBDongle-P model when got devices manufactured by Aqara/Xiaomi and Tuya →

Regardless suggest that you also consider buying a few (recommend three or more) known good Zigbee Router devices (like example IKEA Tradfri Signal Repeater or flash Zigbee Coordinator dongles to use in USB-changers) + follow → Guide for Zigbee interference avoidance and network range/coverage optimization

As mentioned there, changing to a other Zigbee channel sometimes help with some devices.

Also read →

Thank you for posting this. So far, trying to pair & bind devices(door sensors) take forever to do.

FYI, electromagnetic interference is really THE most common issue when having problems pairing Zigbee devices, so stongly recommend follow all tips here →

Hi there… Have you fixed the situation???

I have the same problem here, but using ZHA instead of Z2MQTT.
Could you tell me what firmware are you using with the Dongle-E?
I noticed the github ZHA library do NOT reccomend using Dongle-E due unstability problems…

I have alread ordered a Dongle-P to test, but my only problem is with Aqara end devices…

BTW, I have an Aqara Hub and they work flawlessly, even with 10% battery!!!
But, driving to the offline system way, I “need” they working directly!!!

Most people reported ZDongle-E as very stable with the EmberZNet 6.10.3 NCP firmware as long as have followed the recommended best practices to avoid interference (i.e. at least USB 2.0 port and long extension cable) → Zigbee networks: how to guide for avoiding interference and optimize for getting better range + coverage

What do you mean? ZDongle-E is recommended for ZHA, but not recommended for Zigbee2MQTT:

What is not recommended for any is using a hacked “ITEAD Sonoff ZBBridge” because it uses Wi-Fi:

I also thought that it would be the best option, since it would work straight from the Box, without changing firmware, but in practice it is not working so I researched a little deeper the documentation of the library that it uses in the home assistant.

The Github for the BELLOWS library contains a note saying it has stability issues.

I Will try the firmware you use…

I ordered this one now:

Uses other library, and is supoosed to work better with the Z-Stack 3.x.0 coordinator firmware.

  • Base on TI CC2652P + CP2102N

It does not say that about the Sonoff ZBDongle-E. I think that you are confusing it with the no longer sold Zigbee 3.0 dongle barebone model “9888010100045” adapter from ITead that was a previous barebone dongle that also based on EFR32MG21 (though never had the “Sonoff” branding), but that board is not the same as the Sonoff ZBDongle-E. The board 9888010100045 was not recommended because that board reportingly had a poor antenna design using a poorly tuned circuit board antenna so signal reception has been reported to be extremely sensitive to interference.

Btw, you will also find that the bellows readme is not updated often, so instead check the ZHA integration docs which has been updated more recently →

Comparing “ZBDongle-P” vs. “ZBDongle-E” vs. barebone EFR32MG21 dongle

image verses image versus image

Feature/Model ZBDongle-P ZBDongle-E 9888010100045
Radio SoC/MCU chip Texas Instruments CC2652P Silicon Labs EFR32MG21 Silicon Labs EFR32MG21
Zigbee Stack (Serial Interface Protocol API/CLI) Z-Stack v3 (ZNP 3) EmberZNet (EZSP v8) EmberZNet (EZSP v8)
Optional Zigbee Router firmware Yes (9dBm firmware available from Koenkk) Yes (20dBm firmware available from ITead) Yes (20dBm firmware available from ITead)
USB to UART/Serial Converter Chip CP2102 or CP2102N CH9102F CH340
USB EEPROM Product Description ID SONOFF Zigbee 3.0 USB Dongle Plus SONOFF Zigbee 3.0 USB Dongle Plus V2 (first need to run update script if from first hardware batch shipped) None (no USB chip EEPROM)
Home Assistant USB Auto Disovery Yes Yes (but way need to run update script if from first hardware batch shipped) Not possible
Flow Control None by default (Hardware flow control optional with alternative firmware and flipped dip-switch) Software flow control Software flow control
RF Transmit Output Power 9dBm (firmware hardcoded), Max: 20dBm 20dBm (default) 20dBm (default)
Antenna External (rotatable and tiltable) External (rotatable and tiltable) Onboard circuit board antenna
Enclosure/case Aluminum all-metal shell casing Aluminum all-metal shell casing None
Length 63mm 52mm ?
Packaging Retail-box with manual Retail-box with manual Anti-static bag only
Home Assistant ZHA Supported Supported Supported
Zigbee2MQTT Supported Experimental support as still in development by zigbee-herdsman dev, see Experimental support as still in development by zigbee-herdsman dev, see
IoBroker Supported Experimental support as still in development by zigbee-herdsman dev, see Experimental support as still in development by zigbee-herdsman dev, see
OpenHAB ZigBee Binding Not yet, see request and discussion Supported Supported
Domoticz Zigbee Plugin Supported Supported Supported
Jeedom Zigbee Plugin Supported Supported Supported

Ok I see… that info is about the 9888010100045 model, but they do not say anything about the new Dongle-E, maybe because they do not update that readme… maybe!

But I’m looking everywhere for a plausible reason why my devices aqara are not accessible for more than 2 hours.
I have those cheap tuya door sensors and temp and humidity sensors located much further away from the coordinator and have been operating normally for 3 weeks.
Even some are very close to wifi networks, working normally.
I’ve followed all the recommendations to avoid interference.

I also have another problem with switching devices inside the wall, also Tuya: The ones that don’t need neutral (which don’t work as routers) work normally, but the ones connected with neutral (which work as routers) are losing connection sometimes.

Tonight I will try EmberZNet 6.10.3 NCP.
If it improves stability I could use the Dongle-P that I already ordered with a router firmware, which, by the way, is described in the zigpy-znp library (because of this I thought about changing the dongle!)

Thanks for the help!!!

Maybe you have some rouge Zigbee Router that do not forward all messages, read →

Good idea to add a few known good Zigbee Router devices as mentioned in the guide → Zigbee networks: how to guide for avoiding interference and optimize for getting better range + coverage

Not ”maybe”, it was me that put that info in bellows readme and in the ZHA docs :stuck_out_tongue:

:see_no_evil: I did not imagine I was talking to THE GUY!!! sorry!!!

I will try the firmware you told right now!!!

That is definitly a good reason for the problem from the cheap Tuya Wall Switch devices, but is not my mainly problem !!!

My aqara battery devices allways pair without any problem… But they show unknown after 2 hours…

As my zigbee network is small, I have already done several tests and rebuilt the network in several different ways, including leaving only the coordinator with 2 devices aqara about 1 meter away, far from the entire wifi network (my HA runs on a network wired RPI).
And they just lose connection after few hours.

I understand that a big network needs good routers to make it stable, but I’m still choosing the best coordinator and so far, the Dongle-E doesn’t seem reliable.

Is this the recommended firmware?

  • ncp-uart-sw_EZNet6.10.3_V1.0.1.gbl

I’ve also had problems with Zigbee Dongle E and cheap tuya in wall devices, the ones without nutral worked ok, the one with nutral would disconnect. I also have a new and small Zigbee network (7 devices, 2 routers) and for me what did the trick was changing the original antenna to a bigger one form an old Tp-Link router. Since the change I have not seen a single network drop in 7 days.

My coordinator firmware is: build 131


Actually, due to the short range of Zigbee radio signals, it is more important to have a few known good Zigbee Router devices if you have a small Zigbee network with some battery-powered devices.

A lot of people that is just starting with Zigbee do not understand that it relies on mesh networks and/or that battery-powered devices do not act as Zigbee Router devices so they only buy a Zigbee Coordinator and a bunch of battery-powered devices and then wonder why they the loose connection.

Again, highly recommend you read and try to follow through all of these best practice tips → Zigbee networks: how to guide for avoiding interference and optimize for getting better range + coverage

That is currently the generally recommended firmware because it is known to be very stable, however, later firmware will have later bug-fixes that might offer better compatibility with some newer devices.

So any newer firmware all the way up that has specifically been built for the Sonoff ZBDongle-Z should also work, but they has not been tested as well to can not be said to mature or how stable.

If you have that much problem with those specific Aqara devices then it is worth open an issue to Home Assistant core to get the attention of ZHA developers → Issues · home-assistant/core · GitHub

See what is needed in new issues →

To cleaify, I’m not a developer of ZHA or zigpy, but I did help contribute to documentation + readme files. Please note ZHA documentation are still in dire need of more people contributing improvements to it:

I just realized that maybe I have an interference problem, but not only between wifi and zigbee

My home assistant has all these protocols up and running:

  • Z-wave Aeotec Z-Stick Gen5 Plus
  • Mysensors running on NRF24L+ radio, using 2476Mhz defaut frequency (changeable)
  • Milight Hub - to control Miboxer Bulbs running on 2400-2483.5mhz (not changeable I think)
  • Wifi with 3 AP using Channel 6 (2437MHz) and Channel 1 (2412Mhz)
  • Zigbee Sonoff Dongle-E config channel 25 (2475Mhz) on configuration.yaml
  • RFLink 433,02 Mhz - no inteference i Think
  • Somfy Hub ESP32 - 433,42 Mhz.- no inteference i Think

I also have ApSystems Solar Energy with ECU-R in the roof - which I have no idea what Zigbee channel uses

I think I should change Zigbee to channel 15 (2425Mhz) and let the 2476 defaut to MySensors, once MySensors needs to change every node sketch to a new channel…

Hi @DominikW.

I can not find this firmware you are using!
Could you link to me?

I got it from this web flasher Silabs Firmware Flasher | Web based flasher for ZB-GW04 and ZBDongle-E. MultiPAN RCP firmware enables these devices to be used with Silabs Multiprotocol Addon in Home Assistant. Allow Zigbee and Thread to co-exist on the same dongle. Get ahead of the tech an experiment with Matter!

First I tried the Multi-PAN for Zigbee and Thread - but the firmware was unstable, Silicon Labs Multiprotocol Add-on would stop working from time to time, so I flashed the Zigbee software - first option:


1 Like

After changing

  • firmware to the last
  • antenna to 5dbi
  • longer usb extender wire
  • put the coodinator over my desk, far from power AC and other devices
  • change Wifi channels to 1 and 11
  • change coodinator to channel 15
  • disable mysensors and milight hub
  • turn off ECU-R

I still have Aqara battery end devices disconnecting after 2 hours.
I still have in wall tuya switches disconnection randomly

Now I will test adding 3 Sonoff Dongle-P or E router devices and would like do know that would be the best location:

My last chance on Sonoff Dongles…

Hi @DominikW !

Did you need to use /config/custom_zha_quirks to work with those cheap Tuya in Wall Switches?

I have a lot of them showing power monitoring incorrectly when discovering from ZHA:
For example:

TS0002 - _TZ3000_zmy4lslw - 2 gang
is discovered as ts000x.Switch_2G_Metering, with sensors that do not exist when connected in Smart Tuya App ! (such as Active Power, RMS voltage, current)

TS0003 - por _TZ3000_pfc7i3kt (3 gang Moes device)
is discovered as ts000x.Switch_3G_GPP, with a backlight mode that does not exist in Smart Life App

Do your devices also show these non-existent features?
I am using to make them work!

And the last question for now!!!
Is it worth changing from ZHA to Zigbee2MQTT?

I’m using Zigbee2MQTT, actually my HA server is in the attic, and my Zigbee devices are on the ground floor of a two story building, so I had to connect my Zigbee dongle to a raspberry pi 4 running only Zigbee2MQTT which I put on the ground floor.

After changing the antenna everything works great, no droped devices, but I do not have any Aqara devices.