Ariela - Home Assistant Android Client

I am on - installed the 13th of June.

I would say check the device tracker setup then.
There are two new switches to enable device.see and to use Mobile_App or the “old method” FCM-android.

After checking this, also take a look at your device tracker Tracking Mode/updates period/updates position.
My settings for these three were all reset and I had to put them back to the way I liked.

Let us know if these fix your issue (might have to wait for next push to HA).

Uhm, I don’t think this is it. See, my coordinates are inverted (latitude reported as longitude and viceversa) and actually according to Ariela’s map (not only HA) I am in the arabic sea.

I don’t believe it’s simply reporting. I did play with the switches (although I don’t know what the difference between mobile app/ see is.


This was a issue present in the old version. If you have the latest version try to turn off Location from Phone and then back on and see if its updating (also try to do that while using 3G/ 4G and not home wifi). This will force the location to be updated. Please let me know if works.

Yes! It did it!
Good 'ole fashioned restart :slight_smile:

Thanks guys!

1 Like

Hello everybody,

I created Wall dashboard & Android TV UI / UX topic, in order to keep track of my development progress regarding it, and for all who wants to give an opinion or ideas.

How is the wifi RTT addition coming?

To be honest, its kinda ready for some time, but i do not have the hardware to test it, so a little afraid to release the new sensor. If anyone want to test please let me know.

I have all of the equipment for the testing.

Pixel 2 xl
3x Google WiFi pucks

I would love to test it out.

Thanks again for the good work. Have been using Ariela for a couple of days now, and I have one small feature request: a volume up and down button for media players. I have a device that is very sensitive when it comes to volume control, so using a slider can cause the volume to go up way too much accidentally. Therefore I would like to control the volume via buttons.

Is this open source?

Not for the moment.

Is it possible to have a sensor for if the device is locked or unlocked? And also the current foreground app in use?

I have disabled the old method of notifications (fcm-android) and am attempting to use only the mobile_app notifications. Currently I am getting this error:

0, message='Attempt to decode JSON with unexpected mimetype: '
Traceback (most recent call last):
  File "/usr/src/app/homeassistant/components/websocket_api/", line 121, in handle_call_service
  File "/usr/src/app/homeassistant/", line 1150, in async_call
    self._execute_service(handler, service_call))
  File "/usr/src/app/homeassistant/", line 1172, in _execute_service
    await handler.func(service_call)
  File "/usr/src/app/homeassistant/components/notify/", line 112, in async_notify_message
    await notify_service.async_send_message(**kwargs)
  File "/usr/src/app/homeassistant/components/mobile_app/", line 119, in async_send_message
    result = await response.json()
  File "/usr/local/lib/python3.7/site-packages/aiohttp/", line 1027, in json
aiohttp.client_exceptions.ContentTypeError: 0, message='Attempt to decode JSON with unexpected mimetype: '

I saw earlier in the thread another user getting this error as well.
I have scrubbed the system and removed everything for the phone, and then re-did the credentials with the force mobile_app credentials. Mysteriously it created phone2 even thought I removed all references to it, but I just removed this in the core file and restarted to fix.

Anyway, after all this, I am still getting the error.
Not sure if this is Ariela issue or HA issue.
I am simply sending a test message from the Developer Tools Services - and it gives the error.

Any suggestions/feedback?
I believe re-registering worked for the previous user… not sure why mine isn’t…

Yes, i will implement this soon

Can you share your automation / script that use you for calling the notify service?

I am not even using an automation.
Just calling the service with a test message is failing with the error:

I am not sure if this is related to Ariela, what HA version do you have?
LE: Also try to delete all your previous mobile app integrations, restart HA, try re-registering again.
In HA console do you have a error?

I have already removed everything and re-added it. Still get error.
Currently on HA version 0.94.2.
Scratch that… updated to 0.94.3 - still get the error.
What do you mean by HA console?
In the “Info” or “about” section of HA web UI I get the warning/error I posted earlier.

If there is another place to get a more informational message let me know.
I think also that this is a Home Assistant error not Ariela - but you are so extremely responsive and knowledgeable, we come to you first :slight_smile:



i try to push an image with notification but no image in the notification : but there in config/…/chambre1_year_month_day_hour_minute.jpg```

my automation.yaml :

- id: '1560281320272'
  alias: Automatisation detecteur chambre1
  - entity_id: binary_sensor.chambre1_pir_sensor
    from: 'off'
    platform: state
    to: 'on'
  - condition: state
    entity_id: device_tracker.galaxy_note8
    state: not_home
  - data:
      entity_id: camera.Chambre1
      filename: /config/www/cam_captures/chambre1_{{ now ().year }}_{{ now ().month
        }}_{{ now ().day }}_{{ now ().hour }}_{{ now ().minute }}.jpg
    service: camera.snapshot
  - delay: 00:00:05
  - data:
        image:{{ now
          ().year }}_{{ now ().month }}_{{ now ().day }}_{{ now ().hour }}_{{ now
          ().minute }}.jpg
      message: Détection de mouvement Chambre1
      title: Alerte chambre1
    service: notify.mobile_app_galaxy_note8

Can you help me please?

I try with a fix image name short as : chambre1.jpg : same result no image in notification on mobile.

the snapshot is 640x480, i thought (in doc) is small inough…

Is there a configuration more in Ariela app to do please?


I’m having a hell of a time getting rid of these duplicate entries.

I’ve deleted known_devices.yaml

I Checked all of the files in .storage and removed anything to do with ariela sensors and device tracker.

I’ve deleted the mobile devices from the integrations panel.

I’ve went through the entity registry and made sure none were in there as well.

Then I restart home assistant and Bam! A bunch of old sensors showing old data. I try to use the “force mobile app credentials” button and then I have another device tracker by the same name.