Bali Blinds Remote inclusion mode

I’m trying to configure my Bali Z-wave plus remote using AEOTEC Z-stick, I’m not sure how to put the remote in inclusion mode, I tried checking the user guide, but they do not have clear instructions on putting the remote inclusion mode. Appreciate the help

Are you sure the remote is a z-wave client device and not a z-wave controller?

I was unable to find much documentation on it but found a thread where someone was able to configure
Is there a way I could find the device type ?
Motorized window shades - Configuration - Home Assistant Community (

The post is about including blinds, as far as I can tell. If the remote is a controller, you cannot use it with Home Assistant, and must chose wether the blinds are paired with HA or with the remote, but not both.

If the remote is a normal z-wave remote, you can pair both it and the blinds with Home Assistant, and use automations or associations to control the blinds with both the remote and Home Assistant.

Before Home Assistant, did you need anything else besides the remote and the blinds, or was there a hub of some sorts? If the blinds were paired with only the remote, it is likely the remote is a controller, like your Aeotec stick.

1 Like

It has been many years since I did this for my Bali Blinds and remote. My remote is a small 2-button remote that I believe is named a VCZ-1. It has a small “program” button in the back that you use a paper-clip with. It comes out of the box as a Primary Controller for the blinds, but you can make it a Secondary Controller and then can do a Group Association with the Bali Blinds to allow the remote to still control the blinds.

I took notes on this and here is an image of the steps involved. The “Home Automation Controller” at the time was HA using OZW and Aeotec ZStickGen5 (I also did this with SmartThings hub). Today I am running this with HA using ZStickGen5/Gen5+ and ZWaveJS2MQTT.


Were you successful with this?
Tried pairing using GoControl CECOMINOD016164 HUSBZB-1 USB without luck.
Or is it because it doesn’t support Z-Wave Plus?

I received a set of Bali shades yesterday with the “Plus” (3-button) remote and came across this thread. Following the manual, which both comes with the shades and is in pdf online, I was able to “reset” both the shades and remote, and pair them with my Z-wave stick (Zooz ZST10 500-series) via zwavejs-UI. To summarize, hold the program button on the back of the remote for 15 seconds to reset (after which it no longer works with the shades). To include, place server in inclusion mode and hold the program button on the back fo the remote for 3 seconds.

My remote is basically a 3-button scene controller, model BRZ1. It supports Z-wave Plus v1 (500-series) and has two association groups. I added my shades to Group 2 but as of right now it doesn’t seem to have any effect. Note that to complete the interview, and add associations, you have to wake the remote by clicking (not holding) the indented “program” button (on the back).

The remote buttons send Central Scene zwave_js_value_notification events to Home Assistant. The Up button is Property Key “001”, the down button “002” and the home button “003”. A single-click sends a Value of 0 (zero), press and hold sends Value 2, and release sends Value 1 (I haven’t tried multi-clicks). These events can be used to program any automations you want in HA like any scene controller. I suppose I could write a HA blueprint to emulate the default remote functionality via HA automations, or I could re-pair the remote with my shades, but I’m not a huge fan of the remote and probably won’t be using it much.

My hope was to setup a wired paddle switch (with no load / “smart bulb” mode) as up/down control for the room. Unfortunately the shades do not appear to have the proper target endpoints to do this via direct associations, making it likely necessary to have an automation server in the middle. If anyone can offer any further insight into how the remote sends commands directly to the shades without a controller please let me know.

1 Like

Thanks to this post and the flowchart above by wmaker I was able to restore the stock behavior of the remote (full up/down, incremental up/down, home, interrupt/stop) with no loss of functionality, while also having the shade paired with and controlled by HA.

  1. Reset shade and remote
  2. Pair shade to HA as above
  3. Pair remote to HA as above
  4. Use zwjs-ui to set Group 2 on the remote to point to Endpoint: root node, Node: shade_name. It’s necessary to put the remote in inclusion mode (hold 3s) again prior to saving the changes in zwjs.


Here are the instructions on how to add the blinds and the remote to HA, then adding the blinds to the remote as well. I followed these instructions and everything works perfectly.

I had the BRZ1 working fine following these instructions until the latest update.

The configuration module has several options that I don’t know how to configure. Does anyone have any advice?

Just wanted to say that this works and was very helpful.

For my bali blinds and VCZ1 remote, the process was:

Remote: Depress pin button on back for 15 seconds. Lights flash through colors to red and then stop flashing.
Blind: Hold button for 7 seconds. Blind jogs up and down

Include shade:
Start inclusion on HA (in my case Z-wave JS)
Hold button on shade for 3 seconds. Shade light goes from blinking to solid and shade jogs.
Rename device in HA, add dashboard control and test.

Add/Include remote:
Start inclusion on HA
Depress pin button on back for 3 seconds, remote starts flashing green, then stops after being paired
Rename device in HA

This is the part that seems to be missing from all the manuals Bali provides etc

Add association of Remote to Shade:
Depress pin button on back quickly - one push
Hold button on shade for 3 seconds. Shade light blinks fast. It doesn’t stop right away. But the remote works, and the HA controls work. After a few minutes the light stops blinking.

Test- for me, the remote and the HA shade control work.

Thanks for providing this info!



Thanks for the concise instructions! I had the exact same need today and your instructions worked flawlessly the first time through. I’m excited that I can now manage my blinds from HA.

Could you please explain why we need to “Rename” the device in HA? I’m gonna try this tonight…