Challenges adopting Bali Blinds via Z-wave

I’ve just added Home Assistant to my house and am trying — but failing — to pair some older Z-wave controlled Bali Blinds with it. I’d appreciate any advice.

I’m using a Zooz 800 USB controller and several Zooz 800 repeaters, managed using Z-Wave JS UI.

The blinds in question are described here and I was able to find the following older threads referencing this (but the instructions didn’t work for me): here and here.

I’ve reset the blinds, and then I place them into inclusion mode (LED confirms this). I go to Z-Wave JS UI, click the hamburger menu, then the infinity sign, and the Nodes Manager appears. I choose “inclusion”, hit next, type in name/location, hit next, choose default security, hit next, and then I get 30 seconds of inclusion… during which no new devices are found. Any advice on what I might be doing wrong?


  • Honestly this is the first attempt I’ve made to adopt a Z-wave device that doesn’t have Smart Start, so I may be doing something really boneheaded….
  • Note that the blinds have to be added through a repeater, because they are far away from where the hub must be located. The repeater shows up as successfully connected in Z-Wave JS UI, and it’s quite close to the blinds.
  • I don’t know anything about the security level supported by these older blinds (i.e., no encryption vs. S0 vs. S2). I’m assuming the “Default” option has me covered there (though I did also try adopting with S0 and with “no encryption” security and had the same result).

Thanks in advance for any advice!

Assuming you don’t have an RF coverage gap, you might be experiencing a bug in the SDK where NWI of a 500 series device doesn’t work through 700/800 series repeaters. Allegedly it works on the second attempt, but will reliably fail the initial inclusion. Have you tried immediately starting a second inclusion attempt after the first fails (e.g. don’t factory reset or do anything else in between)?

Also, avoid S0 encryption at all costs.

That is backwards. Start inclusion in ZUI first, then on the device.

Thanks! I tried several times back to back and nothing appeared to work… Then miraculously an hour later I opened my Z-Wave JS UI device list and the blinds are happily listed there (albeit without security)

Now if I could only get the devices to appear in Home Assistant… but I appear to be having this issue…