Blocked by onboarding.html

I’ve installed the app for HA via Qnap app installer, which is described at Qnapclub Store - Home Assistant (Apache80) but after inputting a username and password, it gets stuck at the onboarding.html page with the popup language below. I tried stopping the app and deleting the .storage dir, but still no joy.
Any suggestions on how to bypass this?

Failed to save: Invalid time zone passed in. Valid options can be found here: for dictionary value @ data[‘time_zone’]. Got ‘America/Los_Angeles’

Ok I was able to bypass the onboarding page by deleting the .storage dir and then attempting login with Firefox. So now, how do I enable Supervisor mode??

System Health

Version core-2021.11.4
Installation Type Home Assistant Core
Development false
Supervisor false
Docker false
User admin
Virtual Environment true
Python Version 3.8.5
Operating System Family Linux
Operating System Version 5.10.60-qnap
CPU Architecture x86_64
Timezone UTC

You can’t. You are running HA Core. To have Supervisor, you need to run HA OS or HA Supervised. HA Core and HA Container don’t have Supervisor.

Understood, does anyone know how to install Supervised on a qnap nas?

Can you run VMs on the QNAP? If not, then you can’t install Home Assistant OS or Supervised

Yes Qnap has this ability, any links to how to install on a vm?

I don’t own a QNAP NAS, but there’s a thread here on the forum describing the process

I assume it still works even if it’s from 2019 because someone just posted there a few days ago that it’s working for him.

Wonderful, thanks!

@Burningstone I ended up abandoning the VM implementation and continued with running HA in a container on my Qnap. Woke up this morning and the container had stopped. When I restarted it, HA opened to the ‘create a user’ page and after I filled that out, I now have just the default setup. None of my Integrations or Automations or HACS are showing. I looked at the files in the root config directory and only the the .storage/core.config_entries, core.restore_state files had updated timestamps at 2:10 a.m. and 4:10 a.m. respectively.
Is there any method to restore my prior setup? I spent many hours setting up my devices and am quite unsettled at this point.

You know that you won’t get add-ons and supervisor with this setup?

Did you make a backup at any point? If not, I don’t know how I should be able to help you.

Yes I made a backup of the entire config directly on Saturday, any help is much appreciated.

Including the hidden .storage directory? If so, just copy it in the config folder and restart HA.

I’ve resurected the app for HA via Qnap app installer, which is described at Qnapclub Store - Home Assistant (Apache80) and all is working great except that the timezone is stuck in UTC. I tried adding/changing via config.yaml but get an error when trying to reboot. The General Config page shows timezone as UTC but grayed-out so I cannot modify there.
Any thoughts on how to workaround this?

@Burningstone yes I copied over all files and the .storage but still get the default Overview page after restarting the container for homeassistant. All of the files copied over have legacy timestamps, fyi

Any ideas?

Also @Burningstone I did get HA installed on my Qnap via VM but could not figure out where the /config directory was located to copy over my settings so I abandoned that. Any idea on how to locate the /config directly on the VM for Qnap?

Install the Samba Add-on, connect from a remote machine and copy the files over.

All set, thanks

I got the files copied over but none of Integrations or Automations are coming up. I ended up having to edit the core.config_entries and core.device_registry files in the .storage dir to get the entries to show up in HA, fyi. Things are now coming together!