Broadlink Integration - add support for RM4 Mini

Tags: #<Tag:0x00007f7c66633320>

https://www.home-assistant.io/integrations/broadlink/

Please add support for new Broadlink RM4 Mini to the Broadlink integration.

Have tried various supported devices in configuration.yaml, but consistently get following errors when calling the broadlink.learn service:

2019-12-03 17:51:15 DEBUG (MainThread) [homeassistant.components.websocket_api.http.connection.139941084147472] Received {'type': 'call_service', 'domain': 'broadlink', 'service': 'learn', 'service_data': {'host': '192.168.0.171'}, 'id': 29}
2019-12-03 17:51:15 DEBUG (MainThread) [homeassistant.core] Bus:Handling <Event call_service[L]: domain=broadlink, service=learn, service_data=host=192.168.0.171>
2019-12-03 17:51:15 ERROR (MainThread) [homeassistant.components.broadlink] Failed to connect to device
2019-12-03 17:51:15 DEBUG (MainThread) [homeassistant.core] Bus:Handling <Event system_log_event[L]: first_occured=1575355875.9585288, timestamp=1575355875.9585288, level=ERROR, message=Failed to connect to device, exception=, root_cause=None, source=components/broadlink/__init__.py, count=1>

Works in Google home and Broadlink app. IP address and MAC address confirmed correct.

Well… I just tried all possible broadlink supported types in hopes that one would just work, none did.

More so, the RM4 Mini has the option of adding power cables that include sensors. Mine has humidity + temperature sensors and those don’t work with the broadlink sensor examples either…

This device really does seem like a step forward in the right direction, it’s small and efficient, with modular sensor support. Would love to see this thing working with HA too soon.

There seems to be a thread started here for the same purpose:

I know that RM4 Mini and RM4C Mini are different devices, but the users there seem to be discussing about both products.