Broadlink IR Climate Component


#450

Firstly Thanks a million for an awesome plugin. Easy installation and it just works.

Just a small problem with the built-in temp sensor used the config shown above. Shows up in Home Assistant but unfortunately not updating temp. Just Remaining @ 0"

image

I am using The RM MINI 3 .

Thanks


#451

I don’t think that rm mini 3 comes with temp sensor.


#452

That’s right, no built in temp sensor on the mini as @madrian mentioned.


#453

Ok thanks which would you guys sugest that has built-in temp sensor


#454

I’m not sure the current model RM Pro still have built in sensors.


#455

I just went through and learnt over 200 commands for my panasonic air conditioner.

I created a python script to make this less manual than trying to learn IR codes via home assistant. If anyone wants to use it, link is below.

Basically just put a list of all the command names you want to learn into input.txt, then the script will cycle through the list and prompt you to press the corresponding button for each one. It will then save the entire output to output.csv.


#456

I am having an issue with the Fan commands. All of the “On” commands are working but the “Off” command is not. I have retrained the RF code 5 times and still nothing. my setup is as below:

fan:

  • platform: broadlink
    name: Bonus Room Fan
    host: xxxxxx
    mac: ‘xxxxxx’
    rfcodes_ini: ‘rfcodes/bonus.ini’
    default_speed: Low
    defaut_direction: left
    customize:
    speeds:
    - Low
    - Medium Low
    - Medium
    - Medium High
    - High

Is there something that needs to be added in the config.yaml to enable the off command? Couldn’t find it in the documentation anywhere. Thanks for the help!


#457

Hi,

EDIT: It seems it’s not a thermostat card issue. I have the same behaviour with the ‘normal AC panel’

I’m on version 0.81.5. Error Below.


I tried the new Lovelace Thermostat card with broadlink climate but it doesn’t work.

image

when I move the dial, or change from heat to cold this is triggered:

image

But then I get this error:

Error doing job: Task exception was never retrieved

6:13 PM custom_components/climate/broadlink.py (ERROR)

Log Details (ERROR)
Sun Nov 04 2018 18:13:07 GMT+0000 (Hora padrão da Europa Ocidental)

Error doing job: Task exception was never retrieved
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/configparser.py", line 789, in get
    value = d[option]
  File "/usr/local/lib/python3.6/collections/__init__.py", line 883, in __getitem__
    return self.__missing__(key)            # support subclasses that define __missing__
  File "/usr/local/lib/python3.6/collections/__init__.py", line 875, in __missing__
    raise KeyError(key)
KeyError: 'mid_23'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/helpers/service.py", line 226, in _handle_service_platform_call
    await func(entity, data)
  File "/usr/local/lib/python3.6/site-packages/homeassistant/components/climate/__init__.py", line 572, in async_service_temperature_set
    await entity.async_set_temperature(**kwargs)
  File "/usr/local/lib/python3.6/concurrent/futures/thread.py", line 56, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/config/custom_components/climate/broadlink.py", line 279, in set_temperature
    self.send_ir()
  File "/config/custom_components/climate/broadlink.py", line 163, in send_ir
    command = self._commands_ini.get(section, value)
  File "/usr/local/lib/python3.6/configparser.py", line 792, in get
    raise NoOptionError(option, section)
configparser.NoOptionError: No option 'mid_23' in section: 'heat'

Is there a way of making it work with broadlink climate component? Any info I can provide in order to help?

thanks


#458

I’ve just tested mine in lovelace and all working as expected. Just check that you are running the latest version of the custom component.


#459

I am very interested in this plugin but I am Stuck with the same errorcode than u, I have 2 broadlinks devices working, and I can use them as switches to control aa/cc but the pluguin does not work, and I don’t understand why.

I have tried :

  • previous versions
  • comment other broadlink configs

#460

I’m assuming you might be missing this line in your ini file?


#461

Can you provide us with a sample of your log?


#462

Ok I got it , I had a problem inside de .ini, the codes were wrote as ‘med_21 = JgAEAWQyDAwMDAwlDA…’ renamed it to ‘mid_21 = JgAEAWQyDAwMDAwlDA…’ and there is error no more, now it does no give me any errors related to climate, but it does nothing too. May be incorrect fuji codes… I´ll keep looking.

Edited not gone ! :frowning:

my log :

Error doing job: Task exception was never retrieved
Traceback (most recent call last):
  File "/usr/lib/python3.5/configparser.py", line 786, in get
    value = d[option]
  File "/usr/lib/python3.5/collections/__init__.py", line 881, in __getitem__
    return self.__missing__(key)            # support subclasses that define __missing__
  File "/usr/lib/python3.5/collections/__init__.py", line 873, in __missing__
    raise KeyError(key)
KeyError: 'mid_30'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/lib/python3.5/asyncio/tasks.py", line 241, in _step
    result = coro.throw(exc)
  File "/srv/homeassistant/lib/python3.5/site-packages/homeassistant/helpers/service.py", line 224, in _handle_service_platform_call
    await getattr(entity, func)(**data)
  File "/usr/lib/python3.5/asyncio/futures.py", line 380, in __iter__
    yield self  # This tells Task to wait for completion.
  File "/usr/lib/python3.5/asyncio/tasks.py", line 304, in _wakeup
    future.result()
  File "/usr/lib/python3.5/asyncio/futures.py", line 293, in result
    raise self._exception
  File "/usr/lib/python3.5/concurrent/futures/thread.py", line 55, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/home/homeassistant/.homeassistant/custom_components/climate/broadlink.py", line 303, in set_operation_mode
    self.send_ir()
  File "/home/homeassistant/.homeassistant/custom_components/climate/broadlink.py", line 167, in send_ir
    command = self._commands_ini.get(section, value)
  File "/usr/lib/python3.5/configparser.py", line 789, in get
    raise NoOptionError(option, section)
configparser.NoOptionError: No option 'mid_30' in section: 'heat'

my config :

climate:
  - platform: broadlink
    name: aacccomedor
    host: xxx.xxx.xxx.xxx
    mac: 'xx:xx:xx:xx:xx:xx'
    ircodes_ini: 'broadlink_climate_codes/fujitsu.ini'
    min_temp: 16
    max_temp: 30
    target_temp: 20
    target_temp_step: 1
    temp_sensor: sensor.temperature_158d0001b1c847
    default_operation: 'off'
    default_fan_mode: mid
    customize:
      operations:
        - 'off'
        - cool
        - heat
      fan_modes:
        - low
        - mid
        - high
        - auto

Thanks


#463

If you look closely at the log, you will note in the last line your likely issue. :slight_smile:


#464

Dear Vassilis,
I am looking for ways to control my conditioners/ fans… and found your post.
However, I am a starter with no experience so it quite difficult for me to follow your instruction.
Please let me know where to put *.ini file?
Hope to hear from you soon
Thank you
Best regards
Minh Chau


#465

In the root of your config share create your broadlink_climate_codes then place your ini file here.

ircodes_ini: ‘broadlink_climate_codes/fujitsu.ini’


#466

Thanks, you saved me a few hours there really appreciate it.

Initially had the same error, but when i checked the prob was in my ini file.

[heat]
low_16.0 = JgBYAAABJEQUEBMpExEUKBQQEisTERMqEykTERMRExETKhMREhITERQpEykSEhMSEygUKRMpExETERQoEykTERQpExAUEBMSExETERIpExESExMREioSEhMADQU=
low_17.0 = JgBYAAABJUMUEBMpExEUKBQQEisTERMqEykTERMRExETKhMREhITERQpFCgSEhMSEygUKRQoEhITKhMpEykTERIqEhITERMREioTEhMoFBATEhMREykTERIADQU=
low_18.0 = JgBYAAABJkQTERQpExAUKRQQEyoTERIrEykTERMRExETKRMRExITERMpFCgTERMSEikTKhQoExETERMSExESKhMpExESEhMRExETKRMpExETERMSEykTERMADQU=
low_19.0 = JgBYAAABJEUTERMpExETKRMREioUERMpFCkSERQQFBESKhQRExETERMpFCkTERMREykTKRMqExETKRMQFBESKhMpExESEhMREyoSKhMpExESEhMRFCgUERMADQU=
low_20.0 = JgBYAAABJEUTERMpExETKRMREykUERMpEyoTERIRFBETKRQRExESEhMqEykTERISEykSKxMpExETERMRExETEhMQEyoSEhMRExESKRMqEykTERISEykTERMADQU=
low_21.0 = JgBYAAABJkMTERMpFBETKRQREykUERMpEykTERMRFBESKhQRExATEhMpFCkTERISEykTKRQpExESKRMRFBETERISEykTERMRFCkTKBMqEykUEBMREykTERQADQU=
low_22.0 = JgBYAAABJEUTERMpExITKRMREykTERMqEykTERMRExETKhMRExEUERMpFCgTERITEykTKRQoExESEhQpExAUEBQREykTEhMRExESEhMRExEUKRMREykUEBQADQU=
low_23.0 = JgBYAAABJUMTEhMpExETKRQQEyoTERMqEioTERISExESKxISExEUERIqFCgTERMSEioTKRQoExESKxMpEhITERISEyoTERISEykUEBMRFBESKhQREykTERQADQU=

Once i took the .0 it worked like a charm.

[heat]
low_16 = JgBYAAABJEQUEBMpExEUKBQQEisTERMqEykTERMRExETKhMREhITERQpEykSEhMSEygUKRMpExETERQoEykTERQpExAUEBMSExETERIpExESExMREioSEhMADQU=
low_17 = JgBYAAABJUMUEBMpExEUKBQQEisTERMqEykTERMRExETKhMREhITERQpFCgSEhMSEygUKRQoEhITKhMpEykTERIqEhITERMREioTEhMoFBATEhMREykTERIADQU=
low_18 = JgBYAAABJkQTERQpExAUKRQQEyoTERIrEykTERMRExETKRMRExITERMpFCgTERMSEikTKhQoExETERMSExESKhMpExESEhMRExETKRMpExETERMSEykTERMADQU=
low_19 = JgBYAAABJEUTERMpExETKRMREioUERMpFCkSERQQFBESKhQRExETERMpFCkTERMREykTKRMqExETKRMQFBESKhMpExESEhMREyoSKhMpExESEhMRFCgUERMADQU=
low_20 = JgBYAAABJEUTERMpExETKRMREykUERMpEyoTERIRFBETKRQRExESEhMqEykTERISEykSKxMpExETERMRExETEhMQEyoSEhMRExESKRMqEykTERISEykTERMADQU=
low_21 = JgBYAAABJkMTERMpFBETKRQREykUERMpEykTERMRFBESKhQRExATEhMpFCkTERISEykTKRQpExESKRMRFBETERISEykTERMRFCkTKBMqEykUEBMREykTERQADQU=
low_22 = JgBYAAABJEUTERMpExITKRMREykTERMqEykTERMRExETKhMRExEUERMpFCgTERITEykTKRQoExESEhQpExAUEBQREykTEhMRExESEhMRExEUKRMREykUEBQADQU=
low_23 = JgBYAAABJUMTEhMpExETKRQQEyoTERMqEioTERISExESKxISExEUERIqFCgTERMSEioTKRQoExESKxMpEhITERISEyoTERISEykUEBMRFBESKhQREykTERQADQU=

#467

Glad it made your life easier :slight_smile:

Yeah sorry I should have removed the decimal points from the input.txt file. My AC has 0.5 C steps, but I know most probably just go up in 1 C steps. Found out the half degree settings don’t work with this climate component anyway.


#468

Okay sorry if I am going slightly off topic here. Would it be possible to use our ini files and HA climate component with something like LIRC. The reason I am asking is cause I am running HASSIO on a PI and have an AC in the same room. Was going to buy another RM Mini, but it struck me if I could stick a IR LED on the PI I could save a few $ as well as 1 less power supply.


#469

Lovelace thermostat works beautifully!
I have a dumb aircon so I had to create a separate switch to turn it on and off.
Added a couple of automations that turn it on and off based on motion sensing. It will turn it off it hasn’t picked up any movement for a while. The same for the fans.