Broadlink Manager - Nicer way to Learn and Send IR/RF commands

Hi, thanks, but as mentioned above I have tried all these steps, even reset it by now several times no success.
I have it via USB for power, since I do not yet have a power supply cable

Hi, I am just wondering if I can sen customised RF code? As it doesn’t learn the RF code, but I want to test it. Is it possible?

@ Tomer_Klein Thanks you, you app is very helpful.
May I suggest Raw-IR data with pulse lengths as output too?
Something like:

raw,<frequency>[,<header_mark>,<header_space>,<bit_mark>],<zero_space>[, [<one_multiple>] | <one_space>],<bit_stream>


This will expand dramatically the use of your app, since with this raw output you could reach arduino/esp users too.
More info about the protocol here.


@Tomer_Klein Hello, I also have the problem that RF-learning does not work with my RM Pro+!
I saw that you are using Broadlink.NET in your application, which is quite an outdated port of ‘python-broadlink’.

There is a pretty new port of ‘python-broadlink’ that is still maintained: SharpBroadlink

I tested SharpBroadlink with a tiny WPF application, that I have written and it does work also with RF-learning :slight_smile:

Maybe you want to update your application to use SharpBroadlink?



I have tried this app without success. It finds my RM2 Pro Plus3.
I have an RF remote (controlling blinds)

I have trained the RMPro some time ago to know the buttons and have google home happily triggering them.

I can’t get any codes out to put into HA, when I ask this app to learn the rmpro flashes an orange led intermittently but nothing happens in your app.
Any ideas?

I finally got my Dooya RF roller blinds using my “RM2 Pro Plus3”, the method DrZzs outlines, and the below.

In scripts:

  alias: Blinds Up
    - service: broadlink.send
        host: 192.168.1.XX

in config:

  - platform: broadlink
    host: 192.168.1.YY
    mac: '78:0F:77:63:WW:XX'

Hi @PainElemental Thank you for this.
I’ll check it up and update my app.


1 Like
private async void btnConnect_Click(object senderBtn, EventArgs eBtn)
            if (cmbDevices.Items.Count > 0)
                //    DiscoverClient.Dispose();
                //    DiscoverClient = null;
                //catch (Exception)

  1. public class BroadlinkDevice : IDisposable
        public override string ToString()
            switch (DeviceType)
                case 0x2712: return $"RM2 [{EndPoint.Address}]";
                case 0x2737: return $"RM Mini [{EndPoint.Address}]";
                case 0x273d: return $"RM Pro Phicomm [{EndPoint.Address}]";
                case 0x2783: return $"RM2 Home Plus [{EndPoint.Address}]";
                case 0x277c: return $"RM2 Home Plus GDT [{EndPoint.Address}]";
                case 0x272a: return $"RM2 Pro Plus [{EndPoint.Address}]";
                case 0x2787: return $"RM2 Pro Plus2 [{EndPoint.Address}]";
                case 0x278b: return $"RM2 Pro Plus BL [{EndPoint.Address}]";
                case 0x278f: return $"RM Mini Shate [{EndPoint.Address}]";
                default: return $"Bilinmeyen [{EndPoint.Address}]";

Thanks for this great work for IR i t is perfect

@kitus What app did you use on the phone?

Broadlink for Android but I can’t remember the name. I’m now using iOS and can’t check it anymore. Not sure if one can check purchased apps in google play store using a PC.

I had to use an old Android 5 device and the e-control version from November 2018. After that all smooth running - but after these 5 switches - never again LOL. Used it on these Broadlink light switch that require no neutral and each unit comes with their own RF remote contol!

Many thanks, great app, worked fine for me. Was able to learn codes for my remotes and got together Commands.json alright. This maybe a stupid question – where do I put this file in Home Assistant directory. I would like to be able to select the codes with reference to name or key in automation yaml. Or this json is just for manual reference and you have to find necessary code by hand?

Broadlink Manager can never detect my rm mini 3 in the network correctly, and I found out why…

I discovered that my rm mini 3 has a completely different device type ID (0x27de) compare to the one in the official python_broadlink library, and so I patched it myself and now I am able to use the python_broadlink library to discover and to run CLI to learn the IR codes very very easily!

You can read about the library here -

My PR submission is here -

To use this, you need to be comfortable with python, and I found you have to do this in a venv otherwise the cryptography library will conflict with the system one (Ubuntu 18.04). Its really simple, just follow the instruction in the first link will do.

As to how to patch Broadlink Manager can include this new device ID, I have no idea…

Hope it helps.

Hi! I can’t manage to learn RF codes properly, the app gets stucked waiting for the button press and nothing else happens. I can learn them in the broadlink app, but I don’t know how to extract the codes from there neither.

Someone succesful with RF codes?

AFAIK, nobody, including myself, have had success using this app for learning RF codes. A recurring subject in this thread, scroll up, and you will see several mentioning the same.

The app is great, but I think it’s built using libraries that don’t support RF learning. For IR, it works stellar, though.

1 Like

Ok thenk you, and there is a way that works for learning them? I also tryed using the service broadlink.learn without luck.

Hi @Ragnar_Bull-Nielsen ,
this is correct, i have some problems with the RF.
Working on complete new version that is based on newer version of the
as for now it;s working well but i have some work to do before i’m releasing it.


That’s not true it worked perfectly fine for me.

IR or RF? What devices? It would seem that you are the only one if it is indeed RF