Broadlink RM4 Pro - "Device not supported"

I have just received a Broadlink RM4 Pro, which is listed as compatible here. I can make it connect to my network, but after trying to integrate with HA, I receive the following error: “Device not supported”.

I tryed a few additional things, like to click in 3 dots in Broadlink App and unblock it, si it can receite other connections. I also read about not completing all configuration with the app, just giving the SSID and password… None of the above solved the problem…

Is it a known problem? Is there smething wrong with HA that may be corrected in a next version? Or may I be doing something wrong or there is kown incompatibility?
Thanks to anyone who may help me on this.

PS: If there is a more adequate category , please let me know, then I can edit my post. Thanks

There is a PR already running that should also solve this issue for RM4 Pro.

1 Like

It seems that if you edit broadlink/init.py you can fix this issue. Problem is I don’t know where to find this file X)

1 Like

I tryed to find it with no success. Maybe someone can give a hint.
In the internet I found some references, but it didn’t worked for me. Mayb you have more luck:

/usr/lib/python3.9/site-packages/homeassistant/components/broadlink/init.py
/srv/homeassistant/lib/python3.7/site-packages/broadlink/init.py

1 Like

Any news? I’m having the same issue.

As you see in the above links, the integration is still open.

I found two videos how to add RM4 pro, but both doesn’t worked?
Anybody with any solution?

It’s not a solution, it is a workaround. Find the error code in your log (In my case it was 0x653c and the the model is a RM4 Pro, proceed accordly). Then, SSH to HA: image

After that you will be able to integrate (no restart needed). Keep in mind that if you update HA, it will stop to work. Restart should be ok.

2 Likes

There is a way that can be easier (for RM4 Pro 0x653c):

  1. Open Home Assistant and install “SSH & Web Terminal” add-on
  2. Disable Protection mode
  3. Connect to the device via SSH and install the patch:
ssh [email protected]
docker exec -it homeassistant /bin/bash
pip3 install git+https://github.com/felipediel/[email protected] --force-reinstall --no-deps
  1. Restart the server.

I have a RM4 Pro that I just received and installed from Ali Express also and I am not able to add it to HA even after I installed the patch above and restarted the server. It is unlocked from the app and I still get Device Not Supported when attempting to add device to HA integration.

pip3 install git+https://github.com/felipediel/[email protected] --force-reinstall --no-deps
Collecting git+https://github.com/felipediel/[email protected]
  Cloning https://github.com/felipediel/python-broadlink.git (to revision patch-23) to /tmp/pip-req-build-t624pdxf
  Running command git clone -q https://github.com/felipediel/python-broadlink.git /tmp/pip-req-build-t624pdxf
  Running command git checkout -b patch-23 --track origin/patch-23
  Branch 'patch-23' set up to track remote branch 'patch-23' from 'origin'.
  Switched to a new branch 'patch-23'
Using legacy setup.py install for broadlink, since package 'wheel' is not installed.
Installing collected packages: broadlink
  Attempting uninstall: broadlink
    Found existing installation: broadlink 0.16.0
    Uninstalling broadlink-0.16.0:
      Successfully uninstalled broadlink-0.16.0
    Running setup.py install for broadlink ... done
Successfully installed broadlink-0.16.0

I have a Broadlink RM4 Pro from last december and I get the same message “Device not supported” when trying to integrate it in HA.
I did everything with no success, so I gave up and use the evil thing only with it’s app
…until an expert would solve the integration in the future.
Thanks everyone for your comments and please, brainy experts, work on it!

Would be keen for more info on this when it gets updated.
Going through the same thing.
And when I add it this way I dont actually get to see the temp and humidity sensor either.

Has anyone got it working, I have and RM4 pro coming tomorrow :laughing:

Steps to complete:

For sure. Mine is working fine (0x653c) with steps above.

1 Like

I have it working. But the RF functionality of it isn’t working as intended

Yep, I got it to work without much trouble… just to realize my remote is bluetooth :sweat_smile:

Anyone tried installing this fix in 2021.01.5? It breaks my boot.

Any logs that might hint at a reason?