🔹 Browser_mod - turn your browser into a controllable device, and a media_player

Ah. As I don’t use button-cards with templates, etc. I cannot help any further. With a normal layout card containing entites cards, it is working that way and show then the shadows for the containing cards (again).

I see. Thx anyhow.

Can someone please tell me why this is still opening up full screen on my iPhone? I don’t know what else to try. Is there possibly some master setting over riding this code on the iPhone or in home assistant in general? This is just for a pop up card


tap_action:
  action: fire-dom-event
  browser_mod:
    service: browser_mod.popup
    data:
      title: NAME
      card_mod:
        style:
          ha-dialog$: |
            @media (max-width: 450px), (max-height: 500px) {
              div.mdc-dialog div.mdc-dialog__container {
                align-items: start;
                padding-top: 10px;
              }
            }
      content: test

Hi,
i have this code on my dashboard:

      - type: vertical-stack
        cards:
          - type: custom:state-switch
            entity: deviceID  #deviceID
            states:
              "Macbook": #mac
                type: custom:decluttering-card
                template: weather

and this template:

  weather:
    card:   
      type: custom:weather-card
      card_mod:
        style: |
          ha-card {
            background: none;
            box-shadow: none;                                 
          }
      entity: weather.saint_tropez
      icons: "/local/community/weather-card/animated/"

can any one tell me how to migrate this code to Browser_mod 2 ?
i tried many tricks at my side but nothing give me the same result as version 1.5

Hi All,
I have upgraded to 2.x and restored the popups I used to have before. I am now facing an issue but I’m uncertain it’s related to the new browser_mod release or HA one. I read the entire thread since 2.x release and I cannot find any occurrence that matches it.

Here is the issue:
I have a popup showing the cameras in a swipe content area:

When I tap on the live image it renders a picture glance with the live feed (action more-info is called), however it now shows the header with Info, Settings and Related tabs, which was not the case prior to the update:

Does anyone know how to hide it?

Thanks!

So funny. I was literally just coming here to ask that question! LOL THat is a result of HA combining the more-info and settings card. Terrible effect for the glance cards. This is more of a card_mod question btw.

Hi, everyone. The trouble had appeared after upgrade to version 1.xx.x and unfortunately remained in version 2.xx.x: when click on option arrow (pic1) I getthe option list not droppimg down, but somewhere in the middle (pic2). Here is the code:

                  action: fire-dom-event
                  browser_mod:
                    service: browser_mod.popup
                    data:                                      
                      title: "left"
                      content:                 
                        type: entities
                        entities: 
                          - input_select.light_select_effect_led

1

2

Could anybody solve it?

This seems to be a problem with dropdowns not overflowing on browser-mod popups.

Your dropdown has actually opened, it’s just hidden ‘inside’ the popup.

I noticed this in 1.x.x, but have not upgraded myself yet, so wasn’t aware it appears to be an issue in 2.x still.

I would suggest opening an issue on GitHub - my efforts to work around it by adding the CSS overflow setting using card-mod were unsuccessful, so I kind of gave up.

A workaround is to make a popup with more height, and ensure that any dropdowns are right at the top.

EDIT: issue already reported here

This is more a question about the custom state-switch card isn’t it?

It looks like Thomas will need to update it to work with the new browser_id.

Maybe ask on the thread for the state switch card, or you could add your thumbs up to the issue that’s been opened on GitHub (assuming it wasn’t you who opened it of course).

no and its really annoying? is anyone having this issue?

Having trouble with migrating to 2.x… especially with the closing of popups…
I use a custom “title bar” instead of the standard one so all my popups use:

popup_header:
  color_type: icon
  icon: mdi:close-box
  show_icon: true
  styles:
    name:
      - justify-self: start
      - padding: 0px 5px
      - font-weight: bold
      - color: white
    card:
      - background: DarkSlateGray
      - height: 30px
      - padding: 0 5px # make sure there are 5px on the sides
      - border-radius: 0px
    grid:
      - grid-template-areas: '"i n"'
      - grid-template-columns: 40px 1fr
    icon:
      - padding: 0
      - justify-self: end
  tap_action:
    action: fire-dom-event
    browser_mod:
      service: browser_mod.close_popup
      data: 
         browser_id: THIS

The “close” function is only working if the browser is registered (though the popup appears either way).

Anything obvious I am missing?

Hi, how to change popup windows size to which I want?

That’s a custom button card isn’t it?

Maybe you are affected by the issue reported here.

I have the exact same issue. I used the popup_cards section in the yaml with the earlier version and now I am reading that I would need to change to “fire-dom-event” and other stuff which is not how my code looked like so far. I would need to rewrite a LOT from scratch. Is there a way to make it work keeping the “popup_cards” section so it would just work instead of adding actions to each and every card?

Thanks!

Good day, upgraded fine to BM2 (browser_mod2), but facing an issue with multiple wall tabs running Fully Kiosk.
Setup as follows:

  • running Pi4 with HA
  • configured FullyKiosk on Samsung wall tab
  • upgraded to BM2
  • able to get wall tab loaded as browser mod device
  • bought a 2nd tab, and installed exactly same Fully Kiosk on that tab
  • did same process to load 2nd tab as broswer_mod device
  • it works when on browser_mod page, but soon as I load my home dashboard on 2nd tab. the device becomes unavalible and cannot be accessed on browser_mod tab on HA.
  • tried many scenarios, but cannot get the 2nd tab to work as a device on browser_mod ??

(see screenshots with 2 devices - but tabA81 becomes unavailable when i referesh to my home dashboard on fully)

Any ideas please? THANKS

image

I have a question that I have not seen addressed in this thread…

I have a browser_mod popup setup for a camera in the garage with buttons for open and close…
image

name: Browser pop normal
show_state: false
icon: mdi:test-tube
tap_action:
  action: fire-dom-event
  browser_mod:
    service: browser_mod.popup
    data:
      content:
        type: picture-entity
        entity: camera.garage_camera
        show_state: false
        camera_view: live
      timeout: 20000
      size: normal
      right_button: 'Close Door'
      left_button: 'Open Door'
      right_button_action:
        service: cover.close_cover
        data:
          entity_id: cover.garage_door_controller
      left_button_action:
        service: cover.open_cover
        data:
          entity_id: cover.garage_door_controller
type: custom:button-card

when I click on the button the popup closes, is there a way to configure the popup tp stay open on the button click? I would like to close the door and keep the popup open till its closed…

5 Likes

Did you solve your problem ? I updated today and can see the same symptoms. To be certain I didn’t have some stale cache in the app, I even uninstalled completely and reinstalled the android companion app, to no avail. Everything works a charm, except for the media player that is always unavailable no matter what I do.

Bump

Can someone please tell me why this is still opening up full screen on my iPhone? I don’t know what else to try. Is there possibly some master setting over riding this code on the iPhone or in home assistant in general? This is just for a pop up card


tap_action:
  action: fire-dom-event
  browser_mod:
    service: browser_mod.popup
    data:
      title: NAME
      card_mod:
        style:
          ha-dialog$: |
            @media (max-width: 450px), (max-height: 500px) {
              div.mdc-dialog div.mdc-dialog__container {
                align-items: start;
                padding-top: 10px;
              }
            }
      content: test

Unfortunately, no, I ended up switching from WallPanel to FullyKiosk because I did not had the time to investigate further.
It’s strange that the media player works perfectly in browser, fully kiosk, HA companion app, but not in WallPanel.
Hopefully in the next days / weeks I will have time to check it out, because Fully Kiosk has a delay and sometimes freezes, that’s why I prefer WallPanel.

Don’t get excited too quickly… i run fully kiosk on all my tablets and it’s still happening that media player become unavailable. Pattern is unknown…just “now and then”.