🔹 Browser_mod - turn your browser into a controllable device, and a media_player

Raised an issue

1 Like

I see :frowning: I don’t know why it is not working for me… I have card_mod installed…

Strange… two things to try:

  • clear cache & restart browser
  • create a new empty view, paste in the yaml below into a ‘manual card’ via the UI and see if it works in a single view with no other cards.

beyond that you could try a different device/pc and if it’s still not working then it’s a problem with your card_mod install.

type: custom:button-card
entity: media_player.bedroom_tv
icon: mdi:remote
color: auto
size: 20%
name: Room TV
tap_action:
  action: call-service
  service: media_player.turn_off
  service_data:
    entity_id: media_player.bedroom_tv
hold_action:
  action: fire-dom-event
  browser_mod:
    service: browser_mod.popup
    data:
      style: |
        --ha-dialog-border-radius: 0px;
        --popup-border-width: 20px;
        --popup-border-color: #1c1c1c;
      content:
        type: vertical-stack
        cards:
          - type: horizontal-stack
            cards:
              - type: custom:button-card
                entity: media_player.bedroom_tv
                name: Volume UP
                icon: mdi:arrow-up-bold
                show_name: false
              - type: custom:button-card
                entity: media_player.bedroom_tv
                name: Channel UP
                icon: mdi:arrow-up-bold
                show_name: false
          - type: horizontal-stack
            cards:
              - type: custom:text-divider-row
                text: VOLUME
              - type: custom:text-divider-row
                text: CHANNEL
          - type: horizontal-stack
            cards:
              - type: custom:button-card
                entity: media_player.bedroom_tv
                name: Volume DOWN
                icon: mdi:arrow-down-bold
                show_name: false
              - type: custom:button-card
                entity: media_player.bedroom_tv
                name: Channel DOWN
                icon: mdi:arrow-down-bold
                show_name: false
          - type: horizontal-stack
            cards:
              - type: custom:text-divider-row
                text: '|'
          - type: horizontal-stack
            cards:
              - type: custom:button-card
                entity: media_player.bedroom_tv
                name: Mute/UnMute
                icon: mdi:volume-mute
                show_name: false
              - type: custom:button-card
                entity: media_player.bedroom_tv
                name: Source
                icon: mdi:cached
                show_name: false
      card_mod:
        style:
          ha-dialog$: |
            div.mdc-dialog__scrim {
              backdrop-filter: blur(15px) !important;
              -webkit-backdrop-filter: blur(15px) !important;
            }
style: |
  ha-card{padding-top:20px !important}
  #name{font-size:12px !important;padding:10px}
  {% if states('media_player.bedroom_tv') == "off" %}
  :host {display:none !important} {% endif %}
1 Like

I think I made it working, but only adding the extra_module_url: And now it is working on Chrome, but still not on Firefox :smiley: Maybe the cache thing, I will try it. Thank you!

1 Like

I am not able to open the configuration panel of Browser_mod in my mobile app. I always get a blank screen, so i am not able to register the browser on my mobile.
Any hints?

I saw somebody describe the removal of the image if that is all that your after on the github issue 400.
I think for me and others though the touching of the screen is not a viable option for alot of use cases wherein people want to play warnings or use it as a media player. So hoping somebody has a work around or hack

is there a way to change the background color of the pop-up? it uses the same color as the cards that i´m using so i don´t see them

I had Fully Kiosk working with the Browser_mod and could see my tablets camera feed and also click it to get a pop up from other browsers (not on the tablet itself). Now since the update to version 2 I lost that and I cant get the right card config to get the pop up to work again. I managed to figure out the fire-dom-event settings for my other more info cards and gauges today.

Now when I click the Picture Glance Card I get a pop up header but nothing else…and the binary_sensor.browser_mod__d68c6acb_3261e7b4 was the old id on the previous 1.xx.xx integration…I assume that changes now in the ne integrations? But I done see the new ones in HA for the moment.

camera_view: auto
type: picture-glance
title: Control Panel
entities: []
aspect_ratio: 60%
camera_image: camera.browser_mod_d68c6acb_3261e7b4
image: /config/www/cam_snaps/

Do I have to make any changes to the Fully Kiosk set-up on the tablet? It was a year ago when I initially set up the tablet and HA now I cant remember what i actually did to get it all working…

This camera doesnt show up anymore in my system, does the new integration still support “camera.browser”?

camera.browser_mod_d68c6acb_3261e7b4

Thanx for any assistance possible.

good evening, I do not know what am I doing wrong for weeks, since I updated to the latest version of the browser-mod in all platforms (tablet, smartphone, PC) I have display problems, when I open HA I only see the bar in high and the background image and empty the center, after having done numerous refreshes and updates the page I can view regularly. I followed several suggestions removed the old version, cleared the cache etc. but without results what can I solve?

Blur doesnot work on android app…does it work for you?..and even in pc animation is kind of buggy (looks like 10fps motion) with blur…without blur its cool

I don’t have any Android devices to test with but it should work as expected. Animations look good on my devices.

Is there a way to register the browser in browser_mod 2 without using the sidebar? I hide all of that stuff on tablets and it would be much easier to simply add a card, do the registration and then remove the card afterwards, without having to undo all of the side panel hiding etc.

hi, before the update I used the navigation service to move between the various home assistant areas.
Now the browser_mod.navigate service doesn’t work for me when used in a template switch:
This is the code:

switch:
  - platform: template
    switches:
      hacs_update_available:
        value_template: >-
          {% if states('sensor.hacs') > '0'  %}
            off
          {% else %}
            on
          {% endif %}
        turn_on:
          service: browser_mod.navigate
          data:
            path: /hacs/entry/
        turn_off:
          service: browser_mod.navigate
          data:
            path: /hacs/entry/

Someone who can help me pleaseee!!!

How hard is it to revert back to the last 1.5.3 version and regain the features that I have lost since upgrading? Has anyone done that already? I did manage to get my dashboard card pop-ups working again so if I roll back to 1.5.3 will they still work with the new coding or will I have to revert back that to the previous configurations? Its a deal breaker for me that my wall tablet running Fully Kiosk can no longer be found as a camera entity so I lots a window in to my kitchen for surveillance.

Or has anyone else managed to over come this and can share some tips?

Have you enabled the browser_mod camera on the device?

1 Like

Welcome to the forum. Please format your posts. It is difficult to read the code you posted.

This service call still works fine with browser_mod 2.0.

service: browser_mod.navigate
data:
  path: /hacs/entry

Hiding the sidebar on any or all devices is a simple toggle. How can that possibly be more work than adding and removing a card?

1 Like

Hi @jazzyisj

Thanx for the reply. How do I get the tablet which is running Fully Kiosk to pop the browser window so that the tablets id then comes in to the Browser_mod interface? I have enabled that option for other device browsers, but so far the wall tablet didn’t show up.

Can you not open the sidebar on your kiosk tablet? If not you may have hidden it with browser mod already.

Make sure you are logged into a HASS dashboard as an admin. Go to the front end settings and make sure the sidebar hidden setting is false for your kiosk tablet. Click the edit pencil to change if necessary.

If not, DELETE the browser mod registration for the kiosk table from the admin dashboard browser mod, refresh the kiosk tablet. You should be able to open the sidebar to access browser mod.

1 Like

Thanx found it. In browser mod. There was only the GLOBAL DEFAULT under browser settings. So I added a user and selected my wall tablet.

The switch is off which gives false.

What does this seeing actually do? If it to hide the side bar on the wall tablet? I’m not at home so can’t check but before the fully kiosk was set up to display full screen without the HA side bar.

Edit: oooohh I like it! So now I can set my wife’s phone to only use the dashboard that I created for mobile screens! :heart_eyes:

But how do I pop the wall tablets Brower so it shows up in browser_mod? I have full admin remote access to fully kiosk available here with me.

Thanx for your help and guidance.