Button card no longer appearing on my cast dashboards (but everything else works)

The problem

A few days ago, the built-in button card stopped appearing on the cast dashboard (but everything else, including custom:button-cards, still works fine).

I’m casting my Home Assistant dashboard to multiple Google Nest Hub v2 devices.

The standard buttons appear in the mobile app or when viewing from a web browser, just not when using the cast integration to cast the dashboard to the Google Nest Hubs.

What it looks like in a browser

What it looks like on my Google Nest Hub

All the buttons that are working are custom:button-cards

What I’ve tried

I created a new dashboard with a couple of buttons and some other cards, and the buttons don’t show up on this much simpler dashboard when cast either (but the buttons show up in a browser).

I restored a full backup (using the backups restore feature) from before the buttons disappeared, but that made no difference.

I’m running Home Assistant on a VM, so I restored the last complete backup of the whole computer from 2 months ago, and strangely that made no difference either.

Since a 2-month-old backup of the VM didn’t fix it, I dug out an older Google Nest Hub v1 with older firmware (powered off for months) to see if buttons would work on it, and I don’t think it immediately updated when I turned it on. Either way, the buttons didn’t show up on it either.

What is going on?

I’m quite stumped about why this is happening (and there’s no error reporting when a cast object doesn’t show up (that I know of)).

This started weeks after installing 2023.3.6 and is still happening after the update to 2023.4.2 (the latest at the time of this post).

Does anyone have any ideas? Has anyone else run into this problem?

edit 1: Feels very similar to this cast problem

edit 2:
Is this what the Home Assistant Cast Demo screen is supposed to look like or is this missing buttons too?


Hi, I am experiencing the exact same problem. I also experienced the “cast problem” you referred to which was resolved after installing the beta version suggested by the forum.

1 Like

Hi, just updated to 2023.4.3. Same issue here now.

looks like the issue is tracked on github here: Casting to Nest Hub shows incomplete dashboard · Issue #91274 · home-assistant/core · GitHub

there’s another issue tracked here for 2023.4.3: Button card not showing in 2023.4.3 · Issue #16155 · home-assistant/frontend · GitHub, applying the workaround described has made my buttons show up and work again on my cast display!

same here - no button card on everything except google chrome browser

You can click the git link above or read my thread about this and the workaround fixing it for now.

This problem resolved itself overnight. The missing buttons reappeared on my dashboard by the time I woke up.

I’m glad it’s working now, but it still doesn’t make sense. I had the problem even when I reverted to 2023.2.x, and it was resolved without making any changes on my end (seemingly).

Did it resolve for anyone else without you doing anything?