Buttons not showing on Actionable Notifications on iOS app

The notification message and title show up but the notification action button does not. I used the Automation UI to create this and have the latest version of home assistant 2021.12.9. Can anyone help me with a fix? The automation yaml code is shown below.

- id: '1642376820933'
  alias: Garage Notification
  description: ''
  - platform: state
    entity_id: input_boolean.test
  condition: []
  - service: notify.mobile_app_iphone13promax
      message: Garage Door open
      title: Garage Door Status
        action: CLOSE_DOOR
        title: Close Door
  - wait_for_trigger:
    - platform: event
      event_type: mobile_app_notification_action
        action: CLOSE_DOOR
    timeout: 00:01:00
    continue_on_timeout: false
  - service: notify.mobile_app_iphone13promax
      message: Door was closed
      title: Door notification
  mode: single

I am having the same issue. One observation on your case I think you are missing the “actions:” before the “-action:’ list item

Hi Antonio I have tried both ways aka with actions: then an indented action: and it makes no difference as the outcome is the same… No Action button appears as part of the notification. Hopefully someone else can chime in with some offered solution.

Im facing the same issue, but only on my iPhone.
My Tablet works perfectly with the same script (I´ve just replaced the „Device to notify“.)

So I thinks it´s something with the notification options on the phone. But when I compared both settings (iOS and Settings in the HA App) they where exactly the same. IOS Version is the same as well :confused:

Hi All,
I’m having a similar issue… no buttons appear on my phone. Interestingly enough, if I let the my apple watch display the notification instead, I get the buttons. So I think @mozdi is moving in the right direction that this is a phone setting/option issue.

I also just noticed that if I hold down the notification the buttons appear. Does this happen for anyone else?

I updated to HA 2021.12.9 and updated/reinstalled my mobile app integration and the buttons now appear for notifications on my iPhone. No hold down is required.

I guess I got lucky because nothing else worked.

Same for me, I have to hold in order to see the actionable notifications. i’m on 2022.2.6

Did anyone find an answer to this? I can get the buttons with a long press/force touch on my iPad/iPhone but would love the buttons to display by default

Apple watch displays the buttons correctly, so thats my saving grace but my wife doesn’t have Apple watch (yet)

HA 2022.4.7

Same here: HA 2022.5.2, iOS 15.4.1, Companion 2022.3 (2022.358)

the same problem with both iOS and HA up to date…
but it’s the first time tried them so not like they stopped working or something…

cosslinked issue here:


to close on my issue:
Not sure what helped but what lead to solution was messing around Mobile App - adding new server, setting up a new device name, then getting back to previous name.
In history you can still see working and not working actionable notification though automation was exactly the same. Hopefully this can help someone.

First of all I was pulling my hair out because actions worked on the watch, but not on the goddamn phone. :face_with_symbols_over_mouth:

Now I am at the point that I have completey removed the app profile but never get the direct buttons. I have to do a long press, then the actions get loaded, then I can use them…

Anyone found a way to get the buttons for the actions directly displayed on the lock screen or in the banner when the device is unlocked?

This is how it is supposed to work from everything I’ve read. My issue though is even holding down the notification, no action buttons ever appear. So I must have something else going on. Anyone solve for this?

as you can read above i had the same, now it works. To me it was the App to blame.

Still not working for me either even changing server profile. Anything new to fix this issue?

Still need to press down on the notification for the buttons to show. I think i have seen it showing the buttons when the notification was tapped. Is this new iOS behaviour?

I also have this problem (no buttons shown for actionable notification, but holding down on the notification does show the options). HA 2023.2.4, Supervisor 2023.01.1, OS9.5, and iOS app 2023.2. Just reinstalled the iOS app and it acts the same.

Did anyone ever solve this issue? I have to hold down the notification to get the actionable notifications. Also, when I do click on them, nothing happens. The notification just goes away