Camera Xiaomi Mi Home 360 - how?

Hi everyone.

I bought this camera, Xiaomi Mi Home, and I thought it was easy to add it to HA, but I was wrong.
Mine is version MJSXJ05CM, and I tried to follow a tutorial, but it is impossible to downgrade the firmware, in other words, I cannot integrate it to my HA

Recently, someone told me to install “Xiaomi MioT Auto” …and I did. After to install it, to add my credential, it lists my devices, and yes, it has 3 entities related to my camera:
image

The problem is: I try to add each one of these entities, but nothing works… Am I doing anything wrong?

Thank you in advance

1 Like

I have the same camera and just tried “Xiaomi Miot Auto” from here (via HACS):

Same as your screenshot I have those three entities for the camera.
The “switch_status” one seems to work for switching the camera off and back on.
The “motion_event” one seems to always be unavailable for me (even when I try to trigger some motion).
The “camera_control” one seems to give me a video feed of the last few seconds or so, delayed by a few seconds. However, I only seem to get a frame every ~12 seconds or so if I add it to my dashboard (could very well be me not knowing how the card works though - it has an overlay at the bottom of the screen which says “Video camera Camera Control” on the left and either “Streaming” or “Idle” on the right).

Overall it seems promising, especially as it identified the local IP address of the device, so hopefully this could work without internet access for the camera.

1 Like

I see exactly the same.

Do you have any furthers ideas on how to get livestream onto the dashboard by any chance? I can only get only a few secs and then it goes away.

Mine doesn’t work at all…not even this live feed with 3 seconds. Could you show me a screenshot to understand where you guys see this?




I see the same, down to the exact firmware version. The only difference is in the final screen (accessed from clicking the settings-looking icon in the top right of the dialog from the “Camera Control”) - here the video player dialog shows a short amount of video (~18 seconds) from around an hour ago (might be when I last restarted Home Assistant).

If I try to add this “Camera Control” entity to my dashboard, I get a frame of video which appears to be from the time I added it (with a caption of “Idle” rather than “Streaming”) - so it seems to be able to get the data but isn’t doing it consistently/in a useful manner just yet.

@Guilherme_Gimenes After a day or so I had a look again and I’m seeing exactly the same as in your screenshot - going to the “Camera Control” shows a blank video player with 0 seconds duration.

Looks like I’ve got a similar issue, although I don’t get any video not even a couple of seconds worth. I do however keep getting a notification in the Xiaomi Home app that the stream is being viewed by HA.

This is all i see on my dashboard for the video feed.

Screenshot 2022-07-07 at 09.22.19

same here… I´m still waiting for a definitive solution…

Hello! I tested with https://github.com/al-one/hass-xiaomi-miot and it’s kind of working. The only problem is that it’s lagging (~15-20 sec). Does someone has the same problem?
I even set up a custom.yaml


camera.chuangmi_021a04_80be_camera_control:
  video_attribute: 3 # https://github.com/al-one/hass-xiaomi-miot/issues/11#issuecomment-773054167
  keep_streaming: true # Continuously update stream address

but again it’s the same. Is there a way stream live?

1 Like

lucky you, because I have followed the procedure you just mentioned, and nothing happens here, not even a lagged image. (the screenshots are above)

Thank you for your contribution.
I had the same problem as Guilherme but then I updated HA core to the latest version and now it works with 15sec delay as reported by ppeev.

But still, if I click the motion_event entity, I get no video. Only live preview for camera control entity.

where do u see this video with 15s delay? I never got any video at all …not even delayed, nothing

I go to device, click something like “add to dashboard” and it is there

After some hours of testing I confirm, it works, has the delay of 15seconds.

In order to fix my issues I needed to configure properly customization and use:

keep_streaming: true

I needed to reboot each time I was changing the configuration. And additional settings for event_stream_[…] werestopping my camera integration. So I needed to remove them all and leave just

camera.chuangmi_021a04_xxxx_camera_control:
  video_attribute: 3
  keep_streaming: true

More information is here: Home assistant is unable to catch up with camera stream URL - bytemeta

Could you share the steps you did to make it work?
I’ve added my camera via Xiaomi Miot Auto (connected using mi account), I can see my camera in devices and I can turn it on and off, but I can’t see the stream. I tried adding the attributes you mentioned, but it didn’t help. Now mi home sends me constant messages, that I’m watching the stream, but I can’t actually see it. Did I miss anything?

1 Like

My camera is a bit different than yours
image
image

@alisa @Guilherme_Gimenes , I managed to figure it out you are getting no image because you need to enable Home Surveillance on the Xiaomi App for the camera you added. It will send you an image each time it detect movement.Screenshot 2022-08-29 at 16.33.42

I recently bought this camera MJSXJ09CM. Firmware version 4.1.6_0310
https://home.miot-spec.com/s/chuangmi.camera.029a02

And I can’t see the online stream in my HA dashboard. All I can see is a frame from the last time motion was detected,

  • When I click the frame it opens a video player, but it won’t load anything
  • All my camera entities stays “IDLE”
  • I have “surveillance mode” enabled on the mi home settings
  • I have set the video_attribute and keep_streaming configurations

I don’t know what else to do, can someone help me sort it out?

update:
I had enabled the password for the camera on the mi home app.
Disabling the password got the camera_control entity to stream, but as everyone said, the stream is about 15 seconds delayed. Also unless I click the entity it only displays 1 frame for about 10 seconds, if I want to watch the stream I have to click the entity to maximize the video player

I have two questions now:

  • After a few minutes the camera stream starts looping forever, only restarting the Home Assistant gets it working again, but after some time it goes back to looping a few seconds
Logger: homeassistant.components.stream.stream.camera.chuangmi_<cameraId>_camera_control
Source: components/stream/__init__.py:416
Integration: Stream (documentation, issues)
First occurred: 11:56:43 AM (37 occurrences)
Last logged: 1:48:47 PM

Error from stream worker: Stream ended; no additional packets
Error from stream worker: Error opening stream (HTTP_FORBIDDEN, Server returned 403 Forbidden (access denied)) https://us03.livestreaming.io.mi.com/hlstranscoder/<url>/playlist.m3u8
  • Can I somehow keep the PIN on the camera and configure it on the integration to use the PIN?

I have a 05 mode od camera, adden by Xiaomi auto integration, added cuztomization to mail entity (camera Control) keep streaming true and video attribute 3, disabled pin on Xiaomi app and enabled home monitoring but camera os still on idle mode.
There os no loop or delay😱