Can not add Broadlink rm mini 3 to HA 0.92.1

I’ve just bought a new Broadlink RM mini 3 to replace xiaomi IR remote. I thought it will be an easy upgrade but turns out it is not. I can not add it to the HA using this configuration:

  - platform: broadlink
    mac: 'mac_address'
    timeout: 30

No log error, no entities, no service related to broadlink. I can still ping the ip of broadlink and get response. And can remote control my TV using ihc app. My system is HA 0.92.1 on raspberry pi 3 B+
So is there any method that i can debug the communication problem between HA and Broadlink RM mini 3?
Help me out please

This is what i have in my config:

  - platform: broadlink
    mac: 'B4:43:0D:CC:0F:58'
    timeout: 15
    type: rm2_pro_plus

Maybe try a type?

I did try with with type but it is still not added

There’s an open issue about RM mini on Github.

1 Like

Thanks @VDRainer! I will look into that

I try to downgrad to 0.91.3 and broadlink work fine now

It seems that you have rm2_pro. I also have it and have no problem with it after upgrading to 0.92.1. Looks like only the mini is affected.

It has been said that this issue was fixed on 0.92.1 ( But I still have this problem on my hassio 0.91.2, can anyone help please ?

I have an 0.92 problem with Broadlink minis as well. Switches that were configured worked in HA after I called them from google voice, not from the HA panel. Scripts do not work at all.

I am having the same problem, the switch for rm pro doesnt work, any solution?

This is the error I get:
Error executing service <ServiceCall script.pc_off (c:58855c6f9f4b40c2a1096420021bc3b5)>
Traceback (most recent call last):
File “/usr/local/lib/python3.7/site-packages/homeassistant/”, line 1147, in _safe_execute
await self._execute_service(handler, service_call)
File “/usr/local/lib/python3.7/site-packages/homeassistant/”, line 1160, in _execute_service
await handler.func(service_call)
File “/usr/local/lib/python3.7/site-packages/homeassistant/components/script/”, line 114, in service_handler
File “/usr/local/lib/python3.7/site-packages/homeassistant/components/script/”, line 172, in async_turn_on
kwargs.get(ATTR_VARIABLES), context)
File “/usr/local/lib/python3.7/site-packages/homeassistant/helpers/”, line 131, in async_run
await self._handle_action(action, variables, context)
File “/usr/local/lib/python3.7/site-packages/homeassistant/helpers/”, line 210, in _handle_action
action, variables, context)
File “/usr/local/lib/python3.7/site-packages/homeassistant/helpers/”, line 299, in _async_call_service
File “/usr/local/lib/python3.7/site-packages/homeassistant/helpers/”, line 89, in async_call_from_config
domain, service_name, service_data, blocking=blocking, context=context)
File “/usr/local/lib/python3.7/site-packages/homeassistant/”, line 1115, in async_call
raise ServiceNotFound(domain, service) from None
homeassistant.exceptions.ServiceNotFound: (ServiceNotFound(…), ‘Service switch.broadlink_send_packet_192_168_0_105 not found’)

have you confirmed that’s the correct config for broadlink, pretty sure the switch.broadlink_send_pack is no longer valid

1 Like

This is what I have in my switch.yaml file:

- platform: broadlink
  mac: 'my mac address'
  type: rm2_pro_plus

Same here with rm mini, all my switches are reporting “Entity not available”… Any solution?

do you have an automation that calls switch.broadlink_send_packet

My RM mini is working fine with version 0.92.2! But I had to change my scripts recently from “switch.broadlink_send_packet” to “broadlink.send”.

# Broadlink IR-Blaster
  - platform: broadlink
    host: Your-Broadlink-IP-Adress
    mac: "Your-Broadlink-MAC-Adress"
    friendly_name: RM mini 3

and in my Scripts/automations I use:

  alias: IR Device Command 1
  - data:
      host: Your-Broadlink-IP-Adress
      packet: The-needed-IR-code=
    service: broadlink.send

Good luck!

That seems to have done the trick for me, thanks!
If a few more people jump in with this as a solution I’m thinking to have a bash at changing the docs to reflect the working change…

yes I have a script which calls it

Can you post one of your scripts formatted?

You need to update it to the new format

1 Like