Cannot open Control Panel (ozwcp) Cannot find a path to the configuration files

Tags: #<Tag:0x00007f73991e0d48> #<Tag:0x00007f73991e0bb8>

Hi guys
Ran the All in one installer and up to my z-wave config. Thought I may have mucked up the install so I ran it again and still having issues.

As per the docco I stop the HA service
Cd to /srv/homeassistant/src/open-zwave-control-panel/
Run sudo ./ozwcp -p 8888

Get the following:

2017-02-10 22:46:57.918 Error, Cannot find a path to the configuration files at ./config/. Exiting…
2017-02-10 22:46:57.925 Error, Exception: Options.cpp:91 - 1 - Cannot Find Configuration Files
Error: Options.cpp:91 - Cannot Find Configuration Files

The documentation says that AOI set this all up for you an no need for manual steps
I’m a novice here. Any simple instructions would be very appreciated.

Did even try putting the config_path option in my configuration.yaml file as recommended byan online video. Updated the path to the latest version although I think the prob lies somewhere with the files on the device.

zwave:
usb_path: /dev/ttyACM0
config_path: /srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/libopenzwave-0.3.2-py3.4-linux-armv7l.egg/config

Thanks

After a long time I finally fixed it myself right after posting!
Not much of a linux person either so dont know how I did it.
Well found that in /srv/homeassistant/src/open-zwave-control-panel was a config file I could only read in winscp
It was a symlink point to:

/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/libopenzwave-0.3.1-py3.4-linux-armv7l.egg/config

This doesnt exist on my setup. This does:
/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/libopenzwave-0.3.2-py3.4-linux-armv7l.egg/config

So first I went to the directory the incorrect file is in:
/srv/homeassistant/src/open-zwave-control-panel

Renamed it:
sudo mv config configold

Created a new symlink:
sudo ln -s /srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/libopenzwave-0.3.2-py3.4-linux-armv7l.egg/config /srv/homeassistant/src/open-zwave-control-panel/config

Hope this helps some other fella

7 Likes

Yes it helped some other fella. Me. Thanks. :slight_smile:

yup! found the same problem when using all-in-one 3.7.1.

thanks for the solution.

Thanks! Was just about to post my own problem and found this!
I used the All-In-One 0.38.3.

Great, thanks for posting this, helped me out aswell.

And another person you helped! Thank you so much for sharing the solution.

Thanks, this solved my issue after much headaches

Wow! It helped me too. For me it was now 0.3.3 as shown below also using WnSCP I was able to edit the link by right click on existing link and edit then just changed to 3 from 1 and all started working. Thanks a lot.

/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/libopenzwave-0.3.3-py3.4-linux-armv7l.egg/config

I have same problem but in HASSBIAN, where is the homeassistant_venv directory? Or what shall I do to fix?

In my case is
sudo ln -s /srv/homeassistant/lib/python3.4/site-packages/libopenzwave-0.3.3-py3.4-linux-armv7l.egg/config /srv/homeassistant/src/open-zwave-control-panel/config

Wow!! so many hours looking for a solution. Thats for posting. I had this issue with Hassbian v1.2. I pointed it to this directory /srv/homeassistant/src/python-openzwave/openzwave/config

1 Like

joelphillips, can you please post the specific steps to fix this in Hassbian?

First rename that config file, right?
sudo mv config configold

Then what command did you run?

In case any of this info is important, here’s what I’m seeing on my system…
/srv/homeassistant/src/open-zwave-control-panel/config
is a symbolic link that points to
/srv/homeassistant/lib/python3.*/site-packages/libopenzwave-0.*-linux*.egg/config

It doesn’t exist but this does: /srv/homeassistant/lib/python3.4/site-packages/libopenzwave-0.4.0.31-py3.4.egg-info

There is also a symbolic link named config at
/home/homeassistant/.homeassistant/
that points to
/srv/homeassistant/lib/python3.*/site-packages/libopenzwave-*-linux*.egg/config

/srv/homeassistant/src/python-openzwave/openzwave/config
is a folder in that also includes a symbolic link named config that points to
/srv/homeassistant/lib/python3.*/site-packages/libopenzwave-0.*-linux*.egg/config

Figured it out
sudo ln -s /srv/homeassistant/src/python-openzwave/openzwave/config /srv/homeassistant/src/open-zwave-control-panel/config

Finally wrapped my brain around the fact that I had the syntax for which file was pointing to which backwards in my head for ln. When I had it backwards and my brain was mush trying to figure out what all of this meant I created a symbolic link in /srv/homeassistant/src/python-openzwave/openzwave/config that points to /srv/homeassistant/lib/python3.*/site-packages/libopenzwave-0.*-linux*.egg/config
I should delete that, right? Just making sure there isn’t supposed to be something else named config in that folder before I just delete it.

1 Like

After a couple hours of failure (couldn’t find config error) trying to install openzwave with hassbian I gave up and went to bed. I tried again this morning and no luck (even compiled openzwave outside the venv) UNTIL I stumbled across your post. Many thanks for sharing the linking of the file.

Hello ! Please help me. after rename that config file.
sudo mv config configold

I have config and configold file in /srv/homeassistant/src/open-zwave-control-panel

and here is libopenzwave-0.4.0.31.egg-info folder not a libopenzwave-0.4.0.31.egg/config

and in folder libopenzwave-0.4.0.31.egg-info are those files:

Two posts above yours I posted what ended up fixing it for me (looks like it worked for reichley, too). It created a link here /srv/homeassistant/src/open-zwave-control-panel/config
that points to here /srv/homeassistant/src/python-openzwave/openzwave/config

What do you have here? /srv/homeassistant/src/open-zwave-control-panel/config
And you might want to check the config link you have in your first picture. I don’t know how to do that in that windows folder, but from a command line it’s ls -l

I’m still on version 0.43 partially because I was afraid the Z-wave changes in .44 & .45 might change this and I’m waiting for when I have a few hours to fix it, if that’s the case :slight_smile:

Kind sir- the same directory exists on my machine - /srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/libopenzwave-0.3.2-py3.4-linux-armv7l.egg/config

but! I do not seem to have a directory /srv/homeassistant/src/open-zwave-control-panel

the only item in my /srv/homeassistant/ is homeassistant_venv, I don’t have /srv/homeassistant/src/

I’ve been using zwave for a while, but need to access the open zwave control panel now. Any idea where I should look?

thank you!

EDIT: Nevermind! As I have Home Assistant version 0.50 (and I bet a little older would be okay too) I was able to call add node secure from the front end.

Many thanks, helped me out as well. I had to change the symlink to the versions I had installed: sudo ln -s /srv/homeassistant/homeassistant_venv/lib/python3.5/site-packages/libopenzwave-0.3.3-py3.5-linux-armv7l.egg/config /srv/homeassistant/src/open-zwave-control-panel/config

That’s fixed me too - on version 52 so the command is now - sudo ln -s /srv/homeassistant/homeassistant_venv/lib/python3.5/site-packages/libopenzwave-0.3.3-py3.5-linux-armv7l.egg/config /srv/homeassistant/src/open-zwave-control-panel/config

Thanks for the very helpful post.

1 Like