Climate Airconwithme

Anybody have an Airconwithme account for Mitsubishi Airconditioners . Anybody knows if there is a integration possiblity or feature request for this?

Kind regards

Andreas

Hi Andreas,

Did you manage to get this to work? I recently purchased the same Airconwithme modules.
I was wondering if and how to integrate it into HA.

Thanks in advance,
Pol

same here.

Has anybody sniffed maybe network traffic.

I wrote airconwithme / intensis but they are not that open minded …

nothing yet. seems like nobody uses this function here :slight_smile:

Any updates one this?

I have a bash script that can control the airconwithme units directly via IP (not cloud) however I have no idea how to get that into a thermostat card in HA

  1. Is port 3310 open on Airconwithme (I assume not)

  2. Have you tried controlling it directly with the internet disconnected? I suspect the HTTP endpoint on the Airconwithme may just be relaying the commands to the cloud

  3. Try installing the Intesishome platform on Home Assistant.
    You’ll need pyintesishome.py on your Home Assistant server (it will be in site-packages/pyintesishome) and edit the server address on line 12.

Change INTESIS_URL to “https://user.airconwithme.com/api.php/get/control

If this works, I’ll add a configuration parameter to the platform to select either Airconwithme or Intesishome (+ custom URL to allow any future changes)

1 Like

@jnimmo Only port 80 is open at Airconwithme.
I changed the url and get after a restart an error in HA log:

2019-09-11 21:01:11 ERROR (SyncWorker_15) [pyintesishome] <class 'KeyError'> Exception. ('224571441633544',) / '224571441633544'
2019-09-11 21:01:20 WARNING (MainThread) [homeassistant.components.climate] Setup of platform intesishome is taking over 10 seconds.
2019-09-11 21:02:10 ERROR (MainThread) [homeassistant.components.climate] Setup of platform intesishome is taking longer than 60 seconds. Startup will proceed without waiting any longer.

@jnimmo I also tried to update the URL but I am getting the same error. It appears that the keyerror has to do with the deviceid.

The response is a bit different. It is missing the list of devices:

@jnimmo @Cinamon
Guys I managed to get this working based on @jnimmo work.
It seems that the Airconwithme unit doesn’t return any installations. I made a quick hack to add the unit manually in the code and now my Airconwithme unit works.

I changed the following lines of code:
INTESIS_URL = "https://user.airconwithme.com/api.php/get/control"

In the function: def poll_status change

# Update device status
for status in status_response['status']['status']:
  self._update_device_state(status['deviceId'], status['uid'], status['value'])

into

# Update device status
for status in status_response['status']['status']:
  deviceId = str(status['deviceId'])
  if deviceId not in self._devices:
    _LOGGER.info("Adding Airconwithme device ID %s", deviceId)
    self._devices[deviceId] = {"name": "Airconwithme", "widgets": {}}
    _LOGGER.debug(repr(self._devices))
  self._update_device_state(deviceId, status['uid'], status['value'])

It is not the best solution but it works for now.
@jnimmo you probably have a better solution :slight_smile:

@jnimmo @andreas.r.hauser
So after some more testing I saw that the API version was different. By just changing the URL and the API version it now works for the Airconwithme devices. The API version is 1.6.2 instead of 1.8.5. By specifying 1.6.2 it will return the installations in the initial call

#INTESIS_URL = "https://user.intesishome.com/api.php/get/control"^M
INTESIS_URL = "https://user.airconwithme.com/api.php/get/control"^M
INTESIS_CMD_STATUS = '{"status":{"hash":"x"},"config":{"hash":"x"}}'^M
#INTESIS_API_VER = "1.8.5"^M
INTESIS_API_VER = "1.6.2"^M
1 Like

Nice! I am gonna try that! Thx for the research and sharing from this solution!!

1 Like

It works perfect! Thanks a lot! @jnimmo can you make a different custom component for this one?

is there any way I can that working with hassio ?

Yes! Are you running hassio as OS or are you running it in docker?

hassio os, :slight_smile:

I found another option to fix it.
Install inside hassio portainer. Then go to the portainer webinterface, settings and you see hidden containters. Remove the label behind homeassistant containt.
Homeassistant shows at the container overview, you can edit the files you need :wink:

Would someone mind setting me up an account I can log into their Airconwithme to test my updated version of pyIntesisHome which will support both platforms with a configuration switch?

@jnimmo Do you still want a account to check?

That’d be great if possible - or see how you go with your testing first.