Cloud Update


#21

Because this is a proper Alexa Smart Home Skill that will operate other devices as what they are, emulated_hue, for all it’s brilliant simplicity, just pretends to be a bunch of Hue light bulbs.

If that’s all you want/need then stick with it :+1:


#22

maybe it is time to revisit this: Affiliate! now that you have a vehicle…


#23

Agree with Sunonline. A discounted 6month/annual subscription would be great and a lifetime pass (i.e. PlexPass) would be even more awesome!


#24

Should add, there are instances where you may want both of them, for example, you may want the full smart home skill experience with Alexa but a Harmony Hub for instance won’t pick up any devices that way which is where emulated_hue would still have a legit use alongside, although you could also control the devices using emulated_roku instead.


#25

The login page for the alexa skill seems to be case sensitive for the username (email address) It caused me some frustration when my browser capitalized my email address.


#26

Just want to add my thanks. Just found a whole tonne of devices in my Alexa devices list. HomeAssistant has turbo charged my Alexa…Finally getting to that point where I have an intelligence at the heart of my home powered by HomeAssistant


#27

How to use input_number domain?
alexa:
filter:
include_domains:
- input_number


#28

the domain support for alexa:

AVAILABLE DOMAINS
Currently, the following domains are available to be used with Alexa:

alert
automation (enables/disables)
cover
fan (supports on/off and set speed)
group
input_boolean
light
lock (lock and unlock, but unlock is untested as Amazon has disabled unlock for now)
media_player (play, pause, stop, set volume, adjust volume, next track, and previous track)
scene
script (enables/disables)
switch

#29

Thank you!
I see but i need domain “input_number”.


#30

Great news :slight_smile: being able to aggregate all devices through HA, rename and change this device class is very powerful.

However looking at Google, do you have any plans to use the voice disambiguation. This would be worth adding more google/replacing Alexa. Being able to ask for my morning routine briefing/script (vs my wife’s). “Turn off MY bedside” light :slight_smile:


#31

Hi, any news regarding Home Assistant? Can’t use Google Assistant anymore with emulated hue, Google forced to “update” the home devices saying you need to update first and now it doesn’t work anymore.
Thanks.


#32

Some bugs were found in the Google Assistant integration. The devs have addressed those in the next update (I think), so hopefully it’ll be retested soon.

In the mean time, the Google Assistant component works well.


#33

can’t connect to cloud here


#34

not with hassio and ducksdns it doesn’t. :frowning:


#35

Any more info in the logs?


#36

2018-03-18 19:29:10 ERROR (MainThread) [homeassistant.components.cloud] Error fetching Cognito keyset: Cannot connect to host cognito-idp.us-east-1.amazonaws.com:443 ssl:True [Try again]


#37

Same, I can resolve the address to 54.88.109.216 but still the same error.

Wed Apr 04 2018 14:54:27 GMT+0700 (SE Asia Standard Time)

Error fetching Cognito keyset: Cannot connect to host cognito-idp.us-east-1.amazonaws.com:443 ssl:True [Try again]

However, I can link the account to alexa’s skill through the alexa app.


#38

That error will happen once if your host starts up before there is internet. Home Assistant will recover and you can continue using it


#39

Sorry for spamming but my logs say otherwise:

Error fetching Cognito keyset: Cannot connect to host cognito-idp.us-east-1.amazonaws.com:443 ssl:True [Try again]
11:34 AM components/cloud/__init__.py (ERROR)
Error fetching Cognito keyset: Cannot connect to host cognito-idp.us-east-1.amazonaws.com:443 ssl:True [Try again]
[...]
11:31 AM components/cloud/__init__.py (ERROR)
Error fetching Cognito keyset: Cannot connect to host cognito-idp.us-east-1.amazonaws.com:443 ssl:True [Try again]
11:30 AM components/cloud/__init__.py (ERROR)
Error fetching Cognito keyset: Cannot connect to host cognito-idp.us-east-1.amazonaws.com:443 ssl:True [Try again]

#40

I’ve found out something, I installed SSH on the PI and now I can access the OS. I see that my IP address in hass.io is actually translated from 192.168.1.103 (I can ping this IP from my PC) to 172.30.33.2, so I’m not sure what is going on, is hass.io running in a container or something? The weird thing is, I can ping cognito-idp.us-east-1.amazonaws.com the PI can resolve the address to 54.88.109.216

So what should I do next, I guess its something about the container thats blocking SSL routing?