Conbee 2 not working while SSD connected on RPi 4 model b

Hello there community

Nice to be hear. After moving into my new house this month i want to really start with an Home Assistant setup.
My shutters are already integrated but now im struggling to setup the Zigbee Integration.

What I use:

  • Raspberry Pi 4 Model B 4GB
  • Crucial v4 SSD 256GB [on USB 3.0 port]
  • Conbee 2 [on USB 2.0 port with 3 meter USB extension cable]
  • Original Power Supply with 3.1 A
  • Home Assistant OS

Im trying to setup my Conbee 2 stick for already 3 days without any luck. I read trough so many blogs and tried all the steps without success.
If i plug the stick in, it will be detected (just sometimes!) in the Integrations tap, and i can choose the following:

But if I want then to add it, the message appears that it was not able to connect to this port.

And if everything works and i can set it up, it just won detect any zigbee devices at all, unless i unplug the SSD card.

Its unbelievable frustrating that this setup is so unreliable. Am i doing something wrong, where can i start the debug?

I would really really appreciate any help!

Best regards,

Just a guess: Maybe there is something wrong with your extension cable. Do you have the possibility to try another one?

Hey Heinz

Many thanks for your reply.
I suspected this already and because of that, i bought a new one, which I tested today. Sadly its still not working.

It’s because you are using USB3 for the SSD. It’s a very well known and very common issue. Use USB2 only, and everything will be fine.

I’m using SSD over USB3 and conbee2 connected to USB2. With no probs at all. The only difference is I have rpi4 8GB.
not saying you are wrong, but I’m not aware about such general rule.

It’s something very specifically with the Pi4 talked about at length on this forum. USB3 generates interference, which seems to be really bad on the Pi. It affects devices plugged in to the USB2 port.

I am also running a Pi 4 2GB with an SSD on a USB 3 port and a Conbee II on a USB 2 port via an extension. PSU is the Pi genuine. I have no issues.

I’m sure you do, but as you can clearly see - there are many many many threads all across the internet - here, Reddit, Twitter, the official Raspberry Pi Forums - from people who do encounter problems, with everything from ZWave, ZigBee, Bluetooth, WiFi and wireless keyboard and mice. It’s not like it’s a secret
The solution in every case has been to get a POWERED USB2 hub and run stuff off that.

Many thanks to all of you for your inputs.
I tried all combinations, also have both on USB 2.0
What i did not try is a powered USB hub. I will check that one out and give feedback.


Also something which is strange that the USB gets detected and disconnected the whole time:

I feel your pain since I have the exact same issue.
A week ago, I bought a new ssd and moved my system from the sd card to the SSD that is connected to the USB3 port.
Since then, the ConBee II stick refused to work (properly because of the USB inetrferance that many people are complaining about).
when I put back the sd card, everything just works, and when the system is working from the sd card and I plug in the SSD, the same behavior pops up and the stick refuses to work.

Let me know how the powered usb hub did with you.

hi everyone

I tried the powered USB hub. Its still the same issue. The Conbee 2 gets connected for 4 seconds before disconnecting. After 10 seconds the whole thing starts again.

I wanted to check if the stick was damaged on arrival. So I plugged it in to my WIN 10 Laptop directly, with an extension cable and also with the powered hub. Still the same thing happens.

Could it really be, that my stick is just faulty? Would it be worth to order a new one? (Got the money back from the supplier anyway already.)

The interesting thing was, that in the beginning the stick worked when i plugged out the SSD from the raspi. Could the many reboots have damaged the Conbee?

Many thanks for you help!

Hi Tobi,

Did you try to flash the conbee with the latest firmware ? (if not make a backup of deconz config before flashing).
After flashing and still problems: reset the conbee2 config and reload config backup (with deconz).
If problems are still there, as you have tried everything else, conbee stick is for sure the problem.

I had (almost) the same problem as OP. Though for me the conbee stick is recognized it wouldnt find any sensors or switches, lights worked fine strangely. Putting both SSD and conbee stick in the USB 2 port and everything works as it is supposed to.

Same problem, Conbee 2 and HD on USB3 and it was recognized but did not associate any devices. Moved everything to USB2 and now everything works. Thank you very much everyone for the support.