Conbee II/Deconz stops working when firmware update is needed

I’m running a Conbee II stick via the deconz addon in hassio on a raspberry pi. Latest versions of HA and deconz addon.

Three times in the past few weeks, all devices connected to my Conbee II stick have simply stopped updating. There is no error in home assistant, or in the phoscon web app. It just looks like the devices haven’t sent updates.

However, if I then log onto deconz on the pi via VNC, the deconz screen shows ‘A device firmware update is needed’, and gives me a button to press to start the update. If I update, it’s all fine again. (In this case the update was from firmware 2.05.74 to 2.05.75)

I’m a little confused about what is happening here - any insight? Is anyone else having this issue? Surely it isn’t intended or desirable behaviour that the stick just stops working because there is a firmware update available? And how does it even know that there is an update available?


I’m seeing the same… well sort of. I’m not using the deconz addon because I couldn’t make it connect to my Conbee II. So instead I run the latest image from Dresden Elektronik on a dedicated pi.

Runs ok until it doesn’t, exactly like you described without warning. When it stops working my VPN deconz screen always shows the firmware update request and the Phoscon app always shows “Firmware - not connected” on the Gateway screen - which I guess explains why Home Assistant receives no sensor updates.

If I click the “update firmware” button in deconz, let the progress bar reach 100% and then reconnect to Conbee II, the Gateway screen i Phoscon shows a button saying “Update to 26330500”. If I click that Phoscon will after a few seconds say the update has finished, but nothing changes, I’m still running 2.05.67. I think that’s because 26330500 isn’t meant for the Conbee II. Firmware for this stick should end with 0700 right? So yeah confusing.

Did you ever find a solution?

No solution yet. It’s happened a couple of times since I posted - maybe every week or so.

I’ve found rebooting the pi will fix it (restarting HA doesn’t). Assume the stick needs power cycling.

It isn’t actually necessary to hit the install button (and in fact if I do, although it says it’s installing, the final version does not change).

Every week or so sounds familiar. I was hoping a successful firmware update might’ve solved the issue, but seeing you are on a higher release already I guess not.

Yeah. And even though it says an update is needed, and seems to go through the process, the version does not actually change. I am considering an automation to reboot the pi if it doesn’t get an update from any of the zigbee sensors for a certain period. Very annoying.

Just a quick update… today I decided to update the firmware manually by temporarily moving the Conbee II stick to my Windows box. Installed the latest Windows version of deConz (2.05.75) which includes the latest firmware for the stick (264A0700) and followed this guide to flash the stick.

My thinking is if the stick already has the latest firmware then deConz shouldn’t prompt a firmware update and cause all sensor updates to pause. It’s still a bug, but I’m hoping this could be a temporary fix. I’ll update this post in 1-2 weeks when the results are in :slight_smile:

That’s the firmware version I have and it has still happened a couple of times since I upgraded. (It tells me I need an update, but if I then go though the update process, the version doesn’t change.) But good luck, and thanks for updating!

1 Like

Happened again yesterday :frowning:

Yup, happened to me again today only 4 days in. You were right it’s not the firmware, must be Deconz. It’s just odd the forum is not flooded with similar posts considering how popular the Conbee is.

I think I’ll try reverting to the “headless” SD card image. I used to run it on my dedicated pie and it was rock solid then. The downside being it has no graphical view, just the Phoscon web app, but at least it kept running.

As you say, very odd that there aren’t more reports. Please let me know if your fix works! I emailed dresdner about a previous issue and they did not respond.

Ok, so it happened again! Now convinced you are right - it’s deconz, not the stick. This time nothing worked: restarting HA, rebooting the pi, unplugging the stick, hitting the update firmware button in deconz. Eventually, I unplugged the stick, then hit the update firmware button, at which point it began updating! When I plugged the stock back in, it worked. (Of course still on the same firmware)

It is indeed a struggle. Since my last post I’ve been testing a few deconz versions trying to find a stable one and these are my findings so far.

Just to recap: I’m running HA in Proxmox on a NUC-like mini PC. Maybe for that reason I was never able to make the official HA add-on connect to my Conbee II and instead ended up running deconz on a dedicated RPI 3B+.

It took me a while to discover that the deconz download page actually points to two different image folders.There’s a Beta and Stable folder. You would think the images in the Stable folder were the stable ones, but I found that’s not the case for me at least.

The latest stable “Desktop” version is 2.05.67 (Phoscon_Gateway_2019-09-07.xz) and as we know that one will stop working at random intervals asking for a firmware update even though my stick is on the latest 264A0700. Thinking the issue may be caused by a bug in the Desktop UI I decided to go with a “Headless” version instead - starting with the “stable” versions.

2.05.61 (Phoscon_Gateway_Headless_2019-04-10.xz) (stable): Ran this for a full day before discovering none of my Xiaomi sensors weren’t updating anymore. Other sensors worked ok, so I reckon this version simply doesn’t support Xiaomi.

2.05.63 (Phoscon_Gateway_Headless_2019-04-15.xz) (stable): Ran this for 14 hours and it too stopped working, so apparently has the same bug.

2.05.69 (Phoscon_Gateway_Headless_2019-09-07.xz) (stable): This only ran for 4 hours. Same issue. Now switching to the “Beta” versions.

2.05.72 (Phoscon_Gateway_Headless_2019-12-16.xz) (beta): This version has a different bug. It will run flawlessly for exactly 24 hours, then the pie freezes. It’s very odd. I set up a Ping sensor in HA and sure enough after exactly 24 hours on the minute pinging the pie’s IP fails.

2.05.64 (Phoscon_Gateway_Headless_2019-04-23.xz) (beta): This is the image I’m currently running, so far no issues. It’s only been 5 days but I have high hopes because I previously ran this image for about 9 months with no issues although on an older firmware. When I first got my Conbee II I believe this was the default Headless image linked in the download page. The only reason I started messing with deconz was curiocity towards the Desktop version and its fancy visual connection map I’d seen people talk about. But I’ll rather do without the map and have a stable deconz. Fingers crossed :slight_smile:

Same here, conbee2 stick in hassos via vmware exi usb passthrough. It works but after a whil devices are not connected anymore. vnc login works, see devices, but no connection to them. Sucks.

If I restart the addon it won’t detect usb stick untill I physically eject and insert it in the host:
[s6-init] making user provided files available at /var/run/s6/etc…exited 0.
[s6-init] ensuring user provided files have correct perms…exited 0.
[fix-attrs.d] applying ownership & permissions fixes…
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts…
[cont-init.d] done.
[services.d] starting services
[services.d] done.
starting version 237
[07:51:05] INFO: Waiting for device…

[07:54:05] FATAL: No device /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2194613-if00 found!
[cmd] / exited 1
[cont-finish.d] executing container finish scripts…
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.

I run latest…?

I don’t think this is the same issue. I had similar problems for a while, but pretty sure they were down to interference between zigbee and wifi. Try moving your zigbee and wifi channels around and see if that helps.

1 Like

A bit of an older thread but I experience the same issues. As far as I’m aware, I’m on the latest firmware version.

I’m running Hassio on an rpi4 with the Conbee II stick using deCONZ. After a reboot, everything is working fine and all temperature sensors (xiaomi aqara) are sending updates. After an unspecified period of time (hours, or days) I notice all sensors seem to be stuck.

Version 2.05.79 22/05/2020
Firmware Not connected

Only solution is to restart the pi.
After reboot, the Firmware field now depicts 26580700.

By the way, accessing the VNC interface instead of the web gui also shows a “not connected” error message. I did notice these lines in the log files.

14:22:37:500 COM: --dev: /dev/ttyACM0 (ConBee II)
14:22:37:551 device disconnected reason: 4, index: 0
14:22:38:458 wait reconnect 15 seconds
14:22:38:499 dev /dev/ttyAMA0
14:22:38:499 COM: --dev: /dev/ttyACM0 (ConBee II)
14:22:39:457 wait reconnect 14 seconds
14:22:40:457 wait reconnect 13 seconds
14:22:41:458 wait reconnect 12 seconds
14:22:42:458 wait reconnect 11 seconds
14:22:43:458 wait reconnect 10 seconds
14:22:43:571 Websocket disconnected (state: 0) 
14:22:44:458 wait reconnect 9 seconds
14:22:45:458 wait reconnect 8 seconds
14:22:46:458 wait reconnect 7 seconds
14:22:47:458 wait reconnect 6 seconds
14:22:48:458 wait reconnect 5 seconds
14:22:49:457 wait reconnect 4 seconds
14:22:50:458 wait reconnect 3 seconds
14:22:51:458 wait reconnect 2 seconds
14:22:52:458 wait reconnect 1 seconds
14:22:52:500 dev /dev/ttyAMA0
14:22:52:500 COM: --dev: /dev/ttyACM0 (ConBee II)
14:22:52:525 device disconnected reason: 4, index: 0
14:22:53:458 wait reconnect 15 seconds
14:22:53:500 dev /dev/ttyAMA0
14:22:53:500 COM: --dev: /dev/ttyACM0 (ConBee II)
14:22:54:458 wait reconnect 14 seconds
14:22:55:457 wait reconnect 13 seconds
14:22:56:458 wait reconnect 12 seconds

After reboot, the log looks a lot more promising, which makes sense since the sensors are updating again.

14:30:35:757 found node plugin: - REST API Plugin
14:30:35:763 found node plugin: - Signal Monitor Plugin
14:30:43:303 found node plugin: - STD OTAU Plugin
14:30:43:359 dev /dev/ttyAMA0
14:30:43:359 COM: /dev/ttyACM0 / serialno: DE2193857
14:30:43:359 COM: --dev: /dev/ttyACM0 (ConBee II)
14:30:43:574 dev /dev/ttyAMA0
14:30:44:365 Announced to internet
14:30:44:366 discovery server date: Thu, 17 Sep 2020 12:30:44 GMT
14:30:44:366 	 local time seems to be ok
14:30:44:366 discovery found version 2.04.35 for update channel stable
14:30:53:704 dev /dev/ttyAMA0
14:30:53:704 COM: /dev/ttyACM0 / serialno: DE2193857
14:30:53:704 COM: --dev: /dev/ttyACM0 (ConBee II)
PROTO: CRC error
PROTO: CRC error
14:30:53:763 dev /dev/ttyAMA0
14:30:53:804 GW update firmware found: /usr/share/deCONZ/firmware/deCONZ_ConBeeII_0x26580700.bin.GCF
14:30:53:804 GW firmware version: 0x00000002
14:30:53:829 Device firmware version 0x26580700
14:30:53:832 unlocked max nodes: 200
14:30:53:904 Device protocol version: 0x010B
14:30:53:921 new node - ext: 0x00212effff05a2aa, nwk: 0x0000
14:30:54:007 SensorNode 19 set node 0x00158d0004657766
14:30:54:008 SensorNode 17 set node 0x00158d0004657766
14:30:54:008 SensorNode 18 set node 0x00158d0004657766
14:30:54:011 SensorNode 4 set node 0x00158d000465b7bf
14:30:54:012 SensorNode 3 set node 0x00158d000465b7bf
14:30:54:012 SensorNode 2 set node 0x00158d000465b7bf
14:30:54:015 SensorNode 7 set node 0x00158d000464b332
14:30:54:016 SensorNode 6 set node 0x00158d000464b332
14:30:54:016 SensorNode 5 set node 0x00158d000464b332
14:30:54:019 SensorNode 9 set node 0x00158d000464d885
14:30:54:019 SensorNode 10 set node 0x00158d000464d885
14:30:54:020 SensorNode 8 set node 0x00158d000464d885
14:30:54:022 SensorNode 15 set node 0x00158d0004210776
14:30:54:023 SensorNode 16 set node 0x00158d0004210776
14:30:54:024 SensorNode 14 set node 0x00158d0004210776
14:30:54:026 SensorNode 22 set node 0x00158d0004648bb8
14:30:54:027 SensorNode 20 set node 0x00158d0004648bb8
14:30:54:028 SensorNode 21 set node 0x00158d0004648bb8
14:30:54:151 Current channel 11
14:30:54:167 CTRL ANT_CTRL 0x03
14:30:54:205 Device protocol version: 0x010B
14:30:54:256 Current channel 11
14:30:54:275 CTRL ANT_CTRL 0x03

Slowly but surely, sensors within HA are updating as well.

I am still getting these issues periodically - perhaps every couple of weeks. Restarting home assistant usually works, sometimes rebooting the pi is needed. I’m on the latest versions of everything.

It’s really frustrating - for the rest of my family it really impacts their experience. My hue hub is rock solid. It hasn’t had a single issue in two years. Home assistant is pretty stable, but the conbee stick is really flaky, and the support team don’t even respond to emails.

If there was a good alternative to the conbee II I would definitely try it. I’m getting to the point of writing a script to reboot if I don’t get any info from the sensors for a few hours.

1 Like

Same issue here. Going to have to go back to Smartthings for my zigbee devices because I cant get this working after the firmware update.

I just recovered after two days of outages related to the “firmware not connected” thing. I too am on an rpi4 and am booting off of an SSD on one of the usb3 ports. It hadn’t been a problem until I updated the firmware through phoscon the other day. After that, deconz could no longer connect to the stick. I deleted everything and reinstalled. Still nothing.

I even reinstalled ZHA, but it couldn’t connect either. Assuming it was related to the usb3 thing, I set up an instance of deconz on another pi but still nothing.

While reading through the docs I see it mentioned that the firmware update will fall silently if initiated through phoscon. I downloaded a copy of deconz for windows and ended up manually updating the firmware through the command line. Plugged it back into my pi and there it was. All devices came back after a restore from backup.

The only thing I miss from smartthings was the stable zigbee.

1 Like

Andy, I did everything you said and still cannot get it to work right. I am going to get a longer usb dongle today to see if that helps, but i really think its the firmware update. Everything worked perfect until I did that. Now I may have to resort to moving all my zigbee stuff back to the smartthings hub.

I’m using a 2 meter long cable. Did you follow the firmware instructions exactly? You used the command line interface and got a success message? Given all the trouble I’ve had with zigbee and zwave, and given how stable esphome has been, I’m now wishing I would have just used all esp devices from the start.