deCONZ - Official thread

Hi All, how can I remove (delete) a device (node) from deCONZ ?
Selecting the node and pressing delete removes the node only for a short while before it automatically shows up again by itself.
I’m running deCONZ v2.05.86 in Docker
ConBee II firmware 26660700

I checked the following files for the possibility to manually remove devices (nodes), but I didn’t find anything text-editable:


There surely must be a way to remove/delete/unpair devices from deCONZ ?

@mirekmal I have the same issue. While I’m running both HA and deconz in docker, after a restart the devices become unavailable in HA and I can’t use deconz.device_refresh. Only a reboot of HA or reload of the integration will solve this issue.

Tried using different bridge IDs and calling the refresh service from HA and I only get an error when I use an ID that doesnt exist (meaning when I use the right ID I get no error but it doesn’t work).

I’m using:

  • HA 0.115.3
  • Deconz marthoc docker running 2.05.77
  • Conbee II FW 26580700

Reason for running older FW and deconz versions is that I have had Major issues with the latest versions and my Tradfri devices/basically the whole zigbee network crashing down. Reverting to these versions and everything is stable.

Can i manually expose these attributes to HA?

Recently my Raspbee board stopped working so I decided to replace it with a ConBee II
Of course I had to pair again all the zigbee devices using the Deconz webapp and deleting the old ones.
Unfortunately after some time some devices disappeared from Deconz web app and disappeared too from Home Assistant as entities.
The strange things that I can see these devices regularly connected by a line to the coordinator or to another router using the Deconz UI but I no longer see them in the Deconz web app.
Any Idea how to fix this issue?

Thank You

I had to join again one smart plug and then all the others re-appeared
I cannot explain why

I think I’ve had it with my Conbee2/Deconz. With a HASSOS Proxmox install it would occasionally freeze the entire OS, keep it from restarting, or drop all my sensors after working great for a few weeks.

Then I found this thread: Conbee II/Deconz stops working when firmware update is needed

How on earth do people put up with this? I’m so surprised that it was one of the most recommended Zigbee hubs. It has caused me nothing but headaches getting comfortable with HA.

I should add that this was after I updated the firmware on a Windows machine when I initially got the stick.

It’s not deconz fault but proxmox. The usb reconnection causes the VM to freeze, you’ll see the links here.
I have not fixed it on my setup yet but did a temporary workaround by removing deconz addon out of hassio and creating a seperate VM for it.
The USB disconnects usually happen when I plugin another USB. I read it on another github issue that I need to plugin the conbee stick on a powered usb hub to prevent it. Nevertheless, i have yet to try downgrading proxmox from 6.2 to 5.x too.

This is helpful information. Thank you.

When it was working, I found it relatively easy to use. I apologize for my tone. The esoteric nature of some of these incpompatibilies/issues is really killing my enthusiasm and trust for this project. For now, I think I will give husbzb-1 and zha a try since I already have the husbzb-1 for the eventual zwave devices.

Is it actually possible to upgrade the firmware in deconz in home assistant when using proxmox? Or is that something that never works regardless of configuration/setup?

I’ve found a solution for sensors provided from deconz api but not exposed to HA from the addon:
installed nodered and nodered integration and used deconz input node with home assistant sensor…now node red listens for changes in state of low battery and tampered alarm and updates binary_sensor in HA…

I have one general understanding problem/question (and I hope that this is indeed the right thread and I am not hijacking a thread here!):

I added a set of switches and sensors via the ZHA integration. Can I now just install the deconz addon and use it in parallel/on top if it? And if so, in what cases do I need the deconz integration (not the addon)? I am a bit confused what is which, and how they are all related…

The service: “deconz.device_refresh” doesnt work for me. I use HA on my rpi3 with Deconz+ConBeeII for almost a year now. I added a new IKEA motion sensor via phoscon. I deaactivated the “add newly devices automatically” option, becaue I want to rename it in phoscon first. But the service to add the device dont work :frowning:

Are you running 0.117?

No 0.116.2

Its fixed on 0.117

1 Like


Another question:
What happens with all my automations, if I always use devices as trigger or condition instead of entity name (e.g. light.doorlight) and have to remove (or re-pair) and add one ore more of my zigbee lights/sensors/switches? In the past, I always had to edit/update my automations because the zigbee devices will get a new device ID.

If you remove the device from deconz and restart hass the entry will be cleaned up

I know that. But I want to know if the device ID will change.

Whats my problem:
Sometimes one or more of my window sensors (Xiaomi) or Hue dimming switches (Philips) stop working. Then I have to start a new paring procedure in Phoscon (without deleting the device in phoscon or HA). The “re-paired” device is displayed as a new device with the standard name (the old device name disappear). I give the device the old name. What happens with the device ID in HA?

If I always use the entity name in the automation everything is ok. But if I use the device ID?

If the device entry gets cleared from hass you will get a new ID.

Though I think if you don’t have auto add of new devices in to hass there shouldn’t be an issue. You might be pointing out a situation I don’t really cover with the integration in the best possible way right now; readding a device without removing it

Hi, I just got my Conbee2 (to use with Aqara door/window sensor) and I connected it to a test RPi running hassio supervised, I installed deCONZ addon, started the addon with "device: /dev/ttyACM0", it worked well, so I configured deCONZ adding two sensors and everything worked well. Then I tried to add the sensor to HA, by authorising the API and I noticed that a new firmware update was available, so I updated it, and nothing worked anymore. Looking in the hardware section of Supervisor, the usb ports keep changing and I can’t find one that actually communicate with the conbee.
I changed RPi (from 2b to 3b+), I tried a long USB cable, but nothing changes.
I googled about faulty firmware upgrades for conbee, but there’s no mention of such issues.

Downgrade the firmware back. I had the same issue.

1 Like