Conbee II Disconnecting and Reconnecting

Tags: #<Tag:0x00007f326f623808> #<Tag:0x00007f326f623740>

Hello,

I have a Conbee II that originally worked fine. After some time, it started to give me issues were it will disconnect and then, reconnect. If I create a new HA installation, I can get the Conbee II stick to work fine until I restart the server. It isn’t always the first restart that initializes this error either. I experienced similar behavior of the stick working fine and after disconnecting/reconnecting it, it begins to disconnect/reconnect in a loop by itself on a separate computer (Windows 10) with only deCONZ loaded on it.

This is the error I get in HA on loop:
cdc_acm 2-2:1.0: failed to set dtr/rts

Server info:
Windows 10 running Docker for Ubuntu holding the server
Everything is always up-to-date when I experience this issue since my solution in the past was to recreate the server. (I was having other issues along with this which kept me from identifying this as the problem. As far as I can tell, this is the only issue left.)

Quick side note: If running this on a raspberry pi would resolve this issue, please let me know.

Thanks for any help you can provide!

Running on Ubuntu. Did you disable and remove modem-manager ?

No. How do I do that? When I did a quick Google search, I couldn’t use the commands that came up, sudo…

I am wondering if I am miss labeling my setup. For clarification, I am in Windows 10 running Home Assistant in a Virtual Machine. This virtual machine’s OS is Ubuntu.

Thanks for your help! I’ve been struggling with this for awhile.

If you can’t run sudo, how did you install HA ? As far as I know, you need sudo to install HA.

Log in to your ubuntu console (either the VM console, or with SSH (if SSH, not the HA container, but the Ubuntu host))

systemctl disable ModemManager
systemctl stop ModemManager
sudo apt-get remove ModemManager

I followed this guide to install it:

When I use the commands in SSH, I get
host: couldn't get address for 'disable': failure

An example of the lines of code I am using to be sure that isn’t the issue:
host systemctl disable ModemManager

not
host systemctl disable ModemManager

but

systemctl disable ModemManager
systemctl stop ModemManager
sudo apt-get remove ModemManager

When I type that in, I get the command is not found. I believe I am still in the HA container when I put it. That’s why I add host at the beginning… What am I misunderstanding?

But the linked pdf does not install Ubuntu, but HassOS ? Totally confused !!!

I probably misunderstood what I was installing. Honestly, I started this awhile ago and I haven’t had time to work on it.

The guide I followed has me select Ubuntu as the OS. After that, I just load an image into the system and start it. Maybe I am using HassOS?

If you followed that guide, you don’t run Ubuntu but HassOS, and there is no modemmanager to uninstall.

I did. Thank you and sorry for the confusion. Any other idea what could be causing my issue?

No. I don’t have a conbee myself. Maybe ask in the conbee topic.

Alright, thanks again

Simple question: is your conbee stick in a or next to an usb 3.x port or device? They can’t handle that.

It is. But, I am using a USB 2.0 extension cable. Is the 3.X port still causing the issue?

Not with an extension cable between it. Just wanted to make sure. Windows could be the issue. The thing is with windows 10, it’s not made as server software. So it’s actually optimized to save power and disable a bunch of stuff when it feels you are not using it. It’s really hard to tell if windows is doing this. Is windows going to sleep, or are you using it during connection loss?

Earlier today, I disabled Windows’s ability to turn off USB power. The problem persisted. I don’t know if there is any other power settings that I an try.

Not that I know of, but Windows 10 has a mind of it’s own if you ask me. My workstation is on windows 10, but that is only because I have programs that do not run on Linux and Mac is out of my price range… But for anything else I try to avoid Windows.

Well, thank you! You’ve helped me confirm that I just need to buy a raspberry pi; I was just trying to save some cash re-purposing this laptop that I no longer use. But, I have spent too much time troubleshooting this and I do not want to spend any time troubleshooting on Linux since I’m not familiar enough with that environment.

If your not using the laptop for anything else I would rather install ubuntu on it then buying a RPI4 to be honest. With the laptop you don’t have the problem of SD-card fatigue and you have a build in battery backup in case of power outages.