Connect Daikin Cloud NA to Home Assistant

Hi Everyone,

I am fairly new to HA and I have one last device in my house to connect to HA. I have a Daikin heat pump and I am using an AirZone AZAI6WSCDKA to control the thermostat over wifi. Is this possible to connect to HA? Daikin has documentation for the API (below).

1 Like

I just had all new HVAC systems installed in my home, and one of the systems is a Daikin SkyAir. The installers mounted a BRC1E73 so that we would have wired control over the unit. They also installed a AZAI6WSCDKA to get the unit on the network - which to my chagrin didn’t work like the ductless units with BRP modules, which all showed right up in HA using the Daikin AC integration.

Digging into the Daikin Cloud NA API it looks like they use the same OAUTH token model used to authenticate with the SkyPort cloud used by the DaikinONE+ thermostat and leveraged by @TrickerZ in his daikinskyport component available in HACS.

What appears to be the same are the calls made in the request_tokens and refresh_tokens functions in daikinskyport.py that just need to be pointed to different URLs:

https://api.daikinskyport.com/users/auth/login --> https://www.dkncloudna.com/api/v1/auth/login/dknUsa
https://api.daikinskyport.com/users/auth/token --> https://www.dkncloudna.com/api/v1/open/oauth2/token

But when you get to the get_thermostats function, the data returned is completely different since it’s not a thermostat but rather a control unit. So that function would need to be modified accordingly. I’ve never coded in Python so it’ll take some tinkering to figure out - probably less from anyone who actually knows what they’re doing.

It’s not a solution, but perhaps it’s a start. The other alternative is to use an Ecobee and connect their cloud to the DKN Cloud, but that’s more cost, hops, complexity and points of failure.

1 Like

Did you make any progress here?

I’m about to start exploring the same thing, so appreciate the pointers you already provided to the daikinskyport component in HACS and the updated OAUTH URLs.

Yes! First, my failures for anyone who stumbles on this.

Trying to access the unit via the cloud, I found these projects to access the Airzone Cloud:

The first looked promising, and I thought I might be able to register my controller with the Airzone cloud instead of the DKN NA cloud, but that didn’t work. Then I thought I could make some tweaks to point the code at the DKN cloud. The OAUTH commands seem common across Airzone and Skyport cloud options, but the API calls after that differ. This would require extensive rewriting to account for different calls to be made and data structures being returned.

Then I found this project that allows for local access to the controller (even better since it removes hops and is not dependent on an Internet connection). This morning I successfully connected the integration to my controller and now have a thermostat card for the unit on my dashboard. I’ll post an update after some time using it to make sure that it’s working properly.

I followed these steps to set it up:

  1. In HACS, add a custom repository for https://github.com/gpulido/homeassistant-airzone as an ‘Integration’
  2. Restart Home Assistant
  3. In HACS, search for “Airzone” and install the integration
  4. In Configuration > Integrations, add an AirZone integration by searching ‘airzone’
  5. In the Config Dialog, enter:
    • IP address of the unit
    • Port: 3000
    • Device ID: 1
    • Class: localapi
  6. Once installed, you will see a new climate entity which you can rename to match your ID / naming scheme.
  7. From here, you can add a Lovelace card, automations, etc. as you would any other climate device.

Hope this helps!

1 Like

@Flier1K Thanks for sharing your experience, I’d like to do the same thing and have installed an AZAI6WSCDKB module (note the last character is a B instead of an A) onto a Daikin CTXS07LVJU. The DKN Cloud NA app finds the devices, connects it to wifi, and controls the device without any problem.

I’ve used HACS to add the custom repo, installed the integration, and am attempting to configure with the IP number/port/etc. The dialog defaults to port 7000, which I’ve tried as well as port 3000. I also tried port 5020 that the github readme indicates. None connect with localapi, innobus, or aidoo. The IP number pings on the network, but I’m not finding an open webserver port.

Any ideas?

EDIT: It looks like this may be a common issue. I’m wondering if some AirZone models do not come with a localapi web server available.

@tauren have you tried connecting to the unit from a shell to see what sort of response you get? Below is a Linux cURL command that you can try (replace the <IP_ADDRESS> with your unit’s IP). If you’re using Windows, you’ll probably need to tweak a bit since the syntax differs.

curl -v -XPOST -H "Content-type: application/json" -d '{"systemID":1, "zoneID":1}' 'http://<IP_ADDRESS>:3000/api/v1/hvac'

You can try ports 3000 and 5020 to see if the responses vary. When I try 5020, I get a ‘connection refused’ response. When I try 3000 the response is long and contains a “data” section that lists maxTemp, minTemp, setpoint, etc. I did a little searching and didn’t see reference to any other ports beyond those two.

As for the difference in the last letter, according to the Daikin one-pager the “A” unit is for VRV systems (fan coil systems like my SkyAir), the “B” units are for ductless systems. I can’t imagine why they would enable a webserver on one and not on another.

At this point, I’m pretty sure there is no webserver listening for local HTTP traffic on the device. I thought I read that Daikin is doing away with local control on the new devices. My guess is that the server never listens to an HTTP port and instead opens up a websocket port to the cloud server. The only way to send signals to the device would then be through the cloud service relaying commands via websocket. I’d love to be proven wrong however!

Here’s the results of my connection attempts to port 3000, 5020, and 7000:

❯ ping 10.10.10.71
PING 10.10.10.71 (10.10.10.71): 56 data bytes
64 bytes from 10.10.10.71: icmp_seq=0 ttl=254 time=38.324 ms
64 bytes from 10.10.10.71: icmp_seq=1 ttl=254 time=34.623 ms
64 bytes from 10.10.10.71: icmp_seq=2 ttl=254 time=40.231 ms
^C
--- 10.10.10.71 ping statistics ---
3 packets transmitted, 3 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 34.623/37.726/40.231/2.328 ms
❯ curl -v -XPOST -H "Content-type: application/json" -d '{"systemID":1, "zoneID":1}' 'http://10.10.10.71:3000/api/v1/hvac'
Note: Unnecessary use of -X or --request, POST is already inferred.
*   Trying 10.10.10.71:3000...
* connect to 10.10.10.71 port 3000 failed: Connection refused
* Failed to connect to 10.10.10.71 port 3000: Connection refused
* Closing connection 0
curl: (7) Failed to connect to 10.10.10.71 port 3000: Connection refused
❯ curl -v -XPOST -H "Content-type: application/json" -d '{"systemID":1, "zoneID":1}' 'http://10.10.10.71:5020/api/v1/hvac'
Note: Unnecessary use of -X or --request, POST is already inferred.
*   Trying 10.10.10.71:5020...
* connect to 10.10.10.71 port 5020 failed: Connection refused
* Failed to connect to 10.10.10.71 port 5020: Connection refused
* Closing connection 0
curl: (7) Failed to connect to 10.10.10.71 port 5020: Connection refused
❯ curl -v -XPOST -H "Content-type: application/json" -d '{"systemID":1, "zoneID":1}' 'http://10.10.10.71:7000/api/v1/hvac'
Note: Unnecessary use of -X or --request, POST is already inferred.
*   Trying 10.10.10.71:7000...
* connect to 10.10.10.71 port 7000 failed: Connection refused
* Failed to connect to 10.10.10.71 port 7000: Connection refused
* Closing connection 0
curl: (7) Failed to connect to 10.10.10.71 port 7000: Connection refused

It’s frustrating that your device listens to port 3000 and mine doesn’t. I’m reluctant to buy 8 more of these devices without local control available.

Is there a reason that you’re using this specific module?

It occurred to me that my three Daikin Emura ductless units (FTXR12TVJUW) use a WiFi module from the BRP family. Looking at the submittal sheet for your ductless unit, it calls for the BRP072A43 module for connecting to WiFi - which is the same as what my Emuras call for. These units seem to be on a different Daikin cloud and use a different app entirely. Integration with HA was super easy as mine were immediately recognized by the Daikin AC integration when I supplied their IP addresss, and API keys and passwords listed on the control units.

If it’s not too late, perhaps you could exchange your Airzone controller for a BRP unit and give that a try?

@Flier1K The BRP family is no longer sold anywhere that I can find. All seller tell me that it has been discontinued and replaced with the AZAI modules. As far as I can tell, they are pushing everyone toward their cloud solution. I decided to buy one AZAI to see if I could get a solution working before buying all 8 that I need. Unless someone can share a source for the BRP models, I don’t think I’ll be able to go that route.

Not sure where you’re located, but a Google Shopping search for “BRP072A43” shows them in stock at several US stores.

I can confirm that your model does not have local connections. Copied and pasted from GitHub:

Hi folks! I finally came to the solution after some thorough reading of Daikin’s support documentation. In short, AZAI6WSCDKA and AZAI6WSDKB do not support local connections at all - they are only able to connect through Daikin’s cloud services. Only the AZAI6WSPDKC supports local connections via port 3000, and I’m happy to report that I have purchased it and successfully connected it! Any Daikin hardware must be “DKN plus” in order to have a local connection.

You can purchase and install AZAI6WSPDKC models yourself, I’ve done it and it was pretty straightforward.

Hope this helps!

indeed, many stores do show them in stock. But when you try to order them, the site either reports it out of stock, on backorder with no expected date, or you get a message from the vendor in a few days saying the item has been replaced with a different item. So far I haven’t found any actually available even though the sites say they are. If you know of a place that actually has them, I’d love to hear about it!

Thank you! I’ll attempt to find model number AZAI6WSPDKC instead.

Where did you put the module? Is there a place inside the cover that it can be concealed? I installed the “B” model at the center bottom under the cover, but it barely fit and causes the plastic cover to bulge out. The “C” model has extra protruding connectors and doesn’t look like it would fit in the same place.

I’m struggling with the AZAI6WSDKB model as well. There is no information anywhere I can find online that will help. In my case, the current temp in the room is not showing in the DKN Cloud NA app, I think this has to be a bug or a misconfig somewhere but no one at my installer or Daikin above him knows anything about this. It just shows two dashes instead. Were you having that issue too?

Hi, I’m a Daikin dealer trying to navigate this new install in my home. If you want the thermostat temp to show up in the cloud you’ll need to change Mode No. 10, first code 2, second code to the number 03.

Default is the return air sensor primary with remote secondary 01

02 will remove the remote sensor from the equation.

You’ll need to hold the cancel button for 4 seconds and go into field settings to change these parameters.

Tauren,

Did you get this working? I have the AZA16WSPDKC and can’t figure out the host and port to get it working.

You should be able to remove the front plastic cover and place the module with the refrigerant piping. You could feed the wires through the hole in the wall as well if needed.

I’m looking into adding a ductless unit and my local installer loves Daikin, but I know integrating them with HA locally is pretty hit and miss.

Wondering if it’s worth going with this or just having them try to use a different brand.

Their vendor says they will be including a AZAI6WSPDKC, trusting that the module is the right model number this in theory should work like mentioned in this thread.

I worry that they might sell them an A or B unit, although that seems unlikely?

Hi Motoridersd,

I’m a Daikin Contractor and integrated just fine with the DKN controller. My only problem was finding the IP address of the unit on my wifi. It had a very weird name, I had to punch in a bunch of random IP addresses until it integrated. After that it works great with home assistant.

Thank you for the information! What other data does this integration expose? I have a Midea with ESP32 that shows external unit temp. Does the DKN provide power consumption? Can you show the full details of the device?