Connecting USB adapter to a HA installation inside VMware

I have moved frome Homeseer to Home assistant and i am so glad for that !

But i have a problem.
My installation is in a VMware machine and also was my Homeseer.
Homeseer was installed on a Windows 10 machine and also Deconz for my Zigbee.
All communication to Zigbee and Z-wave adapter go to a Silex DS 510 USB device server through network.
This was the easiest way to connect the adapters.
I tried a passthrough configuration to the USB ports but got problems with this.

Then i moved to Home assistant i continue using Deconz on the Windows 10 machine and this works very well but i want to stop doing that.
And to use Z-wave i hade to continue using Homeseer because i can not connect the Z-wave adapter to Home assistant.

So my question is now.
How can i connect the USB dongles to Home assistant that is inside a WMware machine without using passthrough ?
Is there a way to connect the Silex DS 510 USB device server to Home assistant ?
Some other way to do this ?

Any suggestions ?

Best regards

You can setup automatic USB passthrough with VMware. I had this exact setup for about two months working without issue before moving to Proxmox.

I recently moved my HA from a rPi to a VMWare workstation on my Mac and didn’t have any problems mapping my various USB devices like Zigbee, Z-Wave, Insteon and Bluetooth.


Thanks for the answer.
But i am not sure this will work for me.
I should have mentioned that it’s a VMware ESXI server i use.
But i will take a look at it.

Best regards

Ah…I just presumed you meant you were running HA in VMware on the Windows machine.

You should be able to just use USB passthrough in ESXi. Is there a reason you don’t want to go that route?

Sure, you can add USB devices to HA VM in ESXi Server. I use this configuration for few years by now, initially with ESXi 6U2, since few months with ESXi 8. Hre is configuration of my VM:

As you can see I have 2 USB devices, Conbee II and Aeotec Zwave Gen 5 sticks connected to HA. Working flawlesly. It is done on VM configuration level, as ESXi server does see devices conected to hosts USB controller. It is not passthrough, as required for PCI devices.
Regarding your setup, as I understand you run Deconz on separate machine, so you can migrate to Deconz add-on (as I have it configured) and reconnect stilc to Deconz running inside HA VM. I have no experience with Silex stick, but I’d assume that it could be connected exactly same way. Just make sure, that inside your HA VM you also configured USB controller (you can see on screenshot, but I think it is added by default to HA OVA file already).


Thanks this sounds interesting.
I have to try this.

Last time i tried i used passthrough to USB PCI device in server but this made the whole server instable and could i not fix it.

Yes i will move Deconz to HA instead if i can get this working.

I will tell you when i have tested this.

I’ve been running HA on a ESXi-host for a long time using an external USB stick, no issues at all. Remember to use extender cable.

And here the same… running a legacy RF433 device for only one thermometer :crazy_face:
on esxi 7u3

Luckily with USB devices you do not need to passthrough entire controller, it is handled by host. Then only specific devices are connected to virtual USB controller on VM.
And one more hint, as this might be tricky to identify devices in VA VM, as these might have strange names on OS level…
So for Deconz it looks following (on my system). In Hardware configuration of HA:

In Deconz add-on configuration panel:

For Zwave… frankly speaking I do not recall how it was configured, I believe HA discovered the stick on its own and guided through configuration steps…

I have now tried this.
The VMware USB appear inside HA.
But it can not find any device on USB.

One look like this but this a USB hub

And one look like this but this is not vmware i think.

But not my device.

Any ideas ?

Best regards

Do you have a ttyUSB device?

No i have not.

Do you have any ideas ?

Can you share a picture of how you have configured the vm?

I found the problem.
I had only configured USB Controller in VM machine.
I did not know i had to add a device also.
Now i have a working Z-wave in HA
Thank you for the help.

Now i am wondering what will happen i move my Conbee from Deconz inside Windows 10 to the Deconz inside HA.
Will all my device continue working or do i need to reconfigure all devices.
Do you know ?

I believe you can create backup directly from phoscon (from Gateway view) on Windows and same way restore configuration to HA addon. Did not tried this personaly, but never heard that it is not working…

Just signed up to say thank you for the pics on the ESXI usb setup… i was trying to use passthrough which was not working… Need to break my habbits - Im used to using that method for passing GPU over to VM.

Im having the same issue. I have it in the VM.but HA wont find it.
Just wondering what you mean by:-

I had only configured USB Controller in VM machine.
I did not know i had to add a device also.
Now i have a working Z-wave in HA

He means that only adding the USB controller will not make it work, you will also need to add the USB device to the VM. If you do not have the USB controller already added it will auto-add if you add an USB device to the VM.