[Custom Component] Alarmo - browser managed alarm system

Hi All,

Need some help. My alarm got triggered over the weekend due to a motion. After checking everything, I could not see anything obvious. So I am guessing it could be a false alarm. How can I prevent a false trigger? Thank you

Never mind, found the solution in post 623. Thank you

Hi again

I am getting “Required key ‘service’ is missing.” error when I am trying to create an action. Any thoughts?

Thank you

Yep, first thought: why is a member, that is signed up for more than two years still not knowing how to get fast and reliable answers? :wink:

With code! :wink: Please, post the code you’re trying to get to work, as crystal balls seem not that competitive these days, at least mine isn’t. :rofl:

I am glad that you found it funny. This is what you get when you get crystal balls from Pondland or DollarTree, Get some proper Crystal Balls.

Next time when you write a comment like this, think about the person on the other side. They could have some disability, some medical issues or genuinely cannot remember the process to get the answer. There was no need to write a snotty comment.

Yes, I thought it is a little funny. I think, it is way nicer as telling someone in three words “post the code”.

And yes, it surprises me every time, when someone is not able to take at least one close look into the pinned topic in every forum and sub-forum. And what surprises me even more, is that someone who already knows how to post some code (according to a few of your posts), has read more than two days in the forum and has already created nearly 50 posts him/herself, doesn’t even bother to show that little respect against all the people that are here to help.

Have you ever thought about what people might think, that are here in their free time, trying to give something back to the community by giving support to others, free of charge, and the majority of people asking questions, doesn’t even bother to make it a little easier to give that support and help? :wink:

Or do you think, any kind of disabilty, medical issue or whatever, entitles people to do just as they like? In my world, people try to be nice and if they have questions, they try their best, the same wayas I try my best to give good and reliable answers.

Moving on, do you have some code to post, that shows what you are trying to do? The error message points into the direction that you’re missing a service to call, something like switch.turn_on or light.turn_off. As we don’t know anything about your doings, beside that you had a false alarm, it is not possible to narrow down where you even try to do that. Is it a service that has to do with Alarmo like alarmo.arm or is it something you want to happen in case of an alarm, or, or, or.

Let us know, preferrable with some code, how you’re getting along and if you still have problems. :slight_smile:

EDIT: here is the link to the pinned topic:

1 Like

Few things comes to mind but lets leave it at that. Here is the script and code.


alias: S50001-05 - Alarm Triggered - Turn All Lights ON.
  - condition: numeric_state
    entity_id: sensor.ms_dining_room_illuminance
    below: 50
    value_template: "{{ states('sensor.ms_dining_room_illuminance') | float(0) < 50 }}"
  - service: light.turn_on
    data: {}
      entity_id: light.all_lights_group
mode: single
icon: mdi:script-outline

Set up an action:

Event: Alarm is triggered
Mode: Away
  - service: script.s50001_05_alarm_triggered_turn_all_lights_on
    entity_id: script.s50001_05_alarm_triggered_turn_all_lights_on
    data: {}
Name: Test

When I attempt to save this action, I get an error:
Required key 'service' is missing.

Above code worked fine in version 1.9.9

Event: Alarm is triggered
Mode: Away
  - service: script.s50001_05_alarm_triggered_turn_all_lights_on
    entity_id: script.s50001_05_alarm_triggered_turn_all_lights_on
    data: {}
Name: Test

You need to set a service to call, not the script. Like this:

Event: Alarm is triggered
Mode: Away
  - service: script.turn_on
    entity_id: script.s50001_05_alarm_triggered_turn_all_lights_on
    data: {}
Name: Test

You tell HA what it should do (calling a script) and afterwards you tell HA which script you want to call.

And for the other things, if you want to talk about, please send me a PM! :slight_smile:

Hi Patrick

Thanks, I will give it a go.
In version 1.9.9, I didn’t change anything. I would go to Alrmo → Actions → New Actions and
Select the Event
Select the Mode
Select the Entity (Which was the name of the script)
Depending on the Entity selected, you would get either RUN for the scripts OR TURN ON or TURN OFF for the booleans.
Give it a name.

Now this worked like a charm. So is this changed? Neliss may able to answer? Or anybody else having same issues?


I can’t say, if this has changed with one of the last updates, but this is the way it is supposed to be from the HA side of things. But it could also be a change in HA, that now prohibits a specific declaration.

I just checked the way you described above, and it doesn’t seem to set the correct values in the UI. I’ll need to investigate that further, as I’m not using the UI for such things (doing it in YAML without the Alarmo Board). But for now it looks like a bug or a misunderstanding on how to use that function. :slight_smile: So you might be up to something. :smiley:

Im trying to use the Alarmo Card along side Remote Home-Assistant https://github.com/custom-components/remote_homeassistant

Left side of screenshot is a my main (local) HA instance

Right side of screenshot is a remote HA instance

The alarm is located and conencted to the remote HA instance

As you can see in my screenshot, When I Arm and Disarm the system both the local and remote instance update (Apart from the countdown on the local side)

I can Arm and Disarm the alarm from the built in Alarm card on both instances and I can Arm and Disarm using the Alarmo card at the remote instance.

I cannot Arm or Disarm on the Local instance though.

Has anyone ever tried to get these two things working together?

Hello! First of all, I would like to say thank you to the developers for such an awesome alarm integration!

Having said that, I would like to share some comments and suggestions. It would be great if developers take them into account for a future release, or just tell why such options are not possible.

  1. Wouldn’t it make more sense not to change the main Alarmo control panel entity name upon creating areas? Is there any reason such entity is changed to “master” instead of keeping the usual one, and just create new panel entities according to new areas names?
  2. If for whatever reason you decide to remove one/all areas (to restore the single panel scenario), would it be possible to return entities belonging to such area/s to the master/main alarm panel (or choose another available panel) instead of removing them?
  3. When a new area is added, you have the option to get the config from an existing area. However, actions/automations are not inherited. Would it be possible to do that, so you don’t have to redo all automations/actions for the new created areas?


Hello all

Really stupid question: how do you get into a “Pending” state? I tried everything but can’t see the pending state?

It will only go to pending if you have an entry or exit delay set. If those are set to zero it will jump from disarmed straight to armed and vice versa.

Hi Dave

Thank you

That is what I thought. I get “Arming” state fine when I have Exit delay set. But I cannot get “Pending” state when I have Entry delay.

I think the latest release have some bugs.

So triggering a sensor which is set as an entry delayed one, should put Alarmo into ‘pending’. Is that not happeneing?

Not on my instant

What happens instead then? The alarm triggers?

Ran a test again. Door Opening sets it to Pending, but Motion sensor does not do anything.

Motion Sensor set as a Entry/Exit. This is for the Night Alarm