[Custom Component] Alarmo - browser managed alarm system

thx. did resolve the issue.

Has anyone figured out how long Alarmo will be in a triggered state for after being triggered in disarmed mode? Example by flood or smoke?

Until it is disarmed by the user.

Hi guys, how can I manage, that ALARMO can be armed, even when not all sensors (window sensors Zigbee) are closed? I want to arm the system, no matter if a window is open or closed, but I want to be alarmed, if any change happens on a window-sensor e.g. close → open or open → close.

Is this possible and if so: how?

Currently, if I set an alarm (by a keypad with a 10 second delay) and one of the sensors is open, the alarm is not enabled and I receive a notification on my smartphone warning me that one (or more) sensors are open. Is there a way to ensure that in these cases I am notified of the open sensors but at the same time the alarm is activated by temporarily disabling the open sensors?

Hi all. I am trying to setup Alarmo to turn off all lights when the alarm is set. I currently achieve this with an automation but it would be nice to tuck this into an Alarmo action.

The automation code (which works) is:

service: light.turn_off
metadata: {}
data: {}
target:
  label_id: lights

However, when I pop this in Alarmo I get an error saying “must contain at least one of entity_id, device_id, area_id, floor_id, label_id.”

Any help would be most appreciated. Thanks

Can someone help me understand this about Alarmo? Previously I had one area (house) and three modes: home, night and away.

I noticed a tempting option to categorise my sensors by area of the house so I did so. This split alarmo into various sub alarms and also one master alarm, fine.

But what’s weird is that the general page of Alarmo now shows a very reduced number of sensors ‘active’ for each mode. Is it maybe the case that sensors from different areas of the house can’t be mixed within one mode?

If I click into for example armed night

Screenshot 2024-06-09 at 20.00.42

I get this view

Screenshot 2024-06-09 at 20.01.01

For some reason Alarmo is filtering on a particular floor?

Screenshot 2024-06-09 at 20.01.32

If I tick off ‘Ground floor’ then I get the full list as it was before I divided the house into different areas within Alarmo.

This makes for a confusing and conflicted UI - and I don’t now know whether these ‘inactive’ sensors are in fact part of the mode anymore?

What’s the use of the disarmed vs the armed_home state?

Armed home (also known as armed stay) will be used when setting the alarm while people are in the house. All doors and windows allowing access to the house will be guarded, but not motion sensors inside the house.

Disarmed means the system will not be triggered by any device (door, window, motion).

1 Like

I use this mode when I’m home to arm my sheds and garage door while I’m sleeping.

1 Like

I’m using the “armed_home” state, when I’m in the “home office” and in a (Zoom) meeting, for example. I want to be alarmed, if one of the doors gets opened. In my case that could mean the dog is going to explore the neighbourhood, or wife’s coming home, such things. :slight_smile:

A friend of mine is using it on his farm. Checking if any unattended doors open or close. It’s his way of monitoring his cows. :rofl: The doors that are needed for the workers are not monitored, but if a stable door is openend, he’s practically trying to break Usain Bolt’s records… :rofl: :rofl:

This shouldn’t happen :rofl:


No worries, he got all of them back

1 Like

I’m experimenting with this for the first time with a PN532 NFC/RFID module, which works great! :sparkler:

I have an automation that arms/disarms with a RFID ?keychain? (is that what those are called)

All good so far but… I have it inside the house and use a door sensor as a trigger.
When I arm the system and I open the door to leave the house, the alarm is disarmed: is this normal behavior?

I didn’t find anything in the Alarmo panel to avoid this and of course I could solve this by adding a delay in the automation to arm.
Is this the (only/right) way to solve this?

Not sure, are you saying the alarm you just activated (eg. “arm_away”) gets disabled when you open your front door, or do you say it is still disabled when you open the door and gets activated later?

Anyway, have you played around with the different settings for mode, especially the “exit delay” and “entry delay”?

These (in the Alarmo control panel)

1 Like

Hi Patrick, thanks for helping out! :bowing_man:

It was during the arming state that this occurred.
Removing it completely and reinstalling solved this.

1 Like

I’m back!

I’m on the latest version, installed through HACS.
Somehow my ‘Actions’ panel is not showing anything! :thinking:
Restarting HA doesn’t change it, refreshing my browser or another browser: same

Anyone who has the same experience or a solution for this?

Define “not showing anything”? Perhaps show a screenshot?

Hi, nothing to show/configure, empty.

I feel like I’m missing the obvious here-- hopefully someone can prod me in the right direction.

My “sirens” will be speakers (Sonos speakers, which I have in home assistant) playing siren .mp3 files on loop.

But, when I go to the Alamo Actions section, to set up the speakers, there’s no access to the Media player-- only Entities.

Any way to make it do what I’m hoping for?

Alarmo doesn’t support the complete palette of actions in its own UI. The best to do in such cases is setting up a script, where you have all HA magic available and call that script via the action panel in Alarmo. Or you setup an automation, that reacts on Alarmo events and can as well use all the HA magic. :wink:

That’s strange! I had a few hickups with Alarmo, especially in the beginning, but that one I didn’t have. :thinking: I have no idea what could cause this, sorry! I know, standard question: anything in the logs, maybe enable debug logging? :laughing:

So, that was what I tried-- but the problem with that is that the automation doesn’t end, when the alarm status moves off “triggered”.

Any tips to make it stop, when not in triggered status?

Here is my current attempt:

alias: Alarm sounds/lights
description: Alarm sounds/lights
trigger:
  - platform: state
    entity_id:
      - alarm_control_panel.alarmo
    to: triggered
    for:
      hours: 0
      minutes: 0
      seconds: 0
condition: []
action:
  - service: media_player.repeat_set
    metadata: {}
    data:
      repeat: all
    target:
      device_id:
        - eaf9010e42c583e930db7407c99edb60
        - 6f0c09a5bec417364c5b57f77791eaeb
        - 3ec4d7b91bfd7d81e605bfefa7672003
        - e60cd28d4b351c61e6440faa4c46094d
        - 3e2773325026834ab1a104f4fd764f55
  - service: media_player.volume_set
    metadata: {}
    data:
      volume_level: 0.36
    target:
      device_id:
        - 6f0c09a5bec417364c5b57f77791eaeb
        - eaf9010e42c583e930db7407c99edb60
  - service: media_player.volume_set
    metadata: {}
    data:
      volume_level: 0.26
    target:
      device_id:
        - 3ec4d7b91bfd7d81e605bfefa7672003
        - e60cd28d4b351c61e6440faa4c46094d
        - 3e2773325026834ab1a104f4fd764f55
  - service: media_player.play_media
    target:
      entity_id: media_player.outside
    data:
      media_content_id: media-source://media_source/local/alertklaxon_clean.mp3
      media_content_type: audio/mpeg
    metadata:
      title: alertklaxon_clean.mp3
      thumbnail: null
      media_class: music
      children_media_class: null
      navigateIds:
        - {}
        - media_content_type: app
          media_content_id: media-source://media_source
    enabled: true
  - service: media_player.play_media
    target:
      entity_id: media_player.garage
    data:
      media_content_id: media-source://media_source/local/alertklaxon_clean.mp3
      media_content_type: audio/mpeg
    metadata:
      title: alertklaxon_clean.mp3
      thumbnail: null
      media_class: music
      children_media_class: null
      navigateIds:
        - {}
        - media_content_type: app
          media_content_id: media-source://media_source
    enabled: true
  - service: media_player.play_media
    target:
      entity_id: media_player.kitchen
    data:
      media_content_id: media-source://media_source/local/tng_red_alert3.mp3
      media_content_type: audio/mpeg
    metadata:
      title: tng_red_alert3.mp3
      thumbnail: null
      media_class: music
      children_media_class: null
      navigateIds:
        - {}
        - media_content_type: app
          media_content_id: media-source://media_source
  - service: media_player.play_media
    target:
      entity_id: media_player.living_room
    data:
      media_content_id: media-source://media_source/local/tng_red_alert3.mp3
      media_content_type: audio/mpeg
    metadata:
      title: tng_red_alert3.mp3
      thumbnail: null
      media_class: music
      children_media_class: null
      navigateIds:
        - {}
        - media_content_type: app
          media_content_id: media-source://media_source
  - service: media_player.play_media
    target:
      entity_id: media_player.office
    data:
      media_content_id: media-source://media_source/local/tng_red_alert3.mp3
      media_content_type: audio/mpeg
    metadata:
      title: tng_red_alert3.mp3
      thumbnail: null
      media_class: music
      children_media_class: null
      navigateIds:
        - {}
        - media_content_type: app
          media_content_id: media-source://media_source
mode: single