Deconz is not connecting properly to - Lights visible but "Unavailable"

Summary of the problem: The lights I have successfully connected in deCONZ/Phoscon App remain “Unavailable” in Hass io and cannot be controlled with e.g. light.turn_on service. However I can control the lights from the Phoscon App and I can even activate deCONZ scenes from Hass io. However, the individual light dont connect correctly to Hass io.

I am totally new to the home automation stuff, and have now been trying to set up my first ever home automation project (wakeup lights). I am not sure if I have skipped some critical step, just misunderstood how the whole system should work, or have I ran in to a bug. However it is not working for me now.

My setup is:

  • Raspberry Pi 3B+
  • Hass io image (Home Assistant 0.85.1)
  • ConBee Zigbee USB Gateway plugged in to the Raspberry
  • deCONZ from the Hass io add-on store (Version 2.05.54 / 1/4/2019, Firmware 260B0500)
  • Innr smart candles (RB 245-2)
  • (+ Philips Hue Dimmer Switch)

So far I have successfully done the following steps:

  1. Installed and ran the Hass io on my Raspberry.
  2. Installed and ran the deCONZ add-on on Hass io, (set “device”: “/dev/ttyUSB0” and started the add-on),
  3. Entered the Phoscon App-webpage, connected my lights and dimmer switch to it, and created some scenes. I can now in the Phoscon App turn lights on and off and also control the brightness of the lights. Also controlling lights through the scenes works.
  4. In Hass io, I have done the integration of the deCONZ add-on by doing these steps:
    • Click: Configuration>Set up a new integration>deCONZ Zigbee gateway>Configure
    • Give to the prompt ip and port 9880
    • In Phoscon App opened the gateway for new connections by clicking: Hamburger menu>Settings>Gateway>Advanced>Authenticate App
    • The Hass io then connected “succesfully” to the deCONZ, and I can see all my lights and scenes in home assistant Overview-view.

So that sounds good, but unfortunately both of the lights and the light group all show “Unavailable” next to them. Also they dont seem to react at all to commands I try to send directly to them from home assistant. E.g. using Developer tools>Services to run the service light.turn_on on group entitity light.bedroom_lights (or only one light: light.wakeup_1) does nothing. However, it seems that HA is connected somehow to the deCONZ as in the same interface running service scene.turn_on on entitity scene.bedroom_lights_bedroom_lights_on succesfully turns on the lights!

I have tried to debug this and I have thus enabled the deCONZ logging by adding to configuration.yaml the following lines:

# enable logging
  default: info
    pydeconz: debug
    homeassistant.components.deconz: debug

So I did a test now by running first the light.turn_on service as decribed above (nothing happens) and then running the scene.turn_on service (lights get turned on). In the log this looks like this:

2019-01-18 00:39:28 DEBUG (MainThread) [pydeconz.websocket] Websocket starting
2019-01-18 00:39:28 DEBUG (MainThread) [pydeconz.websocket] Websocket starting
2019-01-18 00:39:28 DEBUG (MainThread) [pydeconz.websocket] Reconnecting to deCONZ in 15.
2019-01-18 00:39:43 DEBUG (MainThread) [pydeconz.websocket] Websocket starting
2019-01-18 00:39:43 DEBUG (MainThread) [pydeconz.websocket] Websocket starting
2019-01-18 00:39:43 DEBUG (MainThread) [pydeconz.websocket] Reconnecting to deCONZ in 15.
2019-01-18 00:39:48 DEBUG (MainThread) [pydeconz.utils] Sending {'data': '{}'} to
2019-01-18 00:39:48 DEBUG (MainThread) [pydeconz.utils] HTTP request response: [{'success': {'id': '1'}}]
2019-01-18 00:39:58 DEBUG (MainThread) [pydeconz.websocket] Websocket starting
2019-01-18 00:39:58 DEBUG (MainThread) [pydeconz.websocket] Websocket starting
2019-01-18 00:39:58 DEBUG (MainThread) [pydeconz.websocket] Reconnecting to deCONZ in 15.

So the call to the light.turn_on service does not show any activity in the log and I think the HA is not even trying to send any command to deCONZ as the lights are “Unavailable”. The scene.turn_on call seems to work as supposed. Also, I dont know if that is part of the problem or normal behaviour, but that “Websocket starting” and “Reconnecting to deCONZ in 15.” keeps repeating in the log all the time.

So dear Home Assistant/deCONZ gurus out there, what is the problem? Why is the HA seeing my lights being unavailable and not be able to control them?

FYI, here is still the log details showing log after the deconz.device_refresh call:

2019-01-18 00:53:24 DEBUG (MainThread) [pydeconz.utils] Sending {} to
2019-01-18 00:53:24 DEBUG (MainThread) [pydeconz.utils] HTTP request response: {...}
2019-01-18 00:53:24 DEBUG (MainThread) [pydeconz] {'config': {'UTC': '2019-01-17T22:53:24',
            'apiversion': '1.16.0',
            'backup': {'errorcode': 0, 'status': 'idle'},
            'bridgeid': '00212EFFFF02F369',
            'datastoreversion': '60',
            'devicename': 'RaspBee',
            'dhcp': True,
            'factorynew': False,
            'fwversion': '0x260b0500',
            'gateway': '',
            'internetservices': {'remoteaccess': 'disconnected'},
            'ipaddress': '',
            'linkbutton': False,
            'localtime': '2019-01-18T00:53:24',
            'mac': '02:42:ac:1e:21:00',
            'modelid': 'deCONZ',
            'name': 'Phoscon-GW',
            'netmask': '',
            'networkopenduration': 60,
            'panid': 10711,
            'portalconnection': 'disconnected',
            'portalservices': False,
            'portalstate': {'communication': 'disconnected',
                            'incoming': False,
                            'outgoing': False,
                            'signedon': False},
            'proxyaddress': 'none',
            'proxyport': 0,
            'replacesbridgeid': None,
            'rfconnected': True,
            'starterkitid': '',
            'swupdate': {'checkforupdate': False,
                         'devicetypes': {'bridge': False,
                                         'lights': [],
                                         'sensors': []},
                         'notify': False,
                         'text': '',
                         'updatestate': 0,
                         'url': ''},
            'swupdate2': {'autoinstall': {'on': False, 'updatetime': ''},
                          'bridge': {'lastinstall': '%cI',
                                     'state': 'allreadytoinstall'},
                          'checkforupdate': False,
                          'install': False,
                          'lastchange': '',
                          'lastinstall': '',
                          'state': 'allreadytoinstall'},
            'swversion': '2.5.54',
            'timeformat': '12h',
            'timezone': 'Etc/GMT-2',
            'uuid': '7be1b32b-b022-4d0a-a5b0-1360c2a2ed57',
            'websocketnotifyall': True,
            'websocketport': 8080,
            'whitelist': {'13C3D14D25': {'create date': '2019-01-16T21:39:22',
                                         'last use date': '2019-01-17T22:53:24',
                                         'name': 'pydeconz'},
                          '2492C5858C': {'create date': '2019-01-16T20:34:59',
                                         'last use date': '2019-01-16T20:35:02',
                                         'name': 'pydeconz'},
                          '42A277B60D': {'create date': '2019-01-15T20:10:07',
                                         'last use date': '2019-01-15T20:37:39',
                                         'name': 'pydeconz'},
                          '4B5DD00D11': {'create date': '2019-01-16T20:43:55',
                                         'last use date': '2019-01-16T21:35:38',
                                         'name': 'pydeconz'},
                          '7634D682A2': {'create date': '2019-01-16T18:22:17',
                                         'last use date': '2019-01-16T18:22:23',
                                         'name': 'pydeconz'},
                          '91B652B409': {'create date': '2019-01-15T21:13:37',
                                         'last use date': '2019-01-15T21:13:51',
                                         'name': 'pydeconz'},
                          'A854700700': {'create date': '2019-01-15T20:07:07',
                                         'last use date': '2019-01-17T22:53:19',
                                         'name': 'Phoscon#B1920x969'},
                          'AC37BBB6A4': {'create date': '2019-01-16T19:13:09',
                                         'last use date': '2019-01-16T19:51:57',
                                         'name': 'pydeconz'}},
            'zigbeechannel': 15},
 'groups': {'1': {'action': {'bri': 190,
                             'colormode': 'hs',
                             'ct': 0,
                             'effect': 'none',
                             'hue': 0,
                             'on': True,
                             'sat': 127,
                             'scene': '1',
                             'xy': [0, 0]},
                  'devicemembership': [],
                  'etag': 'bc6785fc21c479cea384f9d868eb6abb',
                  'id': '1',
                  'lights': ['1', '2'],
                  'name': 'bedroom_lights',
                  'scenes': [{'id': '1',
                              'lightcount': 2,
                              'name': 'bedroom_lights_on',
                              'transitiontime': 0},
                             {'id': '2',
                              'lightcount': 2,
                              'name': 'bedroom_lights_off',
                              'transitiontime': 0},
                             {'id': '3',
                              'lightcount': 2,
                              'name': 'bedroom_lights_level1',
                              'transitiontime': 0},
                             {'id': '4',
                              'lightcount': 2,
                              'name': 'bedroom_lights_level2',
                              'transitiontime': 10},
                             {'id': '5',
                              'lightcount': 2,
                              'name': 'bedroom_lights_level3',
                              'transitiontime': 10},
                             {'id': '6',
                              'lightcount': 2,
                              'name': 'bedroom_lights_level4',
                              'transitiontime': 10}],
                  'state': {'all_on': True, 'any_on': True},
                  'type': 'LightGroup'},
            '11241': {'action': {'bri': 127,
                                 'colormode': 'hs',
                                 'ct': 0,
                                 'effect': 'none',
                                 'hue': 0,
                                 'on': False,
                                 'sat': 127,
                                 'scene': None,
                                 'xy': [0, 0]},
                      'devicemembership': ['2'],
                      'etag': '4986ba6e53bb55f3baee4a641b3ceb8a',
                      'id': '11241',
                      'lights': [],
                      'name': 'RWL021 3',
                      'scenes': [],
                      'state': {'all_on': False, 'any_on': False},
                      'type': 'LightGroup'}},
 'lights': {'1': {'etag': 'bc6785fc21c479cea384f9d868eb6abb',
                  'hascolor': False,
                  'manufacturername': 'innr',
                  'modelid': 'RB 245',
                  'name': 'light_bedroom_1',
                  'state': {'alert': 'none',
                            'bri': 252,
                            'on': True,
                            'reachable': True},
                  'swversion': '2.0',
                  'type': 'Dimmable light',
                  'uniqueid': '00:15:8d:00:02:f4:0e:3c-01'},
            '2': {'etag': 'bc6785fc21c479cea384f9d868eb6abb',
                  'hascolor': False,
                  'manufacturername': 'innr',
                  'modelid': 'RB 245',
                  'name': 'light_bedroom_2',
                  'state': {'alert': 'none',
                            'bri': 252,
                            'on': True,
                            'reachable': True},
                  'swversion': '2.0',
                  'type': 'Dimmable light',
                  'uniqueid': '00:15:8d:00:02:f6:04:e6-01'}},
 'resourcelinks': {'1': {'classid': 3001,
                         'description': 'Resourcelink for switch rule',
                         'links': ['/groups/1',
                         'name': 'opt_on',
                         'owner': 'A854700700',
                         'recycle': False,
                         'type': 'Link'},
                   '2': {'classid': 3002,
                         'description': 'Resourcelink for switch rule',
                         'links': ['/groups/1',
                         'name': 'opt_off',
                         'owner': 'A854700700',
                         'recycle': False,
                         'type': 'Link'}},
 'rules': {'1': {'actions': [{'address': '/groups/1/action',
                              'body': {'on': True},
                              'method': 'PUT'}],
                 'conditions': [{'address': '/sensors/00:17:88:01:04:0b:db:30-02-fc00/state/buttonevent',
                                 'operator': 'eq',
                                 'value': '1002'},
                                {'address': '/sensors/00:17:88:01:04:0b:db:30-02-fc00/state/lastupdated',
                                 'operator': 'dx'}],
                 'created': '2019-01-15T20:50:57',
                 'etag': '607ce1bbdaa5fc00b85c42087beda759',
                 'lasttriggered': '2019-01-17T21:04:00',
                 'name': 'Rule ON',
                 'owner': 'A854700700',
                 'periodic': 0,
                 'status': 'enabled',
                 'timestriggered': 2},
           '2': {'actions': [{'address': '/groups/1/action',
                              'body': {'on': False},
                              'method': 'PUT'}],
                 'conditions': [{'address': '/sensors/00:17:88:01:04:0b:db:30-02-fc00/state/buttonevent',
                                 'operator': 'eq',
                                 'value': '4002'},
                                {'address': '/sensors/00:17:88:01:04:0b:db:30-02-fc00/state/lastupdated',
                                 'operator': 'dx'}],
                 'created': '2019-01-15T20:51:09',
                 'etag': '6017865f516f75d699eebe825a1dedd1',
                 'lasttriggered': '2019-01-17T22:39:46',
                 'name': 'Rule OFF',
                 'owner': 'A854700700',
                 'periodic': 0,
                 'status': 'enabled',
                 'timestriggered': 6}},
 'scenes': {},
 'schedules': {},
 'sensors': {'1': {'config': {'configured': True,
                              'on': True,
                              'sunriseoffset': 30,
                              'sunsetoffset': -30},
                   'etag': 'af294dca63cd65efa24770e02ceddc79',
                   'manufacturername': 'Philips',
                   'modelid': 'PHDL00',
                   'name': 'Daylight',
                   'state': {'dark': True,
                             'daylight': False,
                             'lastupdated': '2019-01-17T22:32:54',
                             'status': 100},
                   'swversion': '1.0',
                   'type': 'Daylight',
                   'uniqueid': '00:21:2e:ff:ff:02:f3:69-01'},
             '2': {'config': {'battery': 100,
                              'group': '11241',
                              'on': True,
                              'reachable': True},
                   'ep': 2,
                   'etag': '8f8a1c56f9bf8d4b3e23663e86bb0c8b',
                   'manufacturername': 'Philips',
                   'mode': 1,
                   'modelid': 'RWL021',
                   'name': 'controller_bedroom',
                   'state': {'buttonevent': 4002,
                             'lastupdated': '2019-01-17T22:39:46'},
                   'swversion': '',
                   'type': 'ZHASwitch',
                   'uniqueid': '00:17:88:01:04:0b:db:30-02-fc00'}}}

Which deconz addon are you using? Not the Marthoc version? Because the firmware of your conbee is old and the deconz version is a bit behind.

I have the version I found from the home assistant add-on store. It is just called “deCONZ” and it is under “Official add-ons / Maintained by Home Assistant”. I think it is this one:

Is this not the same as the “Marthoc”? And if not, how do I install the Marthoc version to Hass_io instead of the “official one”?

I think that is the correct one. But as @Pippyn mentioned you should update the firmware of your Conbee.

I would recommend the one from Marthoc and not the default one, because that one is most up to date. follow these instructions for install;

And for configuration the link in my previous post. On that page is also a comment on how to migrate.

1 Like

Thank you @Pippyn. Thank you @sjee.

I will try today evening if installing the Marthoc version and updating the Conbee firmware will help. I will let you know if that solved the issue.

Thanks everyone! That fixed it. I am not sure if it was the marthoc-deCONZ or the firmware update, but it works now. :slight_smile:

I had the exact same problem as OP. This comment saved my life today!

I have the exact same problem as OP. I’m on the core addon, but that seems to be the goto addon now? ref

My Conbee2 fw version is
Version 2.05.67 / 22.4.2019
Firmware 264A0700

Any ideas?

Same issue here after a system upgrade a day ago.

All of my Deconz entities show as (Unavailable) despite working fine in Phoscon. I am also seeing a System Log message that I suspect is related to Deconz:

WARNING (MainThread) [] No API token provided for /api/config

I have uninstalled / reinstalled Deconz / rebooted multiple times.

Running HassOS 2.12 / Supervisor 185 / Deconz 3.3 (from HA add-on store)
My Conbee2 firmware version is 2.05.67 / 8.26.2019
Firmware 26490700

Are there any suggested troubleshooting paths for this?

Same issue here. So if anybody finds a solution I’d be very happy.

I had the same problem (worked in phoscon, but unavailable/not working in, but this is how I resolved it:

Assumptions - You have already :
a) Installed the core Deconz add-on (via the addon store)
b) in you configuration.xaml you have enabled discovery:
c) Configured and pointed out where your device (in my case Conbee) is installed by typing the config when you go into the deconz addon details, eg:

  "device": "/dev/ttyUSB0",
  "vnc_password": "whatever your password is"

I was seeing issues when I clicked Developer Tools > Logs related to Deconz.

So this is what I did to fix the issue

  1. Go to Configuration > Integrations > deCONZ Zigbee Gateway: deCONZ-…
  2. Click in on the deconz Integration and remove it by clicking the trashcan in the top right.
  3. Restart hassio and after a while you will see that finds a new available integration (deConz)
  4. Go to you Phoscon by browsing, eg: (port depends on what you have configured in your deconz add-on details, but 40850 is the default port)
  5. Click on your Gateway, open up the hamburger menu and click Gateway > Advanced > Authenticate app
  6. Quickly go back to and go to integrations and now add your newly found Deconz integration (should also be available in the notifications area).

If you don’t authenticate the app, you will add the deconz add-on, but no devices will be found!

Good luck and happy home automation! :slight_smile:

1 Like

I was really hopeful about this solution, but I am still getting:

Invalid key for deCONZ at
Error connecting with deCONZ gateway

I can see all the nodes in DeCONZ, I can see and control my Keen Vents in the Phoscon web portal, but no devices/entities are appearing under the DeCONZ integration in Home Assistant and the deconz services do not appear either.

I’ve removed and re-added the DeCONZ integration; I honestly don’t recall whether I’ve tried uninstalling and re-installing the whole add-on, but I’m about to try it if I can’t find a solution.
Once I figure something out, I will definitely post what I find.


  1. Made a backup of the Phoscon config.
  2. Uninstalled the deCONZ add-on.
  3. Rebooted the raspberry pi.
  4. Installed the deCONZ add-on.
  5. loaded the backup to Phoscon config.
  6. Gateway, open up the hamburger menu and click Gateway > Advanced > Authenticate app
  7. In hassio Integrations, selected the discovered deCONZ, clicked configure.

The integration was configured successfully, but the result is still the same: no devices, no services, and the error messages in the log as mentioned above.
Two thoughts:

  1. Does the config-backup contain the issue, so restoring it is not a good option.
  2. Maybe after uninstalling the add-on, check docker to see if there is a container that needs removal.

____________Final Update:

  1. The Gateway > Advanced > Authenticate app piece turned out to be unnecessary in my particular case.
  2. Restoring the Phoscon backup did turn out to be an issue: I had to reset and re-add all of the zigbee nodes one by one after connecting the DeCONZ integration in Home Assistant, then using the deconz refresh device list service.

Everything is working now. The only apparent issue is that the Open / Close of my Keen Vents appears to be reversed. Not sure if there is a way I can fix that via templating or not. Should not matter too much in the long run once I get things fully automated.

I have this problem too. HA loses connection to deconz on every reboot until I restart HA from the webui manually. Should I switch to the other deconz addon? I would have hoped that the one from the official store is the moste stable one? Running official VM image with USB passthru.

Hello, since today I am having the same issue, only for the lights devices in deconz.
Need to restart HA after a reboot of hassio to get the lights to work

1 Like

See my post:

Yes I can confirm the same problem - lights (Hue) under Home Assistant in combination with the Conbee 2 stick are shown as “not available” in the dashboard.

Likewise I can switch them on and off ok in Phoscon.
All my Xiaomi/aqara zigbee gear is working fine in home assistant, it is just the lights not flowing through.

If I delete the deconz integration and re add it (after re-authenticating in phoscon), the lights are available again, but only until the next HA restart.

I did notice at the first time this error occured, my hue light entity names changed from “light.hue_extended colour_1” to what I named it in Phoscon “light.hue_1”

If discovery doesn’t update adress when hass starts you can manually update adress by initiating a new deconz integration setup. The config flow will match the hardware id to the existing integration and it should update it’s adress

Hi, same problem here. I create deconz integration, it works, after I restart HA server via Server management the integration stops working.

I have exactly the same issue. The light integrations are disappearing (the sensor integrations are still here). I didn’t have that issue before… I can also control the lights perfectly from the Phoscon app. I did delete the integration and linked it again but I cannot do this on each restart…