deCONZ - Official thread

What’s new about it? My Docker installation already includes an OTA option. All my Tradfri lamps have been updated.
Just activate the “STD OTAU Plugin” via VNC access.
Here is a small manual (in german):

I want to update my Philips Hue devices. I think they fixed a problem with the firmware files from hue. The fixes are only included in the new plugin. The problem occur because some firmware files have other filenames: .sbl-ota

See this Thread

Ah, I didn’t know that. Thanks for clearing that up.

There is nothing for me todo. This is implemented as part of deconz, so you have to either build your own version or wait for a released version with this functionality

1 Like

The addon saves OTA update files into addons/data/otau folder. This gets packed up and saves into every snapshot.

It’s my understanding OTA files can be re-downloaded. Is there any way to not include this in snapshot?

In the Integration GUI in HA, old deCONZ groups are still there (same issue here), even after calling deconz.device_refresh service or restarting HA and Deconz.

Calling API /groups/ shows only the current groups defined in Phoscon but HA also keeps old groups.

Would it be possible to be able to delete old “ghost” groups from HA ?

Thanks !

1 Like

Currently there is no support in the integration to remove old entries

I have IKEA light and several aqara sensors set up in deconz and working fine in HA.
However I tried adding a Aqara multisensor (temp/humid/pressure) and it works fine in deconz, however it does not show up in HA. I even added another sensor after that and it shows up fine in HA. It seems others have same sensor working with HA. I’ve tried rebooting HA and HASSOS, but does not help. Any suggestions ?

Deleted and added again and it’s working :slight_smile:

How do you make use of the ‘long-press’ action on the dimmer switches. The Philips for example has a long-press action ‘xxx1’ for every physical button on it.
My current plan is to have different cleaning zones assigned to short and long press actions. The problem is that when i press and hold one of the buttons the normal deconz_event ‘xxx0’ is already sent to the vacuum and it starts cleaning the zone assigned to it.

For IKEA switches:

  • short press triggers only xxx2 (no release event)
  • long press triggers xxx1, (after about 1 sec of pressing and without triggering xxx2 first) and then release triggers xxx3
    So you can easily differenciate long and short presses.

I’m testing with the conbee2 now and have a Philips hue dimmer connected. I can see it in deconz, and HA, but I can’t find it in node-red. Any pointers where to look for troubleshooting?

thanks, that worked

Hello guys,

what is your advice to slow deconz reactions.

Click on IKEA button, and after 5 seconds IKEA bulb is turned on.
Funny is that another IKEA bulb (E14) is working fast - max delay is 1s.

I already checked free chanells, i am using channell 15 as default and it looks free.
I am running latest version of HA and deCONZ, running from RaspberryPi3.

Thanks for comments.

Have a nice day!

IKEA Fyrtur only works properly with deConz if both the remote and the blinds are directly connected to the coordinator (Conbee). I tried that and it worked for a while but, as soon as I restarted HA, both devices got paired with a light bulb nearby and now it doesn’t work. You press the button and it respond after 5 min. Deconz is pointless. Every time I need to add a device I need to spend a week troubleshooting.

I have observed no such behavior and I have run fyrtur since the day deconz added support for it.

my fyrtur are having issues all the time.
They are just 3 or 4m away from my conbee II and in a range of 30cm up to 1,5 m there are several routers.
In the deconz app I can see that it is connected to the nearest router, but after some time (somtimes days, somtimes only hours) the connection is lost indefinitely.
Only a reset of the blinds can help here.But that means, that the reporting to home assistant and the max. length must be set again.
I like them, but they are not working very well.
The complaints here are not the only one, as you can see here

I noticed a new entity related to the Deconz integration. The entity is light.configuration_tool_6 and the name is Configuration Tool 6. It’s part of the Daylight sensor device in HA.

This entity showed up the first time when I upgraded to Home Assistant 0.108.x and is still present on 0.108.6. My setup is based on docker.

I tried to delete the entity, but it was not possible. I can only deactivate it.

I’ve noticed the same, but here it’s called “Configuration tool 11”.

It seems that this feature/bug that was introduced with one of the latest deCONZ updates and as far as I understand it relates to the Zigbee controller, e.g. ConBee, itself:

I would just ignore it for now.

Does someone has an issue with aqara PIR sensor?
I have one aqara and one xiaomi. On both, time between detected and clear states was 1min and 30s. Since yesterday (saw it on the history tab) on the aqara time between states is 5min. Does that means I need to change the battery? Or is this a bug in deconz?

Thanks for linking to the issue. I still don’t understand what this Configuration Tool is for. Hopefully it will be “fixed” in an upcoming release of deconz.

Hopefully deleting the entity in HA won’t cause any trouble.