DeCONZ, ZHA and Zigbee components and compatible hardware

Is the onion omega 2 compatible with HA?

That has nothing to do with this topic @Emd01. Have you tried the search function?

1 Like

Thanks for letting me know about Pi-hole. And obviously I was able to set port on the component, and its working now. In my defence I added the component just before bedtime and did not read the instructions all the way. :grimacing:

A couple of questions though:

  1. Is the Conbee hardware the actual gateway, or does the gateway reside server side? As in if I unplug the conbee stick and put it in my desktop and open the desktop app, will it retain the devices added to it?

  2. Do you know what data to pull from the Trådfri wireless dimmer? Since its a rotary thing and not buttons I am assuming it sends something different than the button dimmers.

  1. I am not 100% on this but my understanding is that it is stored with the deConz software
  2. You can see what number you get from it in the logs but if I. Remember correctly it is press up and press down

@wrenchse

I’ve tried to install the Deconz add-on but I’m having some issues.

I’ve downloaded the components and stored them localy in /addons. When I try to install it I get an error message.

ADD failed: failed to GET http://dl-cdn.alpinelinux.org/.../qt5-websockets-5.9.1-r0... with status 404 Not Found

I updated ‘Dockerfile’ and pointed to another site that had the file accessable (later version than originaly in the script). This gets me further, but results in other failures.

docker.errors.BuildError: The command ‘/bin/sh -c tar xv -C / -f data.tar.gz’ returned a non-zero code: 1

Did you have to change anything else than the USB path? If so, could you specify what steps were needed to install the add-on?

Thanks

Edit: Just found the raised issue and comments about this exact problem. Following those instructions worked like a charm.

1 Like

Steps I took to get it working in case anyone else gets here with the same intention: (Running everything deconz on one device. Pi3 with conbee-stick in my case)

  1. Download the files (dockerfile, config.json, run.sh) from the repo above (daniel-mrd-andersson/hassioaddons).

  2. Copy the files to your /addons share under a folder named ‘conbee’.

  3. Edit and the config.json to point to your USB-device. I had to change USB0 to USB1.

“devices”: ["/dev/ttyUSB1:/dev/ttyAMA0:rwm"],

To get your USB ID, SSH to your Home Assistant machine and run the command ‘hassio host hardware’. You should then be able to see what USB-ports are occupied.

  1. Edit and update the ‘dockerfile’ with the documentation found in the comments on the raised issue for the add-on. I replaced all code-blocks, even though I suspect only some were changed.
    https://github.com/daniel-mrd-andersson/hassioaddons/issues/1

  2. Install the Addon from HASSIO local store. Then reboot.

  3. servername:80 should now work in your browser of choice.

  4. Configure deconz in configuration.yaml according to the HA component documentation.

4 Likes

Yes. Sorry, was just reading along and with so much talk about ha guess I forgot where I was. Thanks.

Do you have a beginners section so I won’t ask noob questions and annoy everyone? I get the feeling I do that a lot here lol.

There is nothing wrong with seeking out help. We’ve all been in the same spot
I’d recommend searching a bit in the forums or create a new post

To add My IKEA-remote that usb-stick should I buy? I run my HA om a Raspberry pi 3.

If you want to use deCONZ, then you can buy the Conbee.

I have the Z-Wave Aeon Labs Z-Stick Gen5 in one of the USB-ports and the
ConBee in another.
How do I find the appropriate USB port for the ConBee USB-dongle, for the config.json file, ["/dev/ttyUSB0:/dev/ttyAMA0:rwm"]?

Running SSH and ‘hassio host hardware’ the result is:
“/dev/ttyUSB0”,
“/dev/ttyAMA0”,
“/dev/ttyACM0”

I am a little bit afraid to mess up some hardware if I just try all combination.

The first attempt:
13:57:27:284 COM: /dev/ttyACM0 :
13:57:27:286 auto connect com /dev/ttyAMA0
13:57:27:311 Serial com disconnected, reason: 4
13:57:28:081 COM: /dev/ttyAMA0 :
13:57:28:082 dev /dev/ttyAMA0
13:57:28:082 COM: /dev/ttyUSB0 :
13:57:28:082 COM: /dev/ttyACM0 :
13:57:28:277 COM: /dev/ttyAMA0 :
13:57:28:277 dev /dev/ttyAMA0
13:57:28:277 COM: /dev/ttyUSB0 :
13:57:28:277 COM: /dev/ttyACM0 :

Updating this as I go, for other n00bs.
Changed it to ["/dev/ttyUSB1:/dev/ttyAMA0:rwm"]…could not help myself…

And I think I am good to go. At least no “Serial com disconnected, reason: 4”

4:04:29:304 sql exec SELECT * FROM rules
14:04:29:304 sql exec SELECT * FROM schedules
14:04:29:304 sql exec SELECT * FROM sensors
14:04:29:305 sql exec SELECT * FROM gateways
14:04:29:305 don’t close database yet, keep open for 900 seconds
14:04:29:305 ~ResourceItem() attr/name – str 0xd3ce80

This resulting in Philips Hue popping up. Which I can’t get rid of, due to it has no hidden-attributes?

I’ve got the same two usb sticks and the default values works for me. ttyUSB0 and ttyAMA0 is the Conbee. ttyACM0 is the Aeon Labs Z-Stick.

Hey,

had the same issue once I plugged in an additional USB device. This messed up the device order after a reboot so that the conbee stick was not ttyUSB0 but ttyUSB1 all of a sudden.

I can recommend you to look into this post: https://www.raspberrypi.org/forums/viewtopic.php?t=90265

It describes how you can create a rule so that certain devices are recognized by their serial number and then given a dedicated name. Since then I had not trouble with device names anymore.

My ConBee is now ttyUSBconbee in addition to the randomly assigned ttyUSBx device name, my ZWave stick ttyACMzwave and my Pilight Nano ttyUSBpilight.

.Cheers
Jochen

1 Like

Thanks for sharing.

Will this work for Hassio/ResinOs?
-Have to ask before I mess up my SPI3.

1 Like

Can’t say since I don’t use Hassio.
Since these new names are only in addition to the old ones you should be fine as long as you have the ability to edit these udev rules. This could be a problem because afaik you don’t have access to the OS underneath of hassio, right?

Pushed a small PR to help out with renaming sensors of multi-sensor devices. You will now be able to use an entity ID to specify sensor when using the deconz-configuration service.

https://github.com/home-assistant/home-assistant/pull/11862

I have a RaspBee premium, but I do not understand how I can install it on ResinOS/Hassio and how I can use it with Home Assistant 0.61.1.
Thanks for your help

Follow this comment, there are also useful features in some of the comments above it.

thank you for support.
After a reboot (between step 5-6), it works!

2 Likes

I have associated a Tradfri motion sensor and using rest api i have:

http://ip:80/api/homeassistant/sensors/

{“1”:{“config”:{“alert”:“none”,“battery”:0,“duration”:5,“on”:true,“reachable”:false},“ep”:1,“etag”:“b34941c40d93ca348646a4f85cecac59”,“manufacturername”:“IKEA of Sweden”,“modelid”:“TRADFRI motion sensor”,“name”:"TRADFRI motion sensor ",“state”:{“lastupdated”:“1969-12-31T23:00:00”,“presence”:false},“swversion”:“1.2.214”,“type”:“ZHAPresence”,“uniqueid”:“00:0b:57:ff:fe:93:6a:86-01-1000”}}

but Presence tag is false always. I dont’ undertand why