Default password for the pi account

According to the documentation…

_To login to your Raspberry Pi running HASSbian you’re going to be using a ssh client. Depending on your platform there are several alternatives for doing this. Linux and Max OS generally have a ssh client installed. Windows users are recommended to download and install the ssh client Putty.

Connect to the Raspberry Pi over ssh. Default user name is pi and password is raspberry. Linux and Mac OS users execute the following command in a terminal._

… the password for the pi account should be raspberry. That is not working for me. Anyone have an idea what the password really is?

Are you running HASSbian, or Hass.io?

In hass.io, if you log in via Putty with a ssh key, the default username is ‘root’ and there is no password.

8 Likes

Did you figure this out? I’m having the same trouble.

I can ssh into the hassio.local account just fine.

When I try to ssh into user pi or root it asks for a password I don’t have. I have tried leaving it blank, and raspberry. Neither work.

Thanks!

1 Like

I am having the exact same problem and feel like I am missing something… Video tutorials seem to show you ending up in a user account when you ssh into hass.io, however when I SSH into hass.io via “root” as the username and the password I made up in open ssh it always takes me to: addon_core_ssh:~#. I tried logging in as username “pi” but the default “raspberry” password does not work…

Speaking of Hassio, the Username is ‘root’. Generate a certificate, I hope this video is explaining it for you all: https://youtu.be/L7PCPQYwspo

1 Like

Login with password is disabled by default. You need to generate rsa keys, which you’ll copy (only the .pub one) to hassio SSL add-on. BTW, don’t forget quotes around the key.

Then you’ll just ssh [email protected].

If by any chance you’re upgrading from hassbian,etc and have used the same IP on the HA box, you’ll need to edit known_hosts file on your computer and delete the entry with the matching IP, otherwise you’ll be shouted at and warned about hackers doing something nefarious.:grinning:

@shawndee did you figure this out? I am having the exact same issue. When I login to hassio via root and my password i get cor-ssh:~# and if I type
sudo apt-get update
I get
-ash: sudo: not found

Any help is appreciated. Thanks

@chadbone “hassio help” will show the available commands for the stock ssh in hassio, which is a limited CLI. If you want access to the host (and are familiar with ResinOS and docker containers) you need to use the dev/debugging method for SSH as described here:

Thanks a lot for the feed back. I am not familiar with ResinOS or docker, so perhaps I will see if I can find a tutorial on how to install Dasher (use Amazon Dash as a button) with hassio. It lease know now to stop trying that method. Thanks for the help.

Oh you are trying to install Dasher? There’s an addon for that in one of the community repositories.
https://community.home-assistant.io/tags/hassio-repository

Awesome! I am on that trail now, thanks a lot.

I’m where chadbone was withthe “not found” commands trying to install mosquitto. Kind of a dead end unless someone has some guidance?

Hi People!
I am really new to this and I am having a bad time trying install packages on Home Assistant that demands Linux commands (sudo).

I tried to login to “ssh [email protected]” using the “raspberry” password, but it doesn’t work. I always receive the “Permission denied, please try again.” message.

I am able to login using “ssh [email protected]” and the expected info is shown:


| | | | |_ / __
| |__| | __ _ ___ ___ | || | | |
| __ |/ ` / __/ __| | || | | |
| | | | (
| _
__ _ | || |__| |
|
| ||_,|/()___/

Our Cli:
$ hassio help

debug1: permanently_set_uid: 0/0
core-ssh:~#

When I type the commands to install a package, nginx for instance, I receive:
core-ssh:~# sudo apt-get install nginx
-ash: sudo: not found

As a matter of fact, I receive that “-ash: xxxx: not found” for any command I type.
The only commands that work are those “hassio” commands.

So, the question: How to install packages using Linux sudo commands??

Thank you!

Hassio does not have any apt-get capabilities. There is no ‘pi’ user. You don’t install packages inside the container

1 Like

If you want to install with apt-get etc, then you need to start again with Hassbian.

is there no way to get access to the Resin bash and install another container along with hass-io? I also need this capability, because I need the eibd deamon

The add-ons are installed in separate containers, if you want something that hasn’t already been created for you you can convert it yourself from a docker container…and then share the wealth :slight_smile:

This is kind of the whole point of hass.io, everything bar the core lives in it’s own independent container, which means you can happily restart HA as much as you like but all the add-ons keep running regardless. Very powerful but also very simple for those that aren’t so clued up and someone has already gone to the trouble of sharing an add-on they’ve created…community and all that :+1:

thanks. Will look into it. Not really a linux crack and never worked with docker before, but we’ll see. And yeah, I know how opensource and their communities work - I’m involved in a couple others

Wasn’t trying to imply anything :slight_smile:

You may well find someone has already done the docker bit elsewhere and there are guides here how to convert to an add-on, all a bit over my head though so can’t help further with that.

It is same for me don’t start pi user homeassistant start only with hassio commands.
I want to set the duckdns but I can not connect with terimanl using ssh [email protected]