Did run out of space during update, now HA wont start

I did the recent update, and unfortunately my system did run out of space. Mostly the VM disk was dynamically and therefore would have been okay, but the disk on the server did spill the beans and did run out of free bytes.

So I stopped the VM, did delete stuff from my MV disk and for good measures did a vboxmanage resize and added 8gb as we had been quite close to my dynamic max size anyway.

That went just as expected.

But now the VM does end up in EFI boot console. I have no experience with the EFI stuff.

I found a hint in here, and recreated the vbox vm, but that did not fix it.

how do I get my HA back? Or at least get the last backup before that last update to get back to this state.


I opened the vdi file with 7zip and am extracting the data image, hope i can get to a backup file this way.

so your reboot of the whole system, didn’t even “eventually” get you to the ha-console, in VM ?

nope, just stayed in the UEFI boot console. what ever I tried, it wont go further.

Now I have extracted the data image from the vdi file, but this seams to be corrupt, I cant open it with winrar or 7zip.

im not sure what you mean, when you are “referring” to “Stayed in UEFI boot console” ( maybe because i’ve never “stayed” there :slight_smile: ) … but im sure there must be something “telling” you , “everything is fine NOT” , is there any command-line in this “Uefi” boot-console ?, … or is it just hanging there ? … no options to “get help” in regards to “possible” commands options in there … or there is none ?

thats where i am:

it says nothing as in what the error might be, it just ends in the console. I could type help, that outputs 20 pages of commands, with no option for less or page scroll. so you see the commands starting from v onward…

I only have 1 uefi system, that was HA… no clue about uefi, never worked with it. I did try to avoid uefi for a bad experience in the past, so for that very reason.

Creating backups, without cleaning house on every update by removing old backups from last automated update backups just is crazy, especially if you dump updates in the pace the HA project does it, what I do like, but not the side effects. Also a system should complain when the stock vdi file set for 32GB is at 31,5GB on an update. That was just pure dump luck that my real HDD did run out of space less than 500mb before the VM disk itself did.

I think i just set it up from scratch… easier than recover anything from that hassios-data.img, i guess.

ok, well the link you refers, seems to be the “computers” UEFI boot ( most new computers have this UEFI boot, most likely yours to ) … so my question to you was therefore "how does it look like “This” UEFI boot … a “reverse” selfie would have been sufficient for me to understand …
so actually you now have 2 “UEFI” your computer, and your “virtual” machine … and yes, if you can’t figure out why your Virtual Manager stops in UEFI console, AND you can not click start “Guest/VM-image”, and you have not made any changes/updates to your VM host, and not are familiar with uefi(boot-manager) … and whether you are on a linux computer, windows, or PI, would also , beside a picture(showing what you mean) be very relevant info to “attach” to a Topic
… Yes, i think also it sounds like “crashed during upgrade” ( system corrupted ) , but with the lack of relevant info, my guess is as good as yours … good luck

so i have a host, hp proliant micro gen 8, running debian based OMV as a NAS and virtualbox, in this i build a vm based on the official home assistant provided .vdi file.

my system does have uefi, but i chose to steer way clear and did go old school. no such luck on the home assistant .vdi file, it is build for uefi and one has to activate per the instructions the uefi boot in virtualbox. I probably should have gone down the road of home assistant on debian 11 instead, but I opted for the vdi as it was way faster, and I just wanted to test and take a peak into HA. Well i stuck around.

now my uefiy console looks exactly as in the refferenced post, no sense in doing screen shots. thats it…

ok, well UEFI you can’t “steer” away from, so IF you have an option in you computers bios to disable this … i wouldn’t recommend that, as it’s VERY helpful … i don’t use/manage OVM/NSA or virtualbox, thou again, i’ve never had a system that crashed due to lack of diskspace … yes you could install Debian 11, on your HP, and go for HA Supervised, thou i don’t believe it’s a good choice for you, if you just want to test and look around, and your system crashed due to lack of diskspace, during a manual update of HA

the thin is, I have integrated the SSD into my file structure for easy handling, and I just did not monitor the disk space, as usually none of my systems start to fill up, and not by my choice the .vdi file was dynamically resizing itself…

with an old school bios i would just fix grub, push a kernel, and be done with it. with uefi, no clue, maybe i fool around a bit the other day and get convinced uefi is a nice thing, right now i need to get that stupid HA thing going or my wife will be very pleased when the lights stay off after sun set, in about an hour or so. hence I did not spent much time on fixing and started real fast setup from scratch.

i believe “dynamically resizing itself” is due to the fact that any “system” does provide logfiles, database files, backup(if not “dynamically” choices set/scripted to delete) etc. … but yes, it does dynamically resize it self, and if you haven’t integrated a huge amount of devices in HA ( i guess not, as you only wanted to look around), in your image, or haven’t applied alot new updates to HA lately, it shouldn’t have “resized” itself in any significant pace. Handling OVM/NAS does crave a bit more “attention” , if i should compare

well it did blow up to almost 32gb, I started with the stock vdi with about 1gb. so somewhere the 30,5gb have to come from.

I had a bunch of tasmota flashed gosund plugs, a hand full of automations. and some wifi bulbs and switches as well as my weather station.

was working an awnings and roller shutter control. and well, I did had hacs and stuff and every update since late 2021. every time a backup has been made.

what ever the reason, no sense in crying over spilled milk, how do i get that screwed up system to running state agein?

or at least pull the done backup out from the vdi file

Unlikely, when you start up the ( smal) .vdi first time it does “get” ( install depended files, updates etc, before final installation is done, maybe you forgot to check disk after and ever-since, i do have seen an issue with someone that had a “homeassistant.logfile” size 25GB , again this can’t occur unless you have tons of errors spewing, and logfile does “restart” from zerro, after system-reboot, and normally after major updates,

But , yes, if you haven’t payed any attention, to disksize( in your NAS), and logfiles/DB-file/backup ( Backup during updates about total( 2GB ) past 3 month, in Homeassistant, error-messages etc. , i dont really “see” why you want it running again

EDIT: But yes i do believe that you current(now belated) installation was about 32GB, and it will keep increasing, without a “dedicated” maintenance" , reading Update NOTES, etc. regarding major changes, in recorder etc. etc. etc.

PS: and someone who change retention/purge from default to infinity

Sorry can’t help you on that, i usually do a backup of my “image” after integrating/configuring integration/devices, or atleast when im confident with that it’s running “flawless” … always nice to pick-out a “new” image, in case of total-crash, or fu, thou ive never tried to “fire-up” any of my ( configured HA-Images … might be a good idea to check 1, see how that falls out

well, i think my question did not relate to “do I want it back or not”

it actually related to how do i get the backups out from the .img files that reside inside the official HA .vdi file.

so, maybe Im just dump, but I dont see how your posts can help me any in recovering my settings?

sorry, but i think that question should be in a VM forum, or falls under general google search “recover files from .vdi files” … a google search does usually include more related answers

unfortunately the .img thing inside the container disc format ‘.vdi’ is something special by the HA guys.

most other VirtualBox .vdi files just have the disk inside the .vdi file in plain text, readable with 7-zip out of the box.

hence I was asking here.

ok, well no offense, of-cause someone here might have experienced the same as you, and could help you, i wouldn’t have clicked a “Topic” saying " Recover/ extract from .vdi file" , and your initial question was “How do i get my HA back” … just trying to help/assist you, and still never saw anything relevant "documentation/pic or anything but eventually an url( which i assume you wanted to click on ), and as you don’t have experience of UEFI, would probably not be of any help anyway can’t tell, as you won’t “go that way” … you could open a new “Topic” with the relevant parts i.e , how do i recover files from a crashed .vdi ( in this OS, with this HA-image ) … or better off google in specific

so now im back with the new, all stock HA, and my backups just explode up, first 85mb, second 112mb, 3rd 260mb… If that was the same with the old HA, i do see where my diskspace went.

Its all the database. its over one GB already. And I havent set up any data-storage or my weather station; whos data I want to keep indefinetly; jet.

I dont have a problem on the server any more, as samba backup moves them out.

But for performance reasons I think its time to switch over to MariaDB. But I will run this through the community first.