Ecolink Firefighter - working with

Hi community. I should be receiving a RP3b tomorrow, with some Dome water detection/valve shutoff devices.

I was looking into a z-wave device for fire/smoke detection. In Canada, there are no CSA approved smoke detectors for z-wave.

One option is to install the Ecolink Eirefighter, which is an audio detector designed to pick up on the alarm signal from one of the linked smoke detectors.

Are there any issues between and this Ecolink device?

Did the Ecolink Firefighter end up working for you? Considering getting a couple (house and bunkie) but curious to know how you made out with it.


In short, yes. I have mounted the device about 4" from the alarm output of one of my wireless networked Smoke/CO alarms.The Firefighter will provide a response to Home Assistant when it detects smoke and/or carbon monoxide, (audible) alarms.

I haven’t incorporated the device into NodeRed yet, but the tests that I have done show the expected values to hassio, a binary sensor and several sensor entities. I think it’ll work great when I have time to program it in.

Thanks for your response. I’ll go ahead and get one on my next automation order :slight_smile:

How did you get the FF-ZWAVE5-ECO (Ecolink Firefighter audio detector) working? I’m using a Aeotec Z-Stick Gen5 with HA and every time I try to include it into my network it fails. The light on the firefighter goes from red (good) to green to slow blinking green which means it didn’t get included in the network.
Any suggestions for me?

Sorry, I had no issues pairing the Firefighter.

Sorry for asking, but Is the Firefighter near the Z-Stick when trying to pair, or is it possibly mounted already (and a considerable distance from the Aeotec)?

Thanks for responding… I don’t have the Firefighter mounted and have tried to pair it @20 ft away and @20 inches away and every distance in between.

Maybe I got a bad firefighter that wont pair.

Took a closer look at the electronics and realized I was trying to use the cover switch as the learn button. Once I found that super tiny learn button and did the appropriate steps it worked as intended. So my issue was a user issue and not a device issue.

Nice work troubleshooting the install. Glad everything is working!

Sorry to renew this thread, but I just got around to installing this device and I’m running into some trouble with it.

@Ellis.Dee_25, @kcclone, are you able to detect both Carbon Monoxide and Fire? I can get the CM sensor to flip from 0 to 2 when I test it, but I’m not seeing anything come in when the Fire alarm portion of the test fires.

I’m probably like 1" from the detector. I see @Ellis.Dee_25 you were at 4". Did you have to play with the distance to get it to work? I have it already mounted and I’ll probably try moving it a bit away regardless, but just curious if that’s likely to fix my issue.

Also, I’m getting nothing from the binary sensor that came with it. Which I think makes sense becuase it’s doing a basic report and not a binary report:

2019-01-30 17:56:06.252 Info, Node126, Received Basic report from node 126: level=0
... later when it resets ...
2019-01-30 17:56:06.252 Detail, Node126, Refreshed Value: old value=255, new value=0, type=byte 

Is that your experiences as well?

I just got one of these installaed.
Using Hassio on rpi3b+ with nortek combo stick.

I had no issues pairing it and am getting info from the temperature and tamper (burgler) sensors. I have mine mounted about 1" from the smoke detector and upon pressing the “test” button on the detector, I get the single loud beep that is expected. However, the Firefighter is either not hearing it or not sending the signal that it was heard to my hassio instance.

Anyone else having this same thing going on?

shoeman22 did you get this guy sending alerts? Also how are you testing the carbon monoxide sensor?

Well I found that when I hold the test button for longer, I get the alert on the 3rd or so beep from the smoke detector… So that’s awesome.

But I’m still not sure how to get CO alerts… It may not be something that’s possible in my situation. I have a CO detector outside of the room where the firefighter is located. I guess it just listens for a different tone? Not sure if it’ll hear it since it states that the alarms need to be maximum 6" away. If anyone has insight on this I’d appreciate it.


Just wanted to add, that I installed this yesterday and played around with it today and I am only able to get it to detect the smoke event going from 0 to 2.

I can’t get it to detect the carbon monoxide and until I read the earlier posts in the thread, I thought the fact that I couldn’t get the binary sensor to change was because I didn’t install it properly or it was broken.

Here is what it looks like in my logs:

2020-01-26 15:06:01.734 Detail, Node018,   Received: 0x01, 0x10, 0x00, 0x04, 0x00, 0x12, 0x0a, 0x71, 0x05, 0x00, 0x00, 0x00, 0xff, 0x01, 0x02, 0x00, 0x00, 0x7b
2020-01-26 15:06:01.734 Detail,
2020-01-26 15:06:01.734 Info, Node018, Received Alarm report: type=0, level=0, sensorSrcID=0, type:Smoke event:2, status=255
2020-01-26 15:06:01.734 Detail, Node018, Refreshed Value: old value=0, new value=0, type=byte
2020-01-26 15:06:01.734 Detail, Node018, Changes to this value are not verified
2020-01-26 15:06:01.734 Detail, Node018, Refreshed Value: old value=0, new value=0, type=byte
2020-01-26 15:06:01.734 Detail, Node018, Changes to this value are not verified
2020-01-26 15:06:01.734 Detail, Node018, Refreshed Value: old value=0, new value=0, type=byte
2020-01-26 15:06:01.734 Detail, Node018, Changes to this value are not verified
2020-01-26 15:06:01.735 Detail, Node018, Refreshed Value: old value=0, new value=2, type=byte
2020-01-26 15:06:01.735 Detail, Node018, Changes to this value are not verified
2020-01-26 15:06:01.735 Detail, Node018, Notification: ValueChanged
2020-01-26 15:06:01.736 Detail, Node018, Notification: ValueChanged
2020-01-26 15:06:01.737 Detail, Node018, Notification: ValueChanged
2020-01-26 15:06:01.738 Detail, Node018, Notification: ValueChanged
2020-01-26 15:06:01.752 Detail, Node018,   Received: 0x01, 0x09, 0x00, 0x04, 0x00, 0x12, 0x03, 0x20, 0x03, 0xff, 0x3f
2020-01-26 15:06:01.753 Detail,
2020-01-26 15:06:01.753 Info, Node018, Received Basic report from node 18: level=255

Did anyone ever figure out how to get the CO state to reset to 0 so that a change can be detected?
I notice that it all works great if I manually override the state to 0 in developer settings but that not a long term solution.

Maybe you have CO that it’s detecting? :face_with_hand_over_mouth:

Do you know if it listen for a different sound or does it have an internal CO sensor?

Nope. I just ran another test earlier today and while the Smoke state resets to 0 after the smoke detector beeps, the CO state says as 2. So now every time I reset home assistant, I keep getting an alert that there is CO detected.

Until I can figure something out, I will just comment out the CO portion for now.

Same issue here. I may not have been quick enough testing, but when my smoke/co2 detector went off during testing I didn’t see smoke change from 0, but co2 changed from 0 to 2 and hasn’t gone back.

Does smoke also go from 0 to 2? I think my kids will freak if I test again to find out.

Yes. I created an automation to test two binary_sensors:

  • binary_sensor.smoke_detected
  • binary_sensor.carbon_monoxide_detected


      # Smoke Detector Status
        value_template: "{{ is_state('sensor.ecolink_firefighter_smoke', '2') }}"
        device_class: smoke

      # Carbon Monoxide Detector Status
        value_template: "{{ is_state('sensor.ecolink_firefighter_carbon_monoxide', '2') }}"
        device_class: gas


  - alias: "Smoke/Carbon Monoxide Alarm"
    initial_state: true
      platform: state
        - binary_sensor.smoke_detected
        - binary_sensor.carbon_monoxide_detected
      from: 'off'
      to: 'on'
      - condition: state
        entity_id: input_boolean.disable_smoke_co_alarm
        state: 'off'
      - service: notify.mobile_app_<phone_name>
          title: "Smoke/Carbon Monoxide Alarm"
          message: "{{ }} has been detected in the home!"

Only after the smoke detector finished all of it’s beeps does it “reset” my smoke detector status back to 0 (Off). However, the carbon monoxide sensor stays as 2 (“On”).

I did read somewhere that if you open the Ecolink Firefighter cover after the initial beeps from the smoke detector does it eventually reset the values back to normal. Now, I did try that, but that does not sound like a long-term solution each time I want to conduct a monthly test on the smoke detectors.

1 Like

did you figure it out eventually? I am also thinking ecolink Zigbee but not sure if CO will work.

Did you add yours to HA with deconz? or yours is zwave? I dont see Ecolink listed in deconz compatible devices.

Have you tried to wait longer to see if CO it will reset to 0. It might be the CO sensor takes longer to clear.