Editing config.txt issue

Hey guys new to home assistant. been watching a lot of videos and beginning to get my system going. I installed deconz and purchased a raspbee that installs on the header pins of the rpi to control zigbee devices. the directions say i need to add 2 lines to the config.txt file which on the root of the sd card.


if i take the sd card out of the pi and install it into my windows machine i cant access the sd card. it just keeps popping up saying it want me to format the sd card. If i put it back in the pi ha starts up and runs just fine. Is there another way to add those 2 lines to the config.txt file??

thanks again guys for all the help appreciate it

  1. Run a linux OS from USB or CD on your windows machine - it will recognise all the partitions on the hassio SD card; or

  2. ssh into your hassio instance, mount the boot partition of the sd card read-write and edit config.txt; or

  3. Pretty sure windows should recognise the boot partition anyway as it is some form of fat partition.

Thanks for the help!

I was reading online and multiple people said windows should see it but when i put it in it just pops up not recognized or something and another box says to format.

I have winscp as well at putty. Could you explain step by step how to do number 2. Im new to the script thing. Thanks again!

While the Linux OS boot CD will work, you don’t need to do that.

Your formatted as card will contain 2 partitions:

Boot is formatted FAT32 and is readable by windows. This is where the config.txt file is located.
Root is formatted ext4 and is not readable by windows - causing all the pop ups about formatting device.

So insert card in Windows, don’t format, but also don’t eject. You should see a mounted device named BOOT where you can find and edit the file.

That seems to be the issue. I only get 1 drive F:/ i dont get 2.

And what is in f: ?

sorry for the super late response. I really thought it was a corrupt sd card. my new 32gig finally came in and i went ahead and did a fresh flash of hassio. i put it in my rpi3 and let everything boot. i installed a few basic addons and shutdown. took the new sd card out and out it back in my computer. the first pop up says you need to format disk f before you can use it. i hit cancel. then a box pops up saying f is not accessible. its the same with the old sd and new.

i didnt do anything to the sd card before i used etcher. could that matter?

No that shouldn’t matter. Try putting it in a computer that has a proper operating system instead of windows.

thanks for everyones help. I did manage to fix this issue. I took the sd card out and put it in windows. I cleared all the partitions with diskpart in cmd prompt. Then formatted the entire sd in fat32 with disk management. i decided to do a full format instead of a quick. no idea if it mattered. then installed hassio with etcher. the hassio boot drive now pops up and works like it should. not sure if the sd wasnt formatted fat32 or what the deal was. Its working now.

Hi, I’m also trying to do this, but after editing my HA won’t boot anymore. Where exacly did you place the 2 lines?
My HA won’t load anymore if I place those lines at the end of the file, or am I not patient enough?

I am going crazy with this, have the same problem. Re-flashed the SD over 10 times now and tried different ways of editing the config.txt. Have you solved this?

Meant to reply to you with above message.

No, I also ended up bricking the raspbee. It did not work anymore on the other pi I had it running correctly on. Ended up buying the conbee 2 (usb), that worked, but had to do the pairing etc all over.

Thanks for replying :slight_smile: That’s too bad. I did get it working eventually (Raspbee running op Rpi4). I’ll link my solution/topic for others who might visit this topic in dispair. It involved using Windows for config.txt and Raspbian Buster Desktop for upgradin the Raspbee firmware.