Enable Location Tracking

When trying to enable location tracking the app will freeze. Have to close and re-open.

I have the same problem trying to enable notifications.

Same issue here

I’ve managed to enable location tracking but cannot att the track_ios: true to my home assistant confirguration file. It says that it is not supported.

What’s “track_ios: true” doing, when is it needed?

It replaces the individual location tracking per zone settings on the device so that I didn’t have to create another database just to store that one thing.

So what does it do? Won’t HA trigger home/away if it’s not enabled?

I’m having the same issue. adding track_ios: true seems to be a solution to a different problem. The application freezes when trying to tap “Enable Location Tracking.” I’ve tried re-installing the app.

Latest .42.4 and Enabling Location / Notification freezes the app and eventually crashes. IOS Component enabled. Do we need to perform any other actions inside the config file before attempting to enable?

Uninstall the app from your iPhone and reinstall should be fine after that.

Uninstalling / Reinstalling got the Notification section working. Location still freezing.

Can confirm this is also happening to me - iOS App itself freezes when enabling Location. Notification enables just fine. Is this the best place to watch for fixes to this issue?

1 Like

UPDATE: I deleted and re-installed the app, this time I tried turning on Location first, then Notifications. Both are successfully enabled now; not sure why that fixes it.


Did you have 1.0 installed originally? For a couple of people that was the case, they were having crashes and then reinstalling fixed it.

I was having issues as well with setting up the location tracking. I had set up notifications first, and they were working beautifully. But then when I tried to click on the enable location tracking in the settings, it would just freeze app.

So I tried what @fouram suggested , to uninstall app, and re-install. This time enabling location tracking first, then notifications. I did this and it worked. Now I have location tracking enabled just fine, and notifications too.

1 Like

Glad to hear you got it working. Not sure if it was the reinstall, or the change in the order of feature enabling, or both? Hopefully that’s enough of a clue for the devs to track this one down.

@fouram suggestions seems to be working: :thumbsup:

1. Uninstall and reinstall app
2. Enable Location Tracking
3. Enable Notifications

Thanks so much for figuring this one out guys, I can now reproduce the problem and fix is coming in 1.0.3!

1 Like

Hey what OS version was everyone on? @fouram @IROTRAS @Airpal, @ChipSkylark37