Entity_registry.yaml is gone as of version 0.77.1, as well as the GUI entity registry editor

No sarcasm :man_shrugging:

No, I mean MY sarcasm when I wrote that.

That was sarcasm…

never mind…:roll_eyes:


Ah, you’d be amazed (ok, maybe you wouldn’t) at how many people complain about every change demanding to know why the new way was introduced :man_shrugging:

I’ve got used to largely taking those things at face value as a result of that (and that almost nobody bothers to read the docs, but instead follows ancient YouTube videos).


Oooh. Now there’s some sarcasm! :wink:

I think…

Here is a real world scenario I’m confronted with that was easy to fix with the old system but I can’t figure out how with the new GUI.

I can’t name a new zwave light “kitchen” because “Kitchen” is taken by a dead node that no longer shows in the GUI anywhere. This also means I can’t ask Alexa to turn on the Kitchen, because of the naming conflict.

What am I to do without messing with the hidden entities file?

It’s buried in the replies, but you have to edit the registry manually, which is technically not a thing you’re supposed to do. But apparently the devs have never run into the incredibly rare occurrence (sarcasm) that you stated and editing ghost entries in a sanctioned way is impossible.

The files to edit are in (config)/.storage. Don’t edit the files while HA is running.

This was all done for your convenience.

What timing on my end. Just now, I needed to switch my wemo and tp link smart outlets and what should have been a 30 second thing changing the names of 2 entities in the entity registry has become a problem that there is not currently a solution for… unless you know JSON or want to risk having a headache messing with stuff.

If there is a way to do this via the front end, I’m not seeing it. Please help!

I’m pretty sure you can just click on the entity you want to change the entity_id for, then click the ‘gear’ symbol in the top right of the window that pops up then change the entity_id line then click ‘save’. I can’t confirm that it works because I haven’t had the need to try it yet but I think that’s the way it’s supposed to work. I think…

If all of the things that the 'entity_registry" was supposedly designed to allow you to do were really as easy as that then there wouldn’t be any complaints. But unfortunately that’s not the case (just ask the person who added a bunch of zwave devices that created 13 entities each how they felt about having to manually change over 250 entity_id’s… :roll_eyes:)

Maybe somebody should raise an issue in Github to bring it to their attention then :wink:

Add your vote to this feature request


Thanks for pointing that out.

There already is a bug report about it.

1 Like

Dusing this reply was meant for you: Entity_registry.yaml is gone as of version 0.77.1, as well as the GUI entity registry editor

I just hit this “Entity is already registered” problem after having to re-add half a dozen Tradfri bulbs to the system (with the same name as before) which HA then handily added “_2” to the end of their names breaking all my automations in the process.

With no way to remove the old “zombie” entities using the GUI, I had to either do a messy search and replace on all my scripts and automations resulting in different names for the same device on HA and the Tradfri gateway, or edit the entity registry manually. In the end, it was quickest to remove all the Tradfri entities from the registry and get HA to rediscover the whole system, pulling the bulb names from the Tradfri gateway and bringing everything back in sync

If we’re not supposed to tinker with these files, we do need a way to solve these (admittedly infrequent) issues using the GUI front end.

1 Like

Just came here to say I had to edit this file manually as well to fix an issue with some old Wemo switches. Thankfully this thread was here, otherwise I’d still be befuddled. Gross!

UPDATE: Hooray Entity Editing via GUI! Nice work.

I also just hit this with a dead zwave switch… Now I added a new node and the name is taken up and it’s dead and no way for me to remove the old one…

I just ran into this recently myself when I had a z-wave switch completely die on me (it didn’t even work as a dumb switch anymore.) This is from memory so I apologize if I miss a step, but this should get you close.

  1. Go to Z-Wave control panel.
  2. Select your Node from the Node Management dropdown.
  3. Select “test node.”
  4. After you test the node and it comes back dead, you should have a “remove dead node” option.

There is also this process where you set the “is_failed” to “true.”

I know this is going back a ways, but Im having the same issues with some bulbs. HA reporting ghost entitys

Im running supervisor, so not sure how or where to find the registry?

You can manage “ghost” entities (and devices) in the UI. Look under Configuration → Entities

Thanks mate! I did, they were not there.

In the end it was the smartthings intergration. I disabled it, not deleted it. So the entities were hidden somehow. Removed the intergration and everything was fine :slight_smile: