Error returned from Supervisor: System is not ready with state: setup

Hi. Today I installed last updates as always when new version comes. My device is Rpi4.
After restart I got same problem as discussed above. “Banner”, “Supervisor restore” not helps.
I found old SD card worked for me many years before. I left it before a half of year and made a copy on better card, which is installed now and do not started.
After I try to start HA with an old working SD, I got same error.

I think, problem is not in updates or card or software, but in Hardware.
Trying to find why…

Hi,
My home assistant is installed on VMM Synology.

* Core: 2023.11.3
* Supervisor: 2023.11.6
* Operating System: 11.1
* User interface: 20231030.2

I was getting the error Error returned from Supervisor: System is not ready with state: setup on every reboot, which I apparently resolved by deleting:

/config/home-assistant_v2.db
/config/home-assistant_v2.db-shm
/config/home-assistant_v2.db-wal

and reboot.
Hope this helps.
Have a nice day.

1 Like

This has always appeared to be a poorly set timeout of some sort. I would guess that deleting the database just makes startup happen slightly quicker thus avoiding the issue. If I’m right the issue will reappear once your history grows sufficiently again.

You’re right :unamused: the error has returned.

Apologies for somewhat of a dumb question, but how does one delete these files?

Those files are in the config-folder of HA…

BUT!! Deleting these files will also make you loose all your history.

I just upgraded hardware and my allocated cores were not paired by default. So my VMs were painfully slow. I got this error message. It took about 5 minutes to boot. And when I typed banner all was fine.

Then I paired the cores and restarted and it loaded within about 30 seconds and no error message. This clearly points to a timeout issue as indicated above.

Thanks to the posters for sharing this as it helped me diagnose the issue very quickly.

Hello,

In my case, every night at 3:00 something happens that prevents me from connecting to the Home Assistant, the error shown being the one mentioned above: Error returned from Supervisor: system is not ready with state: setup

For it to work I have to turn off and start home assistant and everything works again until the next night.

In my case I have it installed on a QNAP with virtualization station, updated to the latest version

Same problem, started last night apparently. Running a vm on a synology. Was running fine so far.

hmm, that didn’t quite work for me!

this very same error happened to me today.

after disconnecting raspi3 from power (that runs adguard) - my home assistant went mad - it absolutely broke completely :frowning:

whenever I start it up - it will load for ever.

in cli I get this:

image

GUI keeps connection lost - reconnecting.

managed to finally run it in safe mode.

pinging HA gives flaky results:

image

I run ma HA within proxmox 7 - this was never an issue up until today…

things like banner, supervisor repair, restart - didn’t help.

could anyone direct me what should I do?

I do have backup but I am worried it will not work :confused: (it is full backup indeed).