Fibaro dimmer 2 S2 functionality

Tags: #<Tag:0x00007f3265e9b1c0> #<Tag:0x00007f3265e9af90>

I created this blueprint on the basis of vbflo’s blueprint I found (Inovelli LZW36 Fan/Dimmer Scenes)

This blueprint creates an automation for the fibaro dimmer 2 functions of the S2 switch.
Select witch device you want to use and than create actions for all S2 functions:

  • 1 press
  • 2 presses
  • 3 presses
  • hold
blueprint:
  name: Fibaro Dimmer 2 S2 
  description: |
    Use this blueprint to create automations based on button presses for the Fibaro Dimmer 2 
  domain: automation
  input:
    fibaro_entity:
      name: Fibaro Dimmer
      description: The Fibaro Dimmer that will trigger the scenes
      selector:
        entity:
          integration: zwave

    s2_button_once:
      name: S2 Button Once
      description: Pick an action for when the s2 button is pressed once.
      selector:
        action: 

    s2_button_twice:
      name: S2 Button Twice
      description: Pick an action for when the s2 button is pressed twice.
      selector:
        action: 

    s2_button_trice:
      name: S2 Button Three Times
      description: Pick an action for when the s2 button is pressed three times.
      selector:
        action: 

    s2_button_hold:
      name: S2 Button Hold
      description: Pick an action for when the s2 button is hold.
      selector:
        action: 

mode: single

trigger:
  - platform: event
    event_type: zwave.scene_activated
    event_data:
      entity_id: !input fibaro_entity
action:
  - variables:
      scene_id: "{{ trigger.event.data.scene_id }}"
  
  - choose:
    - conditions:
        - "{{ scene_id == 26 }}"
      sequence: !input s2_button_once
      
  - choose:
    - conditions:
        - "{{ scene_id == 24 }}"
      sequence: !input s2_button_twice

    - conditions:
        - "{{ scene_id == 25 }}"
      sequence: !input s2_button_trice

    - conditions:
        - "{{ scene_id == 22 }}"
      sequence: !input s2_button_hold
4 Likes

I love this blueprint. Could you make the double/triple/gold optional?

tnx :slight_smile:
Good question. I dont know if this is possible.
Some things you can do:

  • Put a delay of 1 sec in the buttons you do not want to use.
  • Edit the blueprint yaml (remove the button presses you dont want to use).

@RutgerJoosten Setting the default value for each action to [] should make all the actions optional. Then people can override them whenever necessary.

1 Like

Aah cool tnx! :smile:
@tvdmoosdijk I adjusted the blueprint. I think you need to import it again to get the changes.

1 Like

I get an error when importing:

Invalid blueprint: expected a dictionary for dictionary value @ data['blueprint']['input']['s2_button_hold']['selector']. Got OrderedDict([('action', [])]) expected a dictionary for dictionary value @ data['blueprint']['input']['s2_button_once']['selector']. Got OrderedDict([('action', [])]) expected a dictionary for dictionary value @ data['blueprint']['input']['s2_button_trice']['selector']. Got OrderedDict([('action', [])]) expected a dictionary for dictionary value @ data['blueprint']['input']['s2_button_twice']['selector']. Got OrderedDict([('action', [])])

Hmm this is very strange. I restarted mij HA and now I get the same error. It worked before my restart…
I could just select 1 action and save the automation.

For now I removed the [] after the action. It is no longer optional, but it should work again.
I will look for a solution for this, but I see someone else also having trouble with this as well in another topic not giving me much hope for now.

very nice!!!

big thx!

My entiteit drop down says “Geen overeenkomende entiteiten gevonden”. But i do have multiple Fibaro 2 dimmers installed ? Do you know how to fix this?

thanks
M

Hmm that is strange. I got the whole list of zwave devices, lights and sensors.
I’m can’t think of anything on how to fix this unfortunately. I don’t think this is due to the blueprint, because it just searches for all zwave devices.

“Have you tried turning it off and on again? :upside_down_face:” (Maybe a restart can help, I also had some strange behaviour that fixed itself after a restart of HA).
Sorry that I can’t be of more help.

I have the same problem, empty dropdown for choosing my dimmers.

Br
Olle

Could it be a bug?
For test sake I imported this blueprint again to check if I got the same problem. This is not the case, so I don’t think the blueprint is wrong.

I am not a dev, so I don’t know what else I can do.
You can try to report this as a bug, then they can look into it.