Fibaro RGBW Controller 2 (FGRGBW-442) - Device unknown

I am adding this to my Home assistant, but only a list of sensors show up and the device name shown as unknown. This is the Fibaro RGBW Controller 2. Any thougts?

I bought one just last week and had the same issue.

Seems like the RGBW controller 2 isn’t on the device list yet, but the RGBW controller is.

I didn’t feel like mucking around, so I returned my 2 for a 1 and it works for my needs (except for the swapped colors thing (click green, see red, etc.)).

So just swap your outputs till red = red, green = green, blue = blue and white = white

I’m using controller 2 and I admit that it is as confusing as hell
6 switches turn up in HA

  1. controls red
  2. controls green
  3. controls blue
  4. controls white
  5. controls last
  6. controls colour

I’m not sure what order they show up in everybody’s systems (you probably need to experiment) of the above 1 to 4 are self explanatory. 6. gives you a switch that you can bring on and adjust the colour directly and 5. seems to be whatever the light was on last at i.e. green if it was green etc.
Basically I’ve hidden all of them apart from 4 and 6 and when I need to use either the automation sets a colour (if applicable) and brightness

I ended up just creating scenes for certain colors… but it’s quite annoying when my light is actually red, but the active icon in HA shows as green.

I hear you, not only showing a green bulb in the frontend but when in the colour wheel you select blue - and the light goes blue, but then a second later it goes to green on the colour wheel (but without affecting the actual strip). so when ‘Adjusting’ colours you have to constantly remember where it should be showing so you can just tweak it a bit more towards red or whatever.
Frustrating ! :rage:

Hi guys!

I have also bought the fibaro rgbw 2 controller.

How have you even managed it to work?
At my researches I found out that it’s not in the open-zwave and so also not in home assistant.

I found then this fork of open-zwave where a guy implemented the configuration for the controller 2: https://github.com/brouwer/open-zwave/commit/988f6dda98e6090adaa8706e8051b41d432cf8e5

I tried to integrate this into my zwcfg_*.xml file.
It actually change the device in my z-wave settings that I can now set configurations of the node.
BUT my node has 0 enities now. So I cannot control anything.

If I find out something more I’ll let you know.

I’m afraid that my installation is completely vanilla and I have no problem making it work.
Open z wave should be implemented in the next 3 to 6 months so that should improve things

Ok thank you. Thats sad.

I sent it back and maybe reorder when open z-wave changes within homeassistant.

Hello guys,
Thanks for the thread. Any updates on the RGBW controller 2, I’ve been fighting with it for weeks before discovering your messages.

I only get sensor entities and no control entities.

Does any of you have a solution to fix it ?

Thanks !

Hi, I am also waiting for this to be resolved. Does someone know how to make it work with Home Assistant (and Open Zwave)? Thanks!

Hi Wendu, did you manage to get the RGBW 2 to work with Home Assistant? Would you mind to describe in a bit more detail which part of the zwcfg_*.xml file that you edited (and how)? Thanks!

Hi I was not able do install it. I removed it again and sent it back.

I am sorry that I cannot help

Same here. Two solutions are possible. Homeassistant bumps it’s Open Z-Wave version to 1.6 (currently it’s 1.4). This is as far is I know not in the books yet.
The other… use the xml from the open z-wave 1.6 to mumbojumbo your zwcfg.xml file.

Yeah still looking for courage to that last one. Can’t return the fibaro so I have even thought of just buying the old version and connecting that one.

Best would be that someone that already did the hard work, shares it’s zwcfg.xml file.

I just found this thread after having difficulties using the RGBW Controller 2 with Domoticz. The latest Domoticz 2020.1 does use open z-wave 1.6, but still does not recognize the module correctly.

After following these steps (manually adding the xml file and adjusting the manufacturer_specific.xml) I managed to include the module and have it recognized correctly.

However, I do not see most of the “control entities” as mentioned in this thread. I can’t control the outputs properly. This could be a similar problem as being described here.

It might indicate that further adjustments are required on the z-wave 1.6 implementation that I’ve tried.

After discussing this with the author of the adjusted xml files for the FGRGBW-442 he states that the XML-files aren’t finished and need further work. That’s probably the reason not all devices are being found.

He also states that open-zwave might only support version 2 of the command class color switch and that the module is using version 3. But he’s not sure if this is causing the problem.

Concluding, the open-zwave implementation for this device needs further work.

I got as far as to have it show as the correct Fibaro type. But it still only shows the sensor entities and no lights. So tough luck.

Does any one know when we can expect the open z-wave upgrade to 1.6?

Hey, from what I can tell from looking at the manual, the Zooz ZEN31 and the Fibaro RGBW Controller 2 are similar (if not the same) device. I know there has been some headway made with the Zooz ZEN31, and one of the problems seems to be with the zwave discovery schema. I modified my home assistant instance as suggested in the link below, and one light entity showed up. It kinda works, I can turn it on and off as well as dim. I can’t seem to control the white channel or change colors.

Also having this question! Need to replace my current fibaro RGBW dimmers with zwave plus…

I got the Zooz ZEN31 working. Maybe this will wirk for the Fibaro RGBW Controller 2.

Just made a coffee and prepared myself for long debugging evening when got notification about your post. You made my day bro! It works exactly the same with Fibaro FGRGBW442. Looks like these two modules are clones. Thanks a lot for update!

1 Like