Fitbit Integration Authentication Instructions?

I followed JeeSee post above and also didn’t succeeded. You are refering to some “All options” and changes in hassio 0.102 - can you help me clearify thoose parts?

Hi I created a new API instance at the FIT APP site and then it started work again. I don’t if something changed when Google acquired Fitbit.

Ok, did you do these parts?

  • Created a folder named ‘fitbit’ in my ‘custom_components’ folder
  • Copied the file from Github as ‘’ in this folder.

Nope - or actually that I did at first. But What made the different (I think) was creating a new Fitbit/Google App connection (Token)

1 Like

Hi All,

I’m trying to set up the Fitbit Integration and I can’t figure it out. When I go to the following information is required:

Application Name
Application Website
Organization Website
Terms Of Service URL
Privacy Policy URL
OAuth 2.0 Application Type (Server, Client, Personal)
Callback URL
Default Access Type (Read & Write, Read-Only)

Application Name, Description, OAuth 2.0 Application Type and Default Access Type are either self explanatory or provided by HA Notifications - CONFIGURE. I did change the Callback URL to HTTPS. But, where do I find the additional information required to register an application.

The information that I still require is Application Website, Organization, Organization Website, Terms Of Service URL and Privacy Policy URL. Must I build a website to provide these URL’s?


@williamwhoch Just make them up. I pasted the same URL for my home assistant that you used in the callback

Anyone know what the sensor names will look like if it’s working? I think I messed up the authorization and I don’t know how to fix it. I have a sensor.steps but I think that’s from the HA app.

Nevermind, It’s “sensor.steps_2”. Looks like I did it ok.

Thank you, that worked. All I have to do now is setup HTTPS.

I have this problem…
My run on a Synology NAS under Docker. It works well but two days ago I was no longer able to reach the Home Assinstand interface. I reinstalled it and recovered everything through a snapshop I had done. But Fitbit is no longer configured. I tried to delete it from the configuration, restart, reinsert it and restart again but nothing.
Anyone have any ideas?

I’m trying to add this, but there’s a problem. The callback url is set to the local ip for some reason (http) and not https (because that’s not configured). I go via the nabu casa cloud. If I set that as callback url, the integration fails miserably. Ok, I change the wrong http local ip url in that adress to the naby casa url and I get the authorize page, I select every option hit authorize and than i get a big fat 500 internal server error. How does this work? And what’s the correct callback url if you use Nabu Casa cloud? Is that a bug that it only works on the local ip? Because I don’t want to set that up again with let’s encrypt and the whole stuff. Nabu Casa is easier and I support HA with that money.


I have the exact same issue as stefan. I remember setting this on my previous HA instance before and I had to try a million things until it worked, but now for the life of me I can’t figure it out.

Tried everything, same as mrkesu had it working in a previous installation but now really stumped.

we now have .


#  ssl_certificate: /ssl/fullchain.pem
#  ssl_key: /ssl/privkey.pem 
#  base_url:

Tried it with NGINX turned on / off, DuckDNS on / off, some of or all configurations in .yaml commented out.

Also tried

I remember months back in my original setup I used my external I.P. but again cannot remeber exactly what worked.

Have HA given up on the fitbit Integration?

I got mine to work now with Nabu Casa.

  1. With the new internal\external URL settings in the UI I set both to “”
  2. Edited fitbit app to use “” as callback
  3. Rebooted home assistant
  4. Opened notification to configure fitbit and clicked the link.
  5. Nothing happened (?)
  6. Checked states under developer tools and YAY, sensor.weight is there from fitbit!
  7. Get depressed about my weight.
1 Like

explain number 2; there’s no such thing as a fitbit app, where does it say that?

I was able to use the Fitbit integration for several months. Then one day it stopped working. I can’t remember when or what changes I made around that time,or if it was when I was making changes, or if I was making changes around that time, or if it was weeks or months ago that it stopped working. Then I set it up with the Nabu Casa url. I wanted to spend time trying again to set it up without Nabu Casa in case I ever stop using Nabu Casa. Now. I can’t see Fitbit in the Integrations page of Home Assistant Configuration even if I take the Fitbit data out of the sensors.yaml. I haven’t signed out of Nabu Casa and am wondering if that is the reason it doesn’t show up.I think I am giving up and leaving it as is unless it breaks.

edit: I also realized that I could have tried deleting the app on the Fitbit end

I think he is talking about the app at Login

Hey guys, im trying since a few days now and no matter what i do i always get this message when i want to authorize the app.

Developer information: unauthorized_client - Invalid client_id

I have no idea what i did wrong, as i just copied and pasted the client_id given to me into the fitbir.conf

Any ideas?

I see this issue got closed and merged (Fitbit authorization always ends up with Server Code 500 · Issue #49285 · home-assistant/core · GitHub), does anyone know when this makes it into a core HA release? I just updated to 2021.6.6 but I still get the same issues trying to authenticate…

i still have problems with the docker home assistant container :frowning: