Flashing hard drive get stuck at 31% (balena fetcher)

It seems balena etcher occasionally get’s stuck during the downloading process.

It is therefore safer to first download the image, and use balena etcher locally instead :wink:

Of course, that’s what I did. From the URL it didn’t start at all.


Same here. I did download first, then flashing, yet it freezes.

1 Like

Indeed, as @Damos said, there is some problem with the networking with HAOS instance installed with such a freezing Balena process. There are 2 “pre-loaded” cloud integrations: Radio Browser and Meteorologisk Institutt (at least on version 10.4 of HAOS). Both fail to work. But I remember that before installing HAOS on my (Chrome)box I run HAOS from SD card and both these integrations worked OK from the start.

1 Like

@Damos I’m sorry for - maybe - a basic question. How do you get the console (shown in the top 2 screenshots) on a hardware with installed HAOS?

After installation I only get
prompt but it has no ping command etc. If I get into the real console I could try and test ping just like you did.

@keydi, since HA is running, I connected from a client to http://[IP-address]:8123 and installed the HA Community Ad-on “SSH & Web Terminal”: Home Assistant Community Add-on: SSH & Web Terminal. From there you can work on OS level.
Installation is straightforward. Just keep in mind that you need to assign a password in the configuration section of the add-on.
If you assign a user too, you can connect with putty as well.

1 Like

This is EXACTLY the same issue I have : Need help - many issues, probably related to each other - #28 by nukem1232

So you also had the installation stuck at 31% and have the same issue as me with the DNS? There is therefore a high chance that they are correlated…

Lol, are you me ? This is exactly, word for word, what I did and occurred to me.

Same for me, whole system crashed.

Same and same

Yes indeed, both fails on my system as well.

So i guess we can safely conclude that the flashing didn’t work properly…

I will order a sata-usb adapter from amazon and flash it from my main computer. This should solve the issue hopefully.


I appreciate the additional step with the SATA-USB adapter. But - I bet a beer that this won’t solve the DNS problem. I cannot believe that the flashing behavior has impact just on the DNS parameter. My guess would be the whole platform won’t be running. IMHO everything else works fine.

However, give it a try - I’d like to be proven wrong! :wink:



I see what you mean, but this would be a massive coincidence that you and me have the exact same issue with dns after having suffered from that strange flashing behavior.
(+ Keydi above mentionned what seems to be a known issue with networking:


I just ordered a m2-usb connector (thinclient runs a m2 ssd) and will keep you posted (ETA this Friday)

What would be your other guess to explain these issues?

My guess: a bug in HAOS. Nevertheless, if just we two have the problem, then fine, let’s see.

What are you going to do? connect a SATA drive to the thin client, flash HAOS on it and have it boot from there?

Agree that this might be a bug into HAOS. However, the fact pattern prior to that bug is the very same for you and me, which is the freezing of the ssd flash. This lead me to conclude, possibly wrongfully, that the freezing creates the DNS issue/bug.

What I am gonna do : I ordered a sata to usb connector (make sure to purchase the correct connector, thinclient is a m2 ssd, but you might need a sata 2.5’’). I will take out the ssd from the thinclient, plug it into the connector, and plug that into my main windows computer, and from there flash the thinclient SSD using balena.

This is what is described as option 1 on the HAOS installation guide.

Considering it will bypass any instability that a live Ubuntu OS may have with balena, I really hope this will solve the issue for good. I will keep updating this topic once I went through this process.

1 Like

:sunglasses: Good luck!

I might have found a solution. On a live distro of Lubuntu (booted on my former Chromebox from SD card) I installed and used USBImager instead of Balena Etcher.
I used USBImager to flash SSD of my Chromebox with HAOS image (if I remember correctly, I unpacked xz archive beforehand, so the file was *.img). No freezing etc. Chromebox booted nicely to HAOS. After all the initial configuration of HA, I don’t see networking issues I reported in my previous posts, i.e.:

  • pre-loaded cloud integrations (Radio Browser and Meteorologisk Institutt) work from the start
  • ping works both with URL and IP (previously worked only with IP)

I don’t have HA Cloud, so I cannot test for that.


Sounds promising, @keyd!
Shouldn’t USBimager work also on Ununtu?
I’ll give it a try tomorrow evening (out of home until then).

I’ll keep you posted.

This sounds promising indeed ! Thanks @keydi for letting us know !

This also highlight the potential correlation between the freezing at 31% and the DNS failures, as I mentionned above - but I might still be totally wrong lol.

On the webpage he linked, it doesnt say anything other than “linux” so I assume it might work.

Will try the same this evening and keep you posted as well !


I have successfully connected to HA via ZeroTier One from the outside of my home network, so network-wise everything seems good so far.

Lol - it legit worked. I had literally 0 hope of resolving that but it actually worked.

Thanks A LOT @keydi !!!

Met.no works, radio works, hacs install is currently going on - I am SO relieved !

@Damos, I confirm it works on Ubuntu LTS - please download USBimager Ubuntu LTS version, then open it with the native software installer from Ubuntu. Ping me if you need any help !

@keydi, thanks again and @all thanks everyone for your shot at trying to help that f*cking issue !


Wow - love the energy here.

So is this the case where there might be compatibility issues with Balena Etcher and HAOS, so that if we use USBImager instead of Balena Etcher, we would be fine?

In my opinion (and experience) it’s a little bit more convoluted than just “Balena Etcher + HAOS” issue. According to my experience, it’s rather “HAOS + Balena Etcher on live Linux booted from SD/USB + flashing SSD on thin-client-like hardware”:

  • I’ve used Etcher on Windows to flash HAOS to SD/USB (but not SDD) → no freezing
  • I’ve used Etcher on live Linux to flash HAOS to USB (but not SDD) → no freezing

But Etcher on live Linux flashing HAOS to SDD → freezing of OS.

1 Like


I concur with Keydi’s conclusions. This seems to be this very specific set of inputs that lead to the issue.

1 Like