Force removal of z-wave node


#1

Hello!

I have a failed node. I have done a hard-reset of the node.
When I try to force a removal of the failed node I get the following in the OZW_log.

Detail, Node006, Queuing (Controller) Remove Failed Node
Info, ControllerCommand_RemoveFailedNode
Detail, contrlr, Queuing (Command) ControllerCommand_RemoveFailedNode: 0x01, 0x05, 0x00, 0x61, 0x06, 0x0f, 0x92
Detail, Notification: ControllerCommand - Starting
Detail,
Info, contrlr, Sending (Command) message (Callback ID=0x0f, Expected Reply=0x61) - ControllerCommand_RemoveFailedNode: 0x01, 0x05, 0x00, 0x61, 0x06, 0x0f, 0x92
Detail, contrlr, Received: 0x01, 0x04, 0x01, 0x61, 0x08, 0x93
Detail,
Warning, contrlr, WARNING: Received reply to FUNC_ID_ZW_REMOVE_FAILED_NODE_ID - Node not found
Detail, Node147, Expected callbackId was received
Detail, Node147, Message transaction complete
Detail,
Detail, contrlr, Removing current message
Detail, Notification: ControllerCommand - Failed

How can I get rid of the node?..

This is how it looks in UI:

//Sam


#2

Have you restarted HA?


#3

Many times… :slight_smile: Updated to 0.64.0, deleted zwcfg, removed all enteries in .yaml - files I have manually added.


#4

Ah, I just did a new try. I did the same things this time. Tried “remove failed node” - command, reset the device. I also did a remove node. Then it finally disappeared. And I could include it again.
Maybe its related to the update to 0.64, was on 0.63.3 before.
:tada:

But anyways, any idea why it didn’t work?..

Next question: The newly included node got id 17, before it was on node id 6. Can I possibly change the node id? Or what is a good practice to use in scripts, to eliminate the need of changing node id’s when a node fail?


#5

You cannot change the node id unless you hard reset the controller and start all over again.
Within HA you should only need the entity id of the device and since a few releases, the entity id should not contain the node id anymore (look at the “new_entity_id” attribute on the dev-state page (<>).

Sebastian


#6

Remove Failed Node only works if the device is marked is_failed: true


#7

Hi,
I have the same issue. I can’t remove a failed node.
I rebooted HA, I tried “Remove failes node”

The device is marked is_failed: true

How can I remove that node ? perhaps with modifications in some files ? but I don’t know wich one …

2018-02-02_0932422018-03-02_102401


#8

Did you restart HA after you selected the node and used Remove Failed Node?


#9

Hello,

thank you for your answer.

Yes I restarted HA but unfortunately the device stays.

Is there another way to delete the device ?


#10

Not really. You can factory reset the Z-Wave stick, but that wipes all the devices from the controller. The other option is to ignore it by using the control panel to exclude the individual entities.


#11

Thanks for your advices! :slight_smile:

I just digged into this again, and I found this:

I have two Telldus - plugs, node 12 and 13… The new_entity_id and old_entity_id are equal. How do I adress those nodes in a configuration without pointing to the node id?

Thanks!

//Sam


#12

Do you have

zwave:
  [...]
  new_entity_ids: true

in your configuration.yaml?


#13

No I havnt got that… Shuldn’t t be opt-out?
I’ll try!


#14

The screenshot shows your actual setup? If so, you can see that the old entity id has an added _12 or _13 representing the node id - and the new entity id doesn’t.
Since the names are identical otherwise, HA starts enumerating them and you get telldus_..._switch as the name for the first device and telldus_..._switch_2 for the second one.
To make your life easier, you should assign more descriptive names to those nodes using the “rename node” function from the zwave configuration panel. For example, you could call one telldus_kitchen and the other one telldus_livingroom.
Since the names then differ, HA won’t add any numbers to it and you will always be able to refer to the device using this name.

Sebastian


#15

Thank you for your answer.

It’s a workaround and it could be fine that the functionality remove failed node works :slight smile:


#16

Ignore them. They’re attributes that don’t matter at all.


#17

I had 4 nodes that were bogus, they were from previous failed attempts to include devices. I had tried to remove them in the past with no success. I decided to try again today. I did a “remove failed node” on all 4 of the bad nodes, then restarted home assistant through Configuration–>General–>Restart.

Only 1 was removed.

I repeated the process with the remaining 3 nodes, “remove failed node” on all 3 followed by the same restart. Another node was removed.

I then repeated with the remaining 2 nodes, again one was removed.

Now I have 1 bad node and it won’t seem to go away.


#18

Here is what I tried and works for me. But it’s a pain in the a**.

Go to Configuration -> Customization -> your device (zwave)
Change the attribute is_failed to true.
I also change the attribute is_ready to false and is_awake to false
Restart HA.
Double check if HA takes these changes.
Go to Configuration -> Z-Wave -> Entity : Your device
Hit Refresh Node, if it take more than a couple of seconds to execute, then it’s working. If it finished immediately, not good. double check the attribute change.
then Hit Remove Failed Node, it should take a moment.
Hit Refresh Node and Remove Failed Node again and again until it finishes immediately.
Restart HA

The bad node should be removed from HA.

Not sure why it’s such a pain in the butt, but I’ve tried it 3 time in my pi and it works.


Horstmann/Secure SRT-321 Thermostat - Zwave
#19

I managed to remove the node also by just trying and trying again to remove the node. It’s finally gone, but in the Z-Wave integrations there’s still an entry that I can’t get rid of. I’m guessing it’s a db entry and that there’s no code to clean it up after removed nodes.


#20

I have this issue too @seanodell …is there any solution to it ? Have you tried deleting the integration and allowing discovery to find it again ?