Fresh Installation Stuck on Preparing HA

For anyone with the same problem, I used the command date inside the SSH Acess and changed it to the current one and then the instllation went fine.

Excellent that you got it sorted out :+1:t3:

So the culprit unable to succeed with the final installation steps was indeed a wrong system time/clock settings on your RPI but not a firewall issue.

Hey Alex, I’m not all that tech proficient so bear with me.

I’m getting the same errors and want to check if this solution works for me. I installed on an SD card through Raspberry Pi imager.

What do I type into the command line for my RPI? I tried typing

ha > timedatectl | grep Time now

but it says that it’s an unknown command.

Again, very novice here for any kind of coding so let me know what logs I can post to help troubleshooting.


type exit to go back to ha >


I have no way to get this command working…

I’ve also tried with (I think the command belongs to the ‘login’ environment)

But I get this:

If I try this:

I get:

I’m connected directly to my odroid via monitor+keyboard and the initial problem I have is about the certificate that afterwards throws the no-connection as you describe:

I’ve solved it by:


#date -s "yyyy-mm-dd hh:mm:ss"

then supervisor could accept a certificate and proceed with the installation.


I’m having this issue (or a very similar one): Stuck on Preparing Home Assistant with a fresh installation and I just tried this solution (changing the date manually in the CLI) but when I try to restart the host to make it work the time date is changed back to a wrong one. I don’t know if I’m doing something wrong, but it is not working for me.

Pi has no RTC so it needs setting on each boot.

hi i have same problem im from iran and i dont kmow its becuse my country internet problem or not
how can i be sure i have acses to home assistant iestalation server
sorry for my bad typing

Can you explain the exact command to run I am stuck on this error too?

I did this change but it errored if I put " around the time format so I removed those and there was no response after typing in the command. Do I need to reboot the system or something to get it to finish installing now?

Hi there.

I had the same problem.
I have been able to fix this by just removing the port triggers / nat , in my router on the Raspbarry pi.
did i help someone with this tip?

B.r. The-Master

How did you change the date?

Hey there,
some time has passed since the OP opened this thread, but since I seemed to be stuck with this issue even today (with HAOS v11.4) and was unable to find some help on this issue, I created an account to help others that might face the same issues.
I was having the same problem when starting up HAOS for the first time, was landing here and could by no means change the timezone settings due to this goddamn read-only error.
What helped me out eventually, was searching for exactly this issue: “SD card read only”…
This led me to the good old Windows terminal with the following commands which removed the write protection on my SD card (… without buying a new one!).

Here they are (requires an elevated Command prompt):

  1. start DiskPart
  1. find the correct volume (hint: check the size value that matches the card)
list disk
  1. select the correct volume (let’s assume it is number 1)
select disk 1
  1. remove the write protection
attributes disk clear readonly
  1. Done! Put the SD back into your RaspPi (or whatever) and (hopefully) see the Setup screen as it should be.

Hope this helps some of you guys!

Peace out :slight_smile:

I had same error and setting date in HA console (script below) solved the issue temporarily. I say temporarily because as HA don’t get to syncronize date time by NTP (every time raspberry it is reset) and rapberry do not has RTC, if raspberry is disconnected several times or for a long time, this datetime is desfased and I have to run the command again.

date -s "yyyy-mm-dd hh:mm:ss"