Friendly name editing in Lovelace UI

Thanks for indulging this newbie. I was confused because you have the Brightness control element and additional metadata for your Aeotec bulb in your entity card but I didn’t see anything for my Aeotec shutter. Re-read the Lovelace documentation and I see I can display that with the service and secondary_info tags.

I am VERY new here too. I have been running/learing in a VirtualBox VM on my laptop.
Tonight I get to start work on a Raspberry Pi for this, I hope.


I do not have that option (hassio latest version) - the gear in the upper right.
What can be wrong, Where should I check?

That option is only available for platforms that provided an unique ID in the code.

OK, how do I get to upgrade/update my hassio to support this? I really do not know this and I would like to have this feature instead of going all the time to Customization

You don’t.

This is something that needs to be done in the platform code.

My issue is I use to have the capability to edit friendly names from upper right corner of entities (42 ). Now it is gone for some entities, not sure why.
This one has:
This one, not:

You can always use the Entity Register to edit friendly names.

True, Entity Register or Customization works fine - but still it is an unknown for me why I can directly edit some sensors from Lovelace and some not

I told you that here and here

Did not get it, sorry.
If you look at the above pictures you’ll see two sensors, both battery type (not plaato), first having the capability to directly edit the Friendly name and second one not.
You are saying that I HA is not assigning unique ID to the second one and this is why the gear is missing?

Correct, the first one is from the ios integration, that has added logic for unique IDs, I’m not sure where the second comes from but since it does not have that icon, there is no logic to create unique IDs for that platforms.

Thanks a lot. Now it make sense and I know where to look.
The second one it is a Fibaro Zwave Flood sensor integrated with HA using Aeon Labs stick.

I’m using Home Assistant 0.104.2 Hassio.

My nmap device_tracker.[mac_address] entities do not have the gear nor do they show up in entities. When I used version 98.5 it was the same, so I had to put friendly names in customize.yaml. I tried the same thing in 104.2 and the configutation.yaml wouldn’t validate after I put

customize: !include customize.yaml

using the same customize file as 98.5. So I don’t get where to include the customizations in 104.2.

I eventually edited the “known_devices.yaml” file to change the name there and that worked.

Configuration, customization, select the device/entity and edit the attribute you want.

Awesome @flamingm0e! I’m just moving on up from 98.5 to 104.2 and finding things has been consuming a lot of time. Thank you.

I finally got my customization file to work after reading a post about it requiring the “homeassistant:” header in the config file.

I’ll have to look up how to set the icon using Configuration/customization page because when I brought up the attribute “icon” to change, it gave me a message saying it was not set, but then it wouldn’t take anything I typed into the field with the word Icon in it. I’ll figure it out because it must be UBD (user brain damage) !!

Always appreciate the help.

It’s the same format as manually inputting it into your customize.yaml. mdi:nameoficon You can get the name of icon from

Thanks. I use all the mdi icons so I was surprised when it said:

The following attributes weren’t set. Set them if you like.


even though the bulb appeared in the box. Each time I save it, I get the same message. So it must be me doing it wrong. I’ll get it - this is closer than I was.

I also plan to put pictures of people as their icons so once I figure this out, that’s next. I haven’t found out where to put the jpg or png file yet though.

You do have a customize.yaml file in the same directory as configuration.yaml? and you have a line in configuration that says to include it for customize?

If you create a www directory and drop them in there, you can reach the images at https://urlofyourhomeassistant:8123/local/nameofpicturefile.jpg

Hope you don’t mind me jumping in on this thread. I’ve just come across this, and it has (partly) answered a question I have been trying to answer by searching, but without success.
So, I need to create a ‘www’ directory for image files, but where does it need to be, please?