Google Assistant and covers

Hi Marthocoo

I had similar configuration to control my garage door through google assistant. It was working fine with my old Home Assistant install, however once I upgraded my HA (0.78), the API calls are failing. It gives me 401 unauthorized error.

Reading up on it, it looks like the legacy api_password method is not supported anymore. Have you experienced the same issue? If so, do you have a working solution?

Please share the steps to make it work again.

Thank you

this works for me in the following format: https://[your publicly accessible HASS url]api/services/cover/open_cover?api_password=[your HA API key]

Hi all,

I’ve followed your istruction setting up covers as lights using customize domain:

      google_assistant: true
      google_assistant_type: light

I can see that HA has this new attribute looking at the cover proprierties:

current_position: 0
friendly_name: Tapparella Stanza da Letto
supported_features: 11
google_assistant: true
google_assistant_type: light

But in my GH app covers appears still as switches.

Can someone please support me?

It seems Google added native support for blinds and shades.

I guess it should be easy to change how the covers are being synchronized with Google Home to be shown properly.

Direct link to developer documentation

I’m sure it’s coming soon™

I have requested this already, but don’t think it’s in development yet… Don’t think much code needs to be changed, it’s basically the same as a switch

1 Like

PR is coming!
support for blinds/covers => open/close


Are you able to open/close blinds in google routine after exposing them as blinds?

I have updated to 0.91, and my covers are now exposed in the google home app (but with a weird gear icon on top of the blinds icon?) But if I ask google to “open all blinds”, she replies “sorry, there was an error with the all blinds” and nothing happens
Has anyone got this working?
This is my covers from configuration.yaml:

    - platform: template
          friendly_name: "All blinds"
          position_template: 50 
              service: script.all_blinds_up
              service: script.all_blinds_down
              service: script.all_blinds_pause

Solved : I removed the line "position_template: 50 " from the above, and it works well now!
(leaving this here in case anyone else has the same issue!)

Or just used the timed cover from here:

With the new changes in custom component locations, I needed to change the template cover to timedcover and relocate it to:


commands like “set cover to %50” does work here with google assistant now. formerly it was working only with siri.

The configuration is this:

  - platform: timedcover
        friendly_name: 'Right Cover'
          service: switch.turn_on
          entity_id: switch.study_cover_right
          service: switch.turn_off
          entity_id: switch.study_cover_right
          service: switch.turn_on
          entity_id: switch.study_cover_stop               
        opening_time: 45
        closing_time: 45

Seems my cover are not working anymore, since I have stateless covers, already created issue on GitHub
… Your covers have a state? Like open/ close in Ha?

Yes, they are either “open” or “closed” in HA. They are controlled by a broadlink RMPro issuing IR commands learnt from the blind’s remote.

Ah ok, then it should work, mine are not, I send tcp command, so HA doesn’t know the state

I had my garage door working for well, along time but recently I stopped getting confirmation that the door was opening or closing. then it stopped working completely. Google Assistant now says the device is incompatible with command or something to that effect and in the home app looks like the attached picture

How can I get this working again? I had a mapped routine so that I could say open my garage door and Google would actually do the command turn on my garage door

yes, the cover domain, is not working correctly if you have stateless covers
this is been fixed, and will be merged in a new HA release

also the garage door will be a new trait in newer release HA

Ok lol I had a thought as I was writing the above question. I had as a work around when Google used to treat the door as switch, a routine that basically translated open my garage door to the command Turn On my garage door. Since Google now supports the open command I had to simply remove the routine and it worked when I said open the garage door…I downgraded to each of the previous builds of HA to trouble shoot… There’s 45 minutes I’m never getting back lol

:slight_smile: good it worked

Google assistant is now telling me that I have not set a code for the Garage lol Anyone got around this? I think classifying as a switch instead will do the trick but I kinda like how google classified it as a garage door with the icon and all :slight_smile:

isnt that a setting? if i go to HA cloud google config (nabu casa) , its default disabled, maybe you enabled that?

This integration requires a Google Assistant-enabled device like the Google Home or Android phone.

Please enter a pin to interact with security devices. Security devices are doors, garage doors and locks. You will be asked to say/enter this pin when interacting with such devices via Google Assistant.