Google Assistant Setup Issue - "Could not update the setting. Please check your connection"

Another project having this issue.

I deleted the google console project and restarted from scratch. Didn’t change a thing other than updating the app id in hass config since google assigned me a new one. Same token, client id, etc and working.

Not sure what the issue is, but I am having a similar issue… If I need to do something special because of being in a virtual environment… or perhaps its related to previously having the emulated hue open through port 80 (but emulated hue is no longer in my config).

Just going to keep checking this forum!

Does your mobile device have more than one Google account configured?

I’ve found that it works better if you only have the google home account on the device you’re using, and that includes the browser that it will use to authenticate.

1 Like

That is correct… perhaps I will configure from different device and see what results I get. Thanks for the tip!

*** this resolved my issue. *** I reformatted an old tablet to use only the account associated with my google home account.

To anyone experiencing this issue I appear to have found one of the causes for the “Could not update the setting. Please check your connection” error. It seems certain entities in home assistant will cause this error to appear even if there isn’t a connection problem. To eliminate this being a cause set expose by default to false then specify individual entities to expose. Examples below:

  project_id: !secret project_id
  client_id: !secret assistant_id
  access_token: !secret assistant_token
  expose_by_default: false


    google_assistant: true
    google_assistant_name: light one

This is indeed the issue. On my work phone (which has two accounts) I can’t get it done. Needed to take a tablet that just had my private account and it worked (had to try twice for some reason)

So if I wanted to control the off and on state of my account reciever, how would I do that?

I tried it, and I’m still getting the issue… Any ideas?

Ive tried all the suggestions in this thread, but none of them have fixed it for me. ive tried the method of switching to a different wifi network… ive tried expose by default, ive tried using a different phone with only one google account, but it isnt working… anyone have a fix?

I don´t know if is the same error but when I click the test app he redirects me to, I have all the ports forward, I´ve installed duckdns addon with let´s encrypt and show me this error : "this site can´t be reached tooktoo long to respond try: check the connection

I don’t think google assistant supports custom ports so you will likely need to map port 8123 internally to port 443 externally. In the project.json file make sure the address is

It works fine with custom ports, I don’t use port 443 and Google Assistant works for me.

1 Like

I restart all the process and now when o click to add the my test app it sends me to error 500, the server encoutered an error and could not complete you request

I was reading some threads in other foruns and here jn brazil we heve an isp called netvirtua and some people are saying that they’re blocking some ports like 443 from their datacenter, anyone knows how to by pass this? Anyone had the same experience?

+1 Same here.
Nothing here resolved the thing.

As I said a few posts up, you don’t have to use port 443 - a custom port is fine.

Unfortunetly i lt didnt work duckdns addon its not working if i set true to lets encrypt, also if I just let duckdns working from time to time my hassio looses conection and I need to enter through hassio.local or reboot via ssh very strange

edit: I don´t know what i did but it seems to be working duckdns and let´s encrypt since now I have to navigate through and not “http” anymore, but when I push my app test on home control it redirects me to a black page with a {“message”: “missing project_id in redirect_uri”}

any clue?

So I still haven’t got this to work… but maybe this will help others debug this…

Looking at my log files I see the auth request go through ok:

Nov 03 10:17:27 hass hass[2299]: 2017-11-03 10:17:27 INFO (MainThread) [homeassistant.components.http] Serving /api/google_assistant/auth to x.x.x.x (auth: False)
Nov 03 10:17:27 hass hass[2299]: 2017-11-03 10:17:27 INFO (MainThread) [homeassistant.components.google_assistant.auth] user login in from Google Assistant

But I do not see a follow up request (I simulated one to see what it looked like):

$ curl -X POST -i -H 'Authorization: Bearer ACCESSTOKENFROMCONFIGFILE' -d '{"inputs":[{"intent": "action.devices.SYNC"}], "requestId": "123"}'
HTTP/1.1 200 OK
Date: Fri, 03 Nov 2017 09:54:17 GMT
Server: Python/3.4 aiohttp/2.2.5
Content-Type: application/json
Content-Length: 318

{"payload": {"devices": [{"id": "light.tall", "name": {"name": "tall"}, "traits": ["action.devices.traits.OnOff", "action.devices.traits.ColorSpectrum", "action.devices.traits.Brightness", "action.devices.traits.ColorTemperature"], "type": "action.devices.types.LIGHT", "willReportState": false}]}, "requestId": "123"}

Nov 03 10:11:44 hass hass[2299]: 2017-11-03 10:11:44 INFO (MainThread) [homeassistant.components.http] Serving /api/google_assistant to x.x.x.x (auth: False)

If you see that follow up request, maybe you can run that curl command and see if something looks off, like maybe your config isn’t filtering the right devices.

Because I am not seeing the follow up request after a successful auth, I suspect something is funny with my gactions project json config where the follow up automation url is… I’m wondering which fields in that are set to “automation” maybe don’t match the correct invocation / project names from the setup page… Can someone who has it working paste their project json and a screenshot of the google assistant config console page?

im not even getting that error which is weird… its like the google assistant app on my phone wont even connect…