Google Maps location sharing - New thread


#81

Not working for me on a Docker build of HASS on 0.76.

Getting “Could not open pickle file, either file does not exist or no read access.” as error. There’s a .cookie file that’s created, so what’s wrong? Already tried to remove it, and it just creates a new one.


#82

Hello everyone.

After last update, currently v0.77.3, the component just stopped working. I was stupid enoguh not to check on breaking changes, so I went on and deleted the cookie file and modified known_devices.yaml.
To my surprise, this time it didn´t fix things, because known_devices.yaml is not supported anymore!!!

Now, (I think) there´s no way to reset things. Does anyone have a workaround??


#83

Hello, did you find any solution, same here :frowning:


#84

Hardly in only two hours…


#85

Try deleting or editing the core.entity_registry in the .storage folder of the config directory.

I needed to this since i still had some old devices that i couldn’t get rid of since known_devices is not used anymore


#86

Where this is documented?
I looked through the 77.3 changes ( I thought)…


#87

Hello again
Since my last post, I´ve been unable to make the component work again. There´s no prompt to authorize in GMaps, no error log, no nothing. Can anybody give any advice at all?


#88

i am in the same boat unable to get it to working… any updates on your side ?


#89

I ran into the issue with the latest version, the issue i was noticing is locationsharinglib requires beautifulsoup4 (version 4.6.0) but 4.6.3 is installed.

I found this out trying to manually create the cookie by running SSH and doing the following:

get-maps-cookies -e EMAIL -p PASSWORD -c FILENAME

which i get an error saying the locationsharinglib requires beautifulsoup4 v==4.6.0 but sees v==4.6.3 and fails.

what i did was run ‘pip install locationsharinglib’
which uninstalled and reinstalled beautifulsoup4 and put the version to 4.6.0

than reran the get-maps-cookies, which than showed the device in the recently used under google. deleted the cookie and restarted hassio, which updated the beautifulsoup4 to 4.6.3 and my google account still authenticated.

This worked for me, but i don’t know if it will for anyone else, and of course i take no responsibility for any issues this may cause


#90

In the latest locationsharinglib update i.e 3.0.2 battery level and charging status has been added. but I’m not able to see the same in my home assistant sensor. is there any special configuration that i need to do ?

Can any one please help !!


#91

any one got this working on hassOs?


#92

Works for me in HassOS. It’s not the greatest for location accuracy but it does work.


#93

will you help me out… did you manually added google_maps.py in custom_components ? what version ur at? i don’t see any error but nothing is created in known_devices file…


#94

No custom components. Only followed the instructions here: https://www.home-assistant.io/components/device_tracker.google_maps/


#95

Hey, did you need to manually generate a .conf file?

I have an error about invalid cookies and I don’t see any device activity to approve but I think this might be related to account security.


#96

you should not need to manually generate a .conf file.

did you:

  1. login with your new account and approved your login on the Device Activity page. (took 30 min for me)
  2. Reboot HA 2 times? (I needed to reboot to let the cookie to be created, a second time so that the component could find it i assume)

#97

Any help on this :point_up_2: please.


#98

Hmmm. I can confirm that I saw multiple reboots were needed.
After the first reboot I get a cookies file and the pickle warning is gone. After the second one I am still seeing an issue with the cookies file. I think my validation is not working, I’m going to test locationsharinglib in python and ill report back.


#99

I just updated to version 0.79.3 to see if something changes. I also cannot find the battery level.

I am learning to find my way around Github and have done the following:

  • found the component here
  • See in the code that it requests the new version: “REQUIREMENTS = [‘locationsharinglib==3.0.3’]”
  • Which was merged on 1 Oct.

How can I see in Github in which version this merge was published?


#100

I think this is the master which is still 2.011. On HA website -> Components search Google Maps Location Sharing -> on the top right side you will see the link. Source: device_tracker/google_maps.py

/blob/master

REQUIREMENTS = [‘locationsharinglib==2.0.11’]

This link you posted above is dev. on the link it has /blob/dev

REQUIREMENTS = [‘locationsharinglib==3.0.3’]