Google Maps location sharing - New thread


#101

Been at this for several days with no success.
Running Hass.io and have tried to follow the https://www.home-assistant.io/components/device_tracker.google_maps/ . Also read through the forums with no luck there either.

Its in my IMHO this services is broken within Hass.io. Installation should be straight forward. However, they are not. Here is how I see it; I love that car, but in order to drive that car I need to build from ground up before it can be driven. What I’m getting to is this, shouldn’t be rocket science.


#102

I agree, this shouldn’t be that complicated, been on this for several days as well, still nothing.
The cookie file gets created but no login attempt on the account, no error in HA…


#103

In can confirm this.
I have the same behaviour here.

No login attempt and no error logs, but cookie was created.


#104

Same issue here. Setup a new install last night as a first time user migrating from smartthings. Have a lot of things working but tried to do location tonight and nothing ive found anywhere is helping. The cookie file gets created but no login is ever attempted to the account (even after a couple hours and several reboots.


#105

Some more info for Hass.io and Google Maps.

Following the process from: https://www.home-assistant.io/components/device_tracker.google_maps/

Link to google_maps.py: https://github.com/home-assistant/home-assistant/blob/master/homeassistant/components/device_tracker/google_maps.py
has “REQUIREMENTS = [‘locationsharinglib==2.0.11’]” in the file.

installed : pip install locationsharinglib
(FYI - to access Hass.io docker: sudo docker exec -it homeassistant /bin/bash )

Last but least. Hass.io seems to be over writing packages after each restart.

As you can see, beautifulsoup4-4.6.0 gets updated after Hass.io restarted to 4-4.6.3.
Is Hass.io overwriting packages. Good chance.

I’m still not able see any login attempts into Google to validate the new device/HA.

  • New Google account setup. (2-step is disabled)
  • Have mine and wife’s google maps sharing location to the new Google account. ( I can see both devices on Google Maps when logging in directly.

After following the HA Google Maps process:

Thu Oct 11 2018 11:15:53 GMT-0400 (Eastern Daylight Time)


#106

I had the same issue (no login attempt and no new known_devices) after setup
After I upgraded to 0.80.0 I get the following error:

home-assistant   | 2018-10-13 18:57:35 ERROR (MainThread) [homeassistant.components.device_tracker] Error setting up platform google_maps
home-assistant   | Traceback (most recent call last):
home-assistant   |   File "/usr/src/app/homeassistant/components/device_tracker/__init__.py", line 184, in async_setup_platform
home-assistant   |     disc_info)
home-assistant   |   File "/usr/local/lib/python3.6/concurrent/futures/thread.py", line 56, in run
home-assistant   |     result = self.fn(*self.args, **self.kwargs)
home-assistant   |   File "/usr/src/app/homeassistant/components/device_tracker/google_maps.py", line 46, in setup_scanner
home-assistant   |     scanner = GoogleMapsScanner(hass, config, see)
home-assistant   |   File "/usr/src/app/homeassistant/components/device_tracker/google_maps.py", line 66, in __init__
home-assistant   |     self._update_info()
home-assistant   |   File "/usr/src/app/homeassistant/components/device_tracker/google_maps.py", line 78, in _update_info
home-assistant   |     for person in self.service.get_all_people():
home-assistant   |   File "/usr/local/lib/python3.6/site-packages/locationsharinglib/locationsharinglib.py", line 459, in get_all_people
home-assistant   |     people = self.get_shared_people() + [self.get_authenticated_person()]
home-assistant   |   File "/usr/local/lib/python3.6/site-packages/locationsharinglib/locationsharinglib.py", line 421, in get_shared_people
home-assistant   |     for info in output[0]:
home-assistant   | TypeError: 'NoneType' object is not iterable

#107

Same issue for me. Cookie gets created and no logon visible on Google dashboard.

        Sat Oct 13 2018 19:28:32 GMT+0300 (EEST)

    Error setting up platform google_maps
    Traceback (most recent call last):
      File "/usr/local/lib/python3.6/site-packages/homeassistant/components/device_tracker/__init__.py", line 184, in async_setup_platform
        disc_info)
      File "/usr/local/lib/python3.6/concurrent/futures/thread.py", line 56, in run
        result = self.fn(*self.args, **self.kwargs)
      File "/usr/local/lib/python3.6/site-packages/homeassistant/components/device_tracker/google_maps.py", line 46, in setup_scanner
        scanner = GoogleMapsScanner(hass, config, see)
      File "/usr/local/lib/python3.6/site-packages/homeassistant/components/device_tracker/google_maps.py", line 66, in __init__
        self._update_info()
      File "/usr/local/lib/python3.6/site-packages/homeassistant/components/device_tracker/google_maps.py", line 78, in _update_info
        for person in self.service.get_all_people():
      File "/usr/local/lib/python3.6/site-packages/locationsharinglib/locationsharinglib.py", line 459, in get_all_people
        people = self.get_shared_people() + [self.get_authenticated_person()]
      File "/usr/local/lib/python3.6/site-packages/locationsharinglib/locationsharinglib.py", line 421, in get_shared_people
        for info in output[0]:
    TypeError: 'NoneType' object is not iterable

#108

I’ve submitted a new issue


#109

the problem is with the function that returns all people,
it returns shared people + authenticated person:
people = self.get_shared_people() + [self.get_authenticated_person()]

the problem with that is the authenticated person returns None at array index [13] which fails it,
to fix it updated google_maps.py to use get_shared_people instead of get_all_people


#110

…i’m rewriting locationsharinglib a bit…maybe more than a bit…

might need some help cleaning up the code to make it integrate with HA once i get the output all nice and clean.

gonna see about my buddy sharing his location info with me as well so i can see how that changes the output for multiple people…

but yeah. i don’t like the way it was doing the login (or rather lack thereof). right now i got it working going another route and playing very well with 2FA via phone notification.


#111

on my output, index[13] appears to be a 43 character alphanumeric string…


#112

My location sharing via Google Maps also stopped working with the 0.80 HA release.
I appreciate all of you who are technical who can figure out why and how to fix this for any upcoming releases.
Not only does the Google Maps location sharing not work anymore, but the battery charge level is a no-go, too.
Thanks.


#113

come to papa


#114

Hello all

Any news on this?


#115

I am still having issues as well.


#116

This would be great if we could get it going again!


#117

I’m having the same error in the H.A log, any solution?


#118

I’m now running 0.81.0 of Hass.io.
My google maps is working, and it shows the battery and charging.


#119

Hi, sorry to ask but I want to know that if your location sharing via Google Maps working correctly now or not ?
And anyone else still have issues with it ?


#120

I’m now on HA Version 0.81.1.
Location sharing via Google Maps is working well for me.
As you likely know, you need to set up a “dummy” account on Google, and link that dummy account to track “you”, and link that dummy account to your HA to actually track you.
Best of luck!