[Guide] Control LightwaveRF (Gen 1) in Home Assistant using RFXCOM

I thought I’d throw a little guide together about how I have integrated LightwaveRF devices into my Home Assistant setup. I know there a number of people already doing it this way, but I thought I would create a post in the hope it might help others.

For those of you unfamiliar with LightwaveRF, it is an automation company based in the UK, who provide cheap and simple home automation tech. One of the nice things about their solution is that they provide wall switches as direct, drop-in replacements for your normal light switches. This greatly helps with the PAF! (partner acceptance factor.)

Please note. This guide only applies to Gen 1 devices. LightwaveRF have recently released a new set of devices (Gen 2) which are HomeKit compatible. These are not running on the same 433Mhz band and are not controllable in the same way.

What you will need/reources:


  1. Download and install RFXCom manager on to your Windows PC and plugin the device.

  2. Launch the RFXCom Manager app:

  3. Click the connect icon in the menu bar:

  4. Select the device from your USB COM port list:

  5. Next, you should see in the yellow text below the transceiver types that have been setup already on your RFXCOM device. De-select the ones you don’t want to use and select the “AD/LightwaveRF” profile. Click “Set Mode” to set the profile. Once this is done, you can check again by pressing “Get Status”. Check that it shows up in the yellow text at the bottom of the screen:

  6. Next, you will want to grab the IDs of one of your devices to test.
    The easiest way to do this is to use the app to sniff the LightwaveRF traffic. Trigger one of your light switches to on, and you should see it’s information pop-up in the yellow text below.
    Note the ID, Unit Code and decimal info.
    You can then use the “Lighting 5” tab to test the RFXCOM device can communicate with your LightwavRF switches by filling in the fields at the top, and hitting “Transmit”:

Now it’s time to disconnect the RFXCOM from your Windows PC and connect it backup to your Raspberry Pi.

  1. Connect to your Raspberry Pi and open up your Hass.io configuration.yaml
    Add the following to communicate with your RFXCOM device:
  device: /dev/serial/by-id/usb-RFXCOM_RFXtrx433_A11I6NWQ-if00-port0
  debug: True
  dummy: False
  1. Check your configuration.yaml file for errors, and restart your device/Home Assistant.
    You should now see your devices show up in the Home Assistant UI when you trigger them from the LightwaveRF app or a nearby remote (pressing the switches themselves doesn’t send an RF signal.)
    Note down the ID shown in the Home Assistant UI, so that we can add these permanently.

  2. Add devices to your configuration.yaml file. Example:

  platform: rfxtrx
  automatic_add: True
      name: Bedroom Light

Replace 0a14000031340001010070 with your device ID.
Again, check your config and restart Home Assistant. You should now see your devices in the Home Assistant UI and be able to control them.

This is by no means a complete, fool proof guide. But I hope it helps someone!


This is a great guide, thank you for writing it. I have successfully updated the firmware of my rfx transceiver and configured it for lightwave. I’m stalling at point number 8. No devices are showing up in HA. I’ve looked in the dev tools states section every time i trigger a light but nothing appears. Is that the right place to look? Also, is the device path in point 7 correct for everyone or do I need to configure according to my setup (if it is different, something I’m not sure of)?

Many thanks,


I got it working adding this to configuration.yaml…

  platform: rfxtrx
  automatic_add: True

  platform: rfxtrx
  automatic_add: True
1 Like

I have successfully configured the RFXTRX platform - it detects an OWL energy monitor and the main ON/OFF switches on an LWRF mood switch. I can’t get it to recognise the smaller mood/scene buttons. Enabling debug mode i can see that HA can see the event of me pressing the mood button, but no new switch is added automatically to HA.

Do you have any advice for successfully using all the buttons on a LWRF mood controller?

Hi Everyone,

Just to say i have created a custom components for LightwaveRF gen 1 devices.
It uses a queuing system to stop any commands not hitting the wifi link.
The lights are fully dimmable as well and it also works well with Alexa and Google home when emulated hue is enabled.
please let me know what you think.


1 Like


In case anyone finds this thread whilst searching the answer to using the mood controller via rfxtrx is in this thread: Automation to react on an rfxtrx event