HA in a VM - can't find USB Z-Wave stick

I’m attempting to migrate from HA Supervised to a VM within VirtualBox.

I have the installation set up and have restored a snapshot from the old installation, and all appears to be present and correct.

But the device for the ZWave.ME USB stick is not appearing. In the supervised installation it appeared in the Hardware listing as /dev/tty/ACM0 and /dev/serial/by-id/usb-0658_0200-if00 but all I get under the Serial heading now is /dev/ttyS0 to /dev/ttyS3. I’ve tried all of those as the path to the USB stick and none of them work. Can anyone help me get it to work?

Did you mount the USB stick to the Virtual machine?

Probably not - how is that done? I didn’t see that in the docs.

Because that’s not part of Home Assistant, that’s about Virtualbox.

I don’t use Virtualbox, I use Proxmox, however a quick google search returned this:


I’m looking at that page and I’ve added my system user to the vboxusers group as it says. Powered off the VM as it says, although my USB settings in VirtualBox have always been USB 2 as that;'s the default and I only made the changes in VirtualBox as described in the Home Assistant documentation. The USB stick is plugged into a USB 2 port. Then powered on the VM. Right-clicked on the USB devices icon as this page says to pick my device from the list, but no devices are shown. Where do I go from here?

I’ve got the VB Extension pack installed.

I’m sorry, as I said I’m not familiar with Virtualbox. Your issue is that somehow virtualbox doesn’t recognize the USB stick, this has nothing to do with Home Assistant. Maybe this post on reddit will help.

It’d be better to ask your question on a virtualbox forum as it has nothing to do with Home Assistant.


That page

That ended up not working for me. I added a post further down that ended up with a scripted process similar to that of the OP.

This isn’t working for me. When I press the green Plus button in the USB Settings of VirtualBox, it says “no devices available”. My host system is Linux. lsusb is able to see the device (it’s the Sigma Designs one):

Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 031: ID 0658:0200 Sigma Designs, Inc. Aeotec Z-Stick Gen5 (ZW090) - UZB
Bus 001 Device 004: ID 040d:3417 VIA Technologies, Inc. 
Bus 001 Device 013: ID 04b4:3003 Cypress Semiconductor Corp. 
Bus 001 Device 012: ID 0458:0024 KYE Systems Corp. (Mouse Systems) 
Bus 001 Device 011: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Not sure if I’ve fixed it yet but I’ve just managed to get the device to appear in the USB settings when I press the Plus button. A post I’ve just seen while browsing suggested that adding the user to the vboxusers group might not actually take effect until you log back in, and this is essential for seeing USB devices in the VM. So I’ve logged out and in again and that bit anyway has worked. [EDIT: Yes, this has persisted, even after a reboot. So thanks to everyone for the pointers]

im having a similar problem. .
when i plug in the sonoff zigbee bridge the pc doesnt even make a ‘ding’ noise indicating something was plugged in . .
if i plug the old zigbee2mqtt dongle in then it goes ding and recognises it.
my pc isnt even recoginising plugging the new device in . . .

Quite normal. Although the sonoff ZigBee bridge has a micro USB port, the only purpose of it is to power the bridge. There are no USB functions attached to the sonoff ZigBee bridge USB port.

thankyou. so if virtualbox cannot see it how can the usb be added to the VM?
how can you add a usb device path to the integration?

The sonoff zigbee bridge is controlled through the network not throug the USB port. I think you also need to flash tasmota on it first. Here’s a guide I saw online that explains it in detail.

ok thanks makes sense. that is why the dongle works out of the box being usb A.
ill flash with tasmota.
thanks all

In virtualbox under the VMs settings you have to go into usb settings find your z-wave stick and actually choose to pass it through to your HA VM

1 Like

Yes, in my case it was because the stick didn’t appear in the VM’s settings, so I thought this was normal and didn’t need to do anything there, I thought it was a HA issue. [Docs didn’t point out that it needs to visible there and needs to be “passed through”]. It seems it’s because the vboxusers group that was added to my user didn’t take effect until after a logout. Long chain of events that need comprehension and understanding here…it needs understanding that the stick needs to be passed through from the Vbox manager through to the HA VM, how to do it and where to look for it and therefore how to recognise when something has gone wrong, what to do if it doesn’t appear, and that a logout is necessary.

Heads up chris I did find passing the usb stick through via the VM settings unreliable… from time to time it would just disappear in the VM. However I’ve found the linux package usbip very reliable. It essentially takes and usb stick connected to the “server” and passes it over your network to a “client”… the client sees the remote usb stick as if it were attached locally

I didn’t know about usbip. That could come in useful in lots of scenarios!